Wakeonlan package no longer available

I was able to install and use the wakeonlan package for a while now - at least whole of last year(probably a lot longer) and earlier this year.
I use openwrt 18.06
Can anyone tell me if I am able to access this package again?


Seems to still be there on 18.06.5 (the device I’m using to check is 3000 miles from me, so I don’t try to do remote updates - can’t test on 18.06.8 at the moment).

Did you update the package list?

I can confirm that it is still available even in the current version (19.07.3), you just need to update the package list.

It's also worth noting that there are two different wake-on-lan packages available (this is from 19.07.3), and there is also luci-app-wol (I can't recall which back-end the LuCI app uses).

# opkg list | grep wake

etherwake - 1.09-4 - You can wake up WOL compliant Computers which have been powered down to sleep mode or start WOL compliant Computers with a BIOS feature. WOL is an abbreviation for Wake-on-LAN. It is a standard that allows you to turn on a computer from another location over a network connection. ether-wake also supports WOL passwords.

wakeonlan - 0.41-1 - With this package you can remotely wake up and power on machines which have motherboards or network cards that support 'Wake-on-Lan' packets. . The tool allows you to wake up a single machine, or a group of machines. . You need the MAC addresses of machines to construct the WOL packets, but, in contrast to 'etherwake', you do not need root privileges to use the program itself as UDP packets are used.

OK, thanks for your help. My bad! Currently, I am actually running 18.06 on Gargoyle. I guess the packages work differently there. I'll post on their forum.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Just to close this out:

  • Gargoyle switched to etherwake and hence wakeonlan is not available
  • Prior to Gargoyle 1.13, it did not support URL redirects and could not follow the HTTP->HTTPS redirect for OpenWrt package repos, so could not find the upstream copy of wakeonlan anyway

Either use etherwake (available natively) or change /etc/opkg.conf to HTTPS addresses to restore opkg functionality.

1 Like