VLAN+WiFi on TP-WPA8631P v4

In another topic, WotC showed screenshots of the VLAN configuration on the TP-WPA8631P v4 range extender.
I'm trying to set up this device, too. I would like to set up the device connected to the main LAN and a second VLAN. The device differs from my other routers in the sense that it doesn't show a native switch0 device. I've been able to create VLANs on the device in different ways (tied to plc0.12, on top of the lan bridge as br-lan.12, a bridge on top of plc0.12) and when I connect the vlan to an ethernet port, all works fine. If I add a wireless network an connect that to the VLAN bridge... it just doesn't work. Best case, the client gets an IP address, but no internet connection. Only if I connect the wireless network to the main (lan) bridge, it works.

I'm just wondering what I'm doing wrong.

part of /etc/config/network:

config device
	option type 'bridge'
	option name 'br-iot'
	option bridge_empty '1'
	list ports 'plc0.12'
	list ports 'eth0.12'

config interface 'iot'
	option proto 'static'
	option device 'br-iot'
	option ipaddr '192.168.222.5'
	option netmask '255.255.255.0'
	option gateway '192.168.222.1'

The part of the dhcp config:

config dhcp 'iot'
	option interface 'iot'
	option start '150'
	option limit '20'
	option leasetime '2h'

...and the wireless config:

	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '3'
	option band '2g'
	option htmode 'HT40'
	option country 'NL'
	option txpower '20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '60'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'
	option country 'NL'
	option txpower '255'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WIRELESS'
	option encryption 'psk2'
	option key 'SECRET'
	option network 'iot'

I'm on version 23.05.3 as 23.05.4 doesn't seem to work.

Any suggestions?

Thanks!

Update: fixed. See VLAN tagged traffic in Mini tutorial for DSA network config.

The trick is:

uci add network bridge-vlan
uci set network.@bridge-vlan[-1].device='br-lan'
uci set network.@bridge-vlan[-1].vlan='1'
uci add_list network.@bridge-vlan[-1].ports='plc0'
uci add_list network.@bridge-vlan[-1].ports='lan1'
uci add_list network.@bridge-vlan[-1].ports='lan2'
uci add_list network.@bridge-vlan[-1].ports='lan3'

uci add network bridge-vlan
uci set network.@bridge-vlan[-1].device='br-lan'
uci set network.@bridge-vlan[-1].vlan='12'
uci add_list network.@bridge-vlan[-1].ports='plc0:t'

network.lan.device='br-lan.1'

uci commit network

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.