VLAN tagging for WAN port for Vodafone UK


I'm having issues configuring my TL-WDR3600 which is on the current stable release to connect to my new ISP. I've moved to Vodafone UK running over CityFibre which from online discussions seems to need VLAN 911 on the WAN interface and a user name and password for PPoE which I've obtained from Vodafone. However despite my best efforts I haven't been able to get a successful connection.

I was skeptical that perhaps the VLAN info wasn't correct, but a wireshark dump from a direct connection to the ONT shows the ID is correct.

I've tried tagging the port as VLAN 911 in the switch configuration section and creating a new VLAN device derived from the WAN port device eth0.2 (ended up being eth0.2.911) which I assigned to the WAN interface, but neither of those or together in combination has given me a successful connection. Hopefully I'm just missing something simple and my inexperience configuring VLANs in OpenWRT is the only issue.

There are several post about Vodafone UK and PPPoE if you search the forum. Maybe one could be of help? VLAN 911 seems correct, not sure about the eth0.2.911 but I don't own that device.

And please search and post relevant entries from the system log the should give at least a hint.

Thanks for the reply, but I've already done my best to scour the forums and larger internet for a working solution and either solutions are from years ago for older builds of OpenWRT which aren't directly transferrable to the current way the configuration works, or aren't directly for my issue it seems. I'll have another go and try and get some logs when I next get chance, unfortunately I can't do both as my internet is down as long as I'm trying to get OpenWRT working.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
1 Like

what's the speed of the Cityfibre connection?

That is not right. For a basic VLAN tag to the modem in this swconfig device, do the following:

  • On the switch page, change the VLAN number on the second line, which is the wan network, from 2 to 911.
  • On the switch page, change the wan physical port from Untagged to Tagged in VLAN 911 (Off in the others)
  • On the Network Interfaces page, edit the wan and change the Device from eth0.2 to eth0.911. Configure pppoe etc as needed.

Thanks for the suggestion @mk24 I'll try that when I have some time where I can take the broadband down while I tinker. If that doesn't work I'll dump the config as suggested by @eduperez. @hecatae I'm on the 500Mb service.

@OmniBlade I'll be interested in the throughput, on stock firmware the WDR3600 manages upto 800 using hardware nat.

So good and bad news, the suggestions from @mk24 worked and I can successfully connect to the internet on my WDR3600, but the bad news is that speed tests max out at around 140Mbps while the vodafone supplied router manages the full 500Mbps+ throughput. Any thoughts on how I can improve the WDR3600 performance?

Head over to firewall, enable software and hardware offload?

That should help I think... your router seems to be very weak... Only a single core at 600Mhz

Hmm, enabling the offload appears to have got me to ~160Mbps down, but I'm seeing 390Mbps+ on upstream? Still not where I want to be so it looks like I'm looking for new hardware? Shame the vodafone hub isn't fully supported, I'm eyeing up a Belkin RT3200 as a possible replacement.

dynalink wrx36 is £77.99 on amazon, half the price of the RT3200 and supported by Openwrt.

Yead idk... from my experience of struggling with SQM on a more powerfull router ( 4 threads 800mhz ) I'd say take some time looking for a beefy router - my current one can only do up to 150Mbps down with SQM ( Tho I am pretty sure that it can easily do 650Mbps with hardware offload and no SQM )

The reason I need SQM is bufferbloat : https://www.waveform.com/tools/bufferbloat

Can you run this test and post results? Depending on how your isp handles bufferbloat you might get away with 10-15$ router ( Xiaomi routers can be found for as low as 10$ , at least for me locally )

Aliexpress has some pretty good deals if you search for newer routers ( Make sure to check in OpenWRT wiki if the router is supported )

The install process for the wrx36 looks a bit involved from the look of the support page?

Booting an initramfs from a usb drive after enabling ssh access looks quite easy.

On closer reading you are right, its multiple processes, not just one long one :smiley: Looks like there is/was an issue with upgrading, but that has fixes in place. Definitely one I will now consider.

@StepSis I got a B on the bufferbloat test FYI.

Share screenshot :smile:

I started with B as well but now it's A+