VLAN tagging for WAN port for Vodafone UK

lol you have inverse of where I started - download good and upload +60ms


I go away for a few days before I plan to order a new router and now it seems the dynalink is out of stock as far as the UK is concerned @hecatae guess you snooze you loose? :sweat_smile:

that was expected, it's being resold on ebay for £20 more that it was being offered on Amazon.

I'm disappointed too. I had my eye on one. Amazon seemed to be the only one stocking them. Hopefully more come in stock or another comparable router becomes available!

I'm going to begrudgingly buy one off of ebay at the scalper price since its still much cheaper than another comparable router that has openwrt support as far as I can tell :frowning:.

That sucks. Not the end of the world though.

I'm going to bide my time. Not in a rush.

1 Like

amazon us may be cheaper:

Hello @mk24. I know I am coming a bit out of the blue here, but I think you might be able to point me in the right direction. I am in a similar position to the original poster. On OpenWRT 22.03 am I right to think that I could add the correct VLAN ID in the LuCI GUI in the network->interfaces->devices tab section. I am missing the 'switch' section and it is my understanding that with the newer DSA enabled OpenWRT builds that the 'switch' section is now moved to the aforementioned section.

What I did to get WAN interface to establish PPPoE connection on the right vlanID was go to Network > Interfaces > Wan > Open WAN settings > click on the devices drop down menu and add a new device wan.enteryourVlanIDhere

That's what you're trying to do as well?

1 Like

Thank you for your response Stepsis. I am moving away from a current FTTC to an FTTP provider who requires a VLAN ID of 911. Not having dealt with VLAN tagging before, my goal is to establish how I will go about adding the VLAN tag on a x86 router running OpenWRT 22.03 before the install day, so that the process is as painless as possible. My current WAN protocol is setup as a DHCP client, so I do not know what options would be presented to me if I change that to PPPoE. Changing and saving settings now, would not only stop my current internet connection from working, but mess with my Adguard DNS and DHCP backend.

Just testing the method that you have suggested if I added an interface: it does not seem to give me an option to add VLAN ID tags.

If the device you wanna use is eth1 , and you wanna add vlan tag to it you need to create virtual device eth1.911

Try that?

Click on the dropdown menu where it says eth1 and add a new device

Your interface will start using the newly created device and tag all traffic going through that interface with vlanID 911...

As simple as that...

I'll send you a picture wait a minute

1 Like

This is what PPPoE protocol looks like - you need pass/username

And other than that nothing else, except knowing if they use vlanID or not ( VlanID 710 in this case )

Internet cable is plugged in wan port of the router... If there were no VlanID you'd simply use wan device , but since there is - new device wan.710 is created

That is what I want to do by going into network->interfaces->devices tab->wan->configure-> VLAN filtering. I have noticed doing so you are able to add VLAN tags. Aren't we basically saying the same thing?

I am not sure... someone more knowledgeable might be able to tell you

This is the standard procedure as far as I know...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.