VLAN... How it works?


I have some trouble to configure my vlans correctly.
Let me explain:
-my LED device is a bt homehub 5.
I dont use anything like router, dhcp or modem. Only as wifi AP and ethernet switch. I set the wan ethernet as a fifth lan port.

-my ISP provide me 2 boxes (so called freebox revolution ") one is the main modem/router, one is for tv.
This tv box is supposed to use vlan 100. I found this on the web, but cannot configure anything on this.

-if I replace the LEDE device with a dummy switch, it works, but with LEDE I cannot make my tv box works, whatever I tried.

-despite this, I have no use of vlans.

I add a couple of screenshots.


I forget to say:
My tv box (vlan100 device) is on port 4
My LAN and modem/router is on port 1. I need both vlan100 for tv but anything else connected to my LEDE device needs also to access lan and internet by port 1.

Port 2&3 are used for other lan device near tv (playstation...)

Turn off VLAN1 to the TV box.


I tried this (tv box on lan4) but doesnt help


I'm not too familar with VLAN, but if a dumb switch works, have you tried configuring your LEDE AP with just the default VLAN only.

1 Like

I tried several stuff :).

If you mean keep only vlan1 all untagged, it's not working.

I also tried "not use vlan".
I mean untick "enable vlan functionnality" and also in network / interface / lan / physical setting, I tried untick switch vlan eth0.1 and enable ethenet swith eth0 instead.
This bricked my device (no more access to settings), so I had to do a "factory reset".

Is there a way to not use vlan and make my device more stupid than it is currently :slight_smile:

When you say "it's not working" I assume you mean you have Internet through the router and that is all OK, but the TV box is not connecting to the provider.

Check that port 4 is really the one physically connected to the TV box by unplugging it and watch the switch icon change from plugged to unplugged. Sometimes the physical port numbering does not match the logical ports.

Connect the TV box to a PC with Wireshark to see which VLAN(s) it is trying to use.

You have not configured the WAN port...where are you receiving VLAN 100???

1 Like

@lleachii is right, you need to receive the packets tagged vlan 100, so the WAN port must be part of this vlan (tagged) and you may need a new LEDE interface bridging the wan.100 to the lan.100 (bridging might be easier than trying to route, particularly if you have multicast IPTV)

1 Like

I didn't notice that. Yes you need 100 tagged to the modem and the TV box. It does not need to go to the router CPU, the router CPU is not interested in TV traffic at all. You're using the hardware switch to pass it through, not the CPU.

1 Like

Good point, the hardware switch should do the job, only need a CPU/software bridge if you want to do any filtering using iptables (you can get bridges to call iptables with a sysctl)

Hi! Thanks for many added suggestions!

I'm not sure but regarding the wan: I use no "wan" function currently.
The port 1 of the switch is the one connected to my lan (over the house), including my isp router.

My lede device wan port is supposed to be converted to a 5th lan port. I read it goes through the cpu, so better use low traffic device here...
Did I go wrong?

I'll try to switch off cpu channel on vlan100 instead of tagged.

I'll also check the port numbering (device marking vs luci display)

Numbering can be wrong. On my router 1 in luci is labeled 4 on the device.

1 Like

Hi there !
Sorry, I was away from my LAN a few days.

Here are the answers:

  • My LAN numbering is ok: port 1 in LEDE/Luci match port 1 marking on the switch (as well as port4).

  • I tried switch off CPU (eth0) on VLAN 100 (see screenshot): not effect. :frowning:


The latest screenshot shows no link on LAN 4, as if there is no cable plugged in.

The port that goes to the modem should be untagged in 1 and tagged in 100.

The port that goes to the TV box should be off in 1 and tagged in 100.

Nothing else connected to 100.

The point is that TV packets, which you think are tagged 100, should flow from the modem to the TV box but otherwise don't need to go anywhere else.

Port1 => Goes to my LAN (including modem)
Port4 => Goes to my TV device.

Sorry for confusion on port4 disconnected, I played with my cables and have done the screesnshot at wrong moment: they are all connected.

I tried to play with wireshark....not easy because it's a pretty complex software.
What I tried is the following:
set port 2 as tagged on VLAN100 and connect my spy PC on port 2.
set a filter on "VLAN" packets.
I can see several "arp" from (seems to be my modem, according to various information I found on google who is also
I can see some packets from (seems to be my TV box, according to various information I found on google).

Here are a correct screenshot of my current switch config, and wireshark



Shall I change something due to this 192.168.27.x ?

Those ARP's appear to be the TV box looking for the modem. There is no reply from, which would likely be the modem.

Is there any other device between port 1 and the modem?

There is a 8port switch (my modem has a 4 port integrated switch, I use an other 8 port to have more port to distribute over the house).

But I can try a direct connection from my LEDE device one of the RJ45 of my modem.

Just modifid my connection: my LEDE device is now directly connected to the modem/router, no more switch in between.
Before it was only 1 dummy switch in between