Very slow WiFi for GB connection

Hello everyone, just installed openwrt for first time. Using netgear r7800 with arris 3.1 8200.
I set up sqm for bufferbloat and still getting +2000ms.
Hardwired to computer from router gets 200mb, WiFi on laptop gets 10mb and WiFi on Apple iPhone gets about 50mb on speed test. Not sure where to go from here

Sounds like your wifi is connected via 2.4ghz only. Post up some of your config and let’s see if we can help, what is the output of the following:

uname -a

cat /etc/config/wireless

cat /etc/config/sqm

--
Netgear r7800 and ZyXEL NBG6817 share the same SOC and are pretty similar overall, close to identical in terms of performance.

I set up both WiFi and set to channels neighbors aren’t using

The details of the above configs will help tremendously. With out the granular details of your config and further details on your clients (what type of iphone, what year of laptop) I am shooting in the dark. :grin:

sorry but im not sure how to enter those commands.. maybe im in over my head.
doesnt work in cmd prompt
and i read a little to use putty.. downloaded that and its a key gen
sorry!

For your iphone the app “terminus” is a good SSH app that can easily log in to your device.

Check your system / administration section in luci (The GUI) and make sure your SSH is turned on. Jump on the terminus app and plug in the router IP, username, and password. I keep a lengthy reference of commands - helps to understand the system better, find information, and share information faster.

Uname lets us know what type of openwrt you have. Cat is a benign command that displays whats in the file you reference. Only put in commands that you know what they do. :sunglasses:

1 Like
root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.180 #0 SMP Sat May 16 18:32:20 2020 armv7l GNU/Linux
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel '40'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Noworries1986-5g'
        option key ''
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option channel '3'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 
        option ssid 'Noworries1986'
        option encryption 'psk2'

root@OpenWrt:~# cat /etc/config/sqm

config queue 'eth1'
        option qdisc_advanced '0'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option linklayer 'ethernet'
        option overhead '44'
        option interface 'eth0'
        option download '600000'
        option upload '40000'

SQM- I have an asymmetric 940/35 connection. (My settings are below)

  1. change the interface to eth0 (eth0 is the default WAN interface). Your current config is performing SQM on the LAN interface (that’s why your rate is lousy via wire)
  2. For a gig connection I found the best result was turning off SQM (with download 0) for docsis 3.1.
  3. the r7800 can handle about 200mbps with cake, 400-500mbps with fq-codel. I found fq-codel to be helpful on the upload side. Cake is great for high power systems or slow connections...I’ve found the r7800 does better with fq-codel.

root@OpenWrt:~# cat /etc/config/sqm

config queue 'eth0'
        option interface 'eth0.2'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option upload '32500'
        option download '0'
        option qdisc 'fq_codel'
        option script 'simplest_tbf.qos'
        option qdisc_advanced '0'
        option linklayer 'ethernet'
        option overhead '22'

Wireless -

  1. for cipher select “force ccmp” - that gets you the best WPA2 encryption
  2. in advanced settings I turn off “allow legacy 802.11b”

Firewall- turn on software offloading

See if your results improve. There are tons of additional tweaks depending on what you are looking for. :sunglasses:

You’re awesome! I’m going to change the settings in a minute. What I’m looking for .. best ping / latency while getting the most download speed out of my 1gig connection. If it means lowering speed to get better bufferbloat that’s fine. Let you know how it help! :ok_hand:

ok weird.. so I went to change WAN interface and I already had it to eth0.. but it showed different in the scan i posted.. i dont know if its not saving correctly somewhere? and I had the download to 500000 not 0.. I changed to fq-codel and left "piece of cake"? selected force ccmp.. and turned off allow legacy 802.11b .. turned on software offloading under firewall..
ill do another scan to see if it changes what i saved ?

did a speed test.. 14down with 5.4up .. +3000 bufferbloat.. this on 2.4ghz on laptop..
another test with iphone 10max 60.5 down 35up.. +7ms on 2.4ghz

root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.180 #0 SMP Sat May 16 18:32:20 2020 armv7l GNU/Linux
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel '40'
        option legacy_rates '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Noworries1986-5g'
        option key ''
        option encryption 'psk2+ccmp'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option channel '3'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key ''
        option ssid 'Noworries1986'
        option encryption 'psk2'

root@OpenWrt:~# cat /etc/config/sqm

config queue 'eth1'
        option qdisc_advanced '0'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option script 'piece_of_cake.qos'
        option linklayer 'ethernet'
        option overhead '44'
        option interface 'eth0'
        option upload '40000'
        option qdisc 'fq_codel'
        option download '500000'

on yours the config queue is 'eth0' & option interface is 'eth0.2'

mine is config queue 'eth1" and interface is 'eth0' ??

My WAN is technically eth0.2. It should have a (wan) icon on the GUI drop down list. Try eth0.2 (If that is your WAN interface). My abbreviated network config is below for comparison. Worst case turn off your SQM and see what your results are (to make sure that SQM indeed is the problem).


root@OpenWrt:~# cat /etc/config/network
config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

changed it to "eth0.2 (wan,wan6)"
looks like yours now.

still slow wifi on laptop.. 10-15
iphone is faster.. 90-100mb

disabled SQM.. no change

Older iPhone?
iPhone 5 only supports wifi 4 which would explain your speed of 100mbps- see here: https://www.duckware.com/tech/wifi-in-the-us.html#wifi4

Laptop speed would be explained if it has a 1x1 wireless card using 802.11g wireless. Explanation of PHY: https://www.duckware.com/tech/wifi-in-the-us.html#PHY

iPhone 10max - used to get 600mb
2009 laptop Was getting way more than 10mb before openwrt..

Speedtest / fast.com (focused on bandwidth) should get about 400mbps with 5ghz, 80mhz wide channel on your iphone 2x2 client (in a medium sized room). For 2.4ghz 20mhz wide channel (2009, wireless g / wifi 3?) you should expect mid 20’s. On your iphone you’ll get wireless speed on 2.4ghz of up to 100-150mbps under ideal conditions (I would forget the 2.4ghz network with your iphone and strictly use 5ghz)

Dslreports is latency focused (doesn’t provide the best bandwidth measure due to limited servers) and requires some tweaking / repeat testing.

Post some of your test results. Here is a random mid morning 5ghz iphone measurement:

iPhone 10max
WiFi 5ghz
Tested 5 times
I used to get 500-600 on 5ghz

2.4 tested 5 times (closest server for both)