Very slow Wifi connection speeds

Hello;

I have a TPLink Archer A7 v5 router with Open WRT 21.02.3. My WiFi speeds when connected to my cable co router are 600 mbps+. When connected to the WiFi of the TPLink I am getting 20 mbps at best. I have searched the forums and this is what I have found and confirmed in my setup

  1. Using a Cat6 cable from the modem to the router
  2. Confirmed that VMM is checked/enabled

What else can I try to increase the speeds?

is 4 years old, you should have upgraded a long time ago.

set a country code for the wifi.
don't use sae-mixed wifi encryption.

Upgrade to 23.05.5?
SoC can forward at 1.1..1.3Gbps, if it has one SoC mii of 2 connected to switch it becomes 1.0Gbps(950Mbps in tcp connections)-ie not full gigabit

Special performance trick - untag WAN onn SoC port.

Try enabling flow offload, on v23 both are same, in v24 soft is a bit slower, hard a bit faster even without support.

24.10.0 is if you are adventurous as challenged in last paragraph of release notes.

Wifi should be able to transfer at half if indicated link speed.

Thank you for the responses. I used the sysupgrade image to flash the firmware and I am now running OpenWRT v24.10 and I have set the country code for the Wifi. Also ensured I am not using sae-mixed encryption. Unfortunately I am still only getting ~20Mbps on speedtest.

Please post outputs of

ubus call system board
cat /etc/config/wireless
cat /etc/config/network
cat /etc/config/firewall
cat /etc/config/dhco

Use </> to fomat text and replace secrets like passwords with ABC

Also what is the client? Say Win10 laptop with degraded battery will be permanently in deep powersave and never reach good network or disk speeds.

How many devices tested @ that speed?

Which band? 2.4 or 5?

{
	"kernel": "6.6.73",
	"hostname": "OpenWrt",
	"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
	"model": "TP-Link Archer A7 v5",
	"board_name": "tplink,archer-a7-v5",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "24.10.0",
		"revision": "r28427-6df0e3d02a",
		"target": "ath79/generic",
		"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
		"builddate": "1738624177"
	}
}
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option band '5g'
	option cell_density '0'
	option htmode 'VHT20'
	option channel 'auto'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'ABC'
	option encryption 'psk2'
	option key 'ABC'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde2:99e2:049f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config device
	option name 'eth0.2'
	option macaddr 'xx:xx:xx:xx:xx'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
	option name		Support-UDP-Traceroute
	option src		wan
	option dest_port	33434:33689
	option proto		udp
	option family		ipv4
	option target		REJECT
	option enabled		false

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

It's a Macbook Pro M2 on AC power

VHT20? We cannot stop you throwing brick on your foot.
Use 80MHz channel and watch normal speed happen.

Thank you - after that change I am getting slightly better speed. I am now getting ~35Mbps. Better but still much lower than I would expect. Does this sound right?

Try wired something, smart tv is fine.

On a wired connection I am getting ~200Mbps but that is still not as high as if I connect to the wireless modem network where I average around 500Mbps.

This is an old SOC/ device, designed when VDSL in the 50-100 MBit/s range was king, 170-200 MBit/s is the max. it can do under duress (software flow-offloading might double that by cheating, but that isn't real). If you want 600 MBit/s wired routing, you need a faster router - if you want to get that over the air, you need a wifi6 router (which can provide you with 700-800 MBit/s wireless throughput in the same room).

1 Like

If you ferl adventurous you can change WAN vlan2 to untagged at cpu port, then relocate wan/wan6 device to eth0 in place if eth0.2 .
config backup and wifi connection recommended in case switch crashes.

Post a screenshot from the MBP M2, hold the [option/alt] key down & click on the Wi-Fi icon on the menu bar at the top of the scree.

The 5G Wi-Fi looks OK between the MBP to WAP.

Can you try disabling WMM?

Disabling brings it back down to under ~9Mbps. Re-enabled VMM and tested speeds again and now getting around 70Mbps. Is that about top speed for this TPLink device? Or can speeds be faster?

[ISP Router] - [Archer A7 v5] - 5G ---- MBP

Above is my understanding of your Topology, please confirm.

Are you running the Archer A7 in Double NAT or is it running as a pure AP?
Confirm the port between the ISP Router and WAN port on the Archer is operating at 1Gbps and not 100 Mbps.

This is correct.

Running as a pure AP. ISP does not allow configuration of ports however testing the same port from ISP Router on target MBP wired tests out at just under 1Gbps speeds.