VDSL problem, need to change name

Making progress but got another problem with my BT HH5
I created a VLAN named 832 because apparently that's what needed by Orange France
so my network config looks like this:
config interface 'wan'
option ifname 'dsl0.101'
option proto 'dhcp'

If I manually change that to dsl0.832 after reboot it changes itself back to dsl0.101 :confused:
It appeard that is the 'hardware name' and I can't see how to change it?

Apparently you changed the physical interface for wan6 to eth0.832.
This does not look right to me, can you explain this configuration?

According to the specs you gave, the correct configuration would be

  • wan -> dsl0.832
  • wan6 -> dsl0.832

Enter dsl0.832 into the --custom-- field for each interface (wan, wan6), push "Save", and finally "Save&Apply". Please report back whether it survives a reboot.

3 Likes

absolutely fantastic that did it!
Great forum, love to you all! Now dare I go for an upgrade to version 20 whatever? lol

My BT HH5 is working fine with RC3. However may just be worth waiting till the final V20 release and use that.

1 Like

got a link to the procedure please? I read the FAQ but it just mentions sysupgrade and I ain't even got that in my /sys folder!

Instructions are linked in the first post.

i do suggest you do a clean install and then redo any customisations u need.

I cheat and automate this by using OpenWrtScripts/config-openwrt.sh at master ยท richb-hanover/OpenWrtScripts (github.com)

and once i reset / reload the new release candidate i can pretty much auto install my settings.

(mostly resetting the wifi, setting timezone but there are other settings you can do like SQM.)

if it helps these are my settings for the network (set it up so it can do VDSL on Openreach network VLAN 101) Just copy them into the sections of the script and then SSH into the router and run it. Dont forget to make it executable first

chmod +x config-openwrt.sh

# echo 'Configuring WAN link for PPPoE'
# DSLUSERNAME=YOUR-DSL-USERNAME
# DSLPASSWORD=YOUR-DSL-PASSWORD
uci delete network.atm
uci delete network.dsl
uci delete network.wan

uci set network.globals.packet_steering='1' #Use every cpu to handle packet traffic

uci set network.dsl=dsl
uci set network.dsl.annex='b'
uci set network.dsl.xfer_mode='ptm'
uci set network.dsl.line_mode='vdsl'
uci set network.dsl.ds_snr_offset='0'
uci set network.dsl.tone='a'

uci set network.lan.igmp_snooping='1'

uci set network.wan=interface
uci set network.wan.device='dsl0.101'
uci set network.wan.proto='dhcp'
uci set network.wan.mtu='1500'
uci set network.wan.ipv6='1'

# uci set network.wan.username=$DSLUSERNAME
# uci set network.wan.password=$DSLPASSWORD
uci commit network
ifup wan
echo 'Waiting for link to initialize'
sleep 20

And this will auto install some needed packages

# === Update the software packages =============
# Download and update all the interesting packages
# Some of these are pre-installed, but there is no harm in
# updating/installing them a second time.
 echo 'Updating software packages'
 opkg update                # retrieve updated packages
 opkg install luci          # install the web GUI
 opkg install luci-app-sqm  # install the SQM modules to get fq_codel etc
 opkg install bind-tools	#dns tools
 opkg install ca-certificates # CA Certs for SSL
 opkg install igmpproxy	#TV igmpproxy needed for IPTV

wifi Settings

# === Assign the SSID's
 echo 'Setting SSIDs'
 uci set wireless.@wifi-iface[0].ssid=BT5-5GHz
 uci set wireless.@wifi-iface[1].ssid=BT5-2-4Ghz

# === Assign the encryption/password ================
# Update the wifi password/security. To see all the wireless info:
#	uci show wireless
# The full list of encryption modes is at: (psk2 gives WPA2-PSK)
#	http://wiki.openwrt.org/doc/uci/wireless#wpa.modes
# Set WIFIPASSWD and the ENCRMODE, and then uncomment the remaining lines.
# 
 echo 'Updating WiFi security information'
 WIFIPASSWD='changeme'
 ENCRMODE=psk2+ccmp

 uci set wireless.@wifi-iface[0].key=$WIFIPASSWD
 uci set wireless.@wifi-iface[1].key=$WIFIPASSWD

 uci set wireless.@wifi-iface[0].encryption=$ENCRMODE
 uci set wireless.@wifi-iface[1].encryption=$ENCRMODE

 uci commit wireless

echo 'You should restart the router now for these changes to take effect...'
1 Like

I have just realised you will need to edit one rather important line.

uci set network.wan.device='dsl0.101'

You need to change 101 to 832 which is the VLAN for Orange France as per your first post.

1 Like

thanks for your posts. I'm still confused as to how to load the new firmware lol
I read sysupgrade won't work so which method to use?

Where exactly did you read that?

Anyway, maybe if attempting to go from 19.07 to 21.02 (RC or snapshot) one would need to discard the configuration. Especially to go to 21.02-snapshot which now uses DSA. But otherwise, I don't see why sysupgrade should not work resp. it should work but might requie re-setting the configuration.

1 Like

quote 'There is no migration path for targets that switched from swconfig to DSA. In that case, sysupgrade will refuse to proceed with an appropriate error message'
from
https://openwrt.org/releases/21.02/notes-21.02.0-rc3#known_issues

Yes, but the Lantiq target did not switch to DSA for 21.02 as far as I know. It only introduced DSA in master very recently. So unless you really plan to run very latest master based snapshots you should not have any issues sysupgradeing.

1 Like

ok so from my router, is this the package I need for sysupgrade and I can download the upgrade from here https://downloads.openwrt.org/releases/21.02.0-rc3/targets/lantiq/xrx200/

And it means you have to reset the device when upgrading, not that it isn't upgradable.

1 Like

Yes, the bt_homehub-v5a-squashfs-sysupgrade.bin one to be precise.

And not sure, what exactly you tried to ask/show with that Software screenshot. As for such update one would initiate it from within LuCi aka the web browser based UI under something like: System - "Backup / Flash Firmware": "Flash new firmware image" with the "Flash image..." button. Alternatively, one may scp that .bin file to /tmp/ on the target and then initiate it via SSH running:

sysupgrade /tmp/bt_homehub-v5a-squashfs-sysupgrade.bin

1 Like

Ace cheers! Sorry I was thinking I needed to do it from the CLI with the sysupgrade program

[OpenWrt Wiki] Upgrading OpenWrt firmware using LuCI

You can do it via CLI but easier to just use the Luci interface. Do not keep previous configuration. Its far easier to clean install and reset it back up to avoid issues.

The file you need to upgrade is here : https://downloads.openwrt.org/releases/21.02.0-rc3/targets/lantiq/xrx200/openwrt-21.02.0-rc3-lantiq-xrx200-bt_homehub-v5a-squashfs-sysupgrade.bin

1 Like

I went for it as the DSL connection appeared to reset itself twice in the last day AND.....
it worked so far!! lol
I told it to keep the current config, Luci did some bits of reconfig when I went into Network, Interfaces but looking good so far
Thanks for everyones input!!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.