Using QOS in a variable way

It is possible in OPENWRT to balance data on the router, for example:

10Mbps of internet:

  • if 1 is using, use 10Mbps,
  • if one more entry comes in. So, 5Mbps for each,
  • if you enter 4 at the same time 2.5Mbps

I don't want to always set 2.5Mbps for each. And yes, the internet link is better used by everyone.


Fábio Saboia

you can use sqm with cake and per-host isolation option and it will automagically distribute the available bandwidth fairly between all devices/connections.


hello can you screen for learning please i don't very understand ,


Thanks. I will try this configuration.

Thank you, @jesanor


I think the screens would be these.

I did a test in a virtual environment with VirtualBOX (5Mb link and 3 VM Ubuntu).
At first it does get the balance. Of course, the division is not the same, but it is very similar.



1 Like

just to be sure.. i don't see this in your screens..

To enable Per-Host Isolation Add the following to the “Advanced option strings” (in the Interfaces → SQM-QoS page; Queue Discipline tab, look for the Dangerous Configuration options):

For queueing disciplines handling incoming packets from the internet (internet-ingress): nat dual-dsthost ingress

For queueing disciplines handling outgoing packets to the internet (internet-egress): nat dual-srchost

please mark as solved if you are satisfied with the results

Him, the test_WAN_* variants of the scripts are really not maintained, do I would recommend switching back to either piece_of_cake.qos or layer_cake.qos (if you want to use DSCPs to prioritise some traffic), and I would try the manual configuration of per-internal-IP fairness, as recommended by @jesanor
Why these are not in the default scripts, you might ask? Well, to configure this one needs to know in which direction of the SQM'd interface the internal network is located, otherwise one risks to configure per-external-IP fairness, and I am not sure anybody ever wanted that :wink:

1 Like



1 Like

be also sure about this.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.