Use BT Hub5A With OpenWrt as router - Connection problems [SOLVED]

Hi Everyone,

I brought a BT Home Hub 5A model from online which as the newest stable version of OpenWrt (18.06.1).

I am wanting to use it as the sole router and have it connect to BT just like my Home Hub 6 does. I have been searching around online now for around three days and tried all different configurations. Please see screenshots below, I am convinced it is trying to connect to BT but they are refusing the connection.

Capture

I was going to post this in an already created BT PPPOE topic I found on here but it was closed, so apologies for the new post.

Capture3

There is a mistake with the WAN interface having a green colour, which means you have assigned it to the lan zone in firewall.
Could you post the contents of /etc/config/network and /etc/config/firewall ?

Have you studied the installation guide?
link to ebilan forum

Suggest factory resetting the HH5a as described in section 8 to resolve the issue described by @trendy

Then start at section 7.5 which will redirect you to the relevant section 9.x for setting up the internet connection for FTTC fibre, FTTP fibre or upto 17mb ADSL broadband services.

If you have BT Infinity FTTC fibre, have you configured the VLAN 101 tag (ie. dsl0.101) in the Physical Intertaces section, which is described in section 9.1 ?

1 Like

I have rebooted the router and started fresh using the instructions on your guide. I feel I am still missing something I don't have infinity. I have super fast fibre unlimited, live out in the countryside so..... interner speeds are not the best! :frowning:

Trendy, I got copies of the files you asked for:

Network Config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdce:b4ff:58d8::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option tone 'a'
        option ds_snr_offset '0'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'c8:91:f9:25:a1:98'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 '1'
        option ifname 'ds10.101'
        option username 'bthomehub@btbroardband.com'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr 'c8:91:f9:25:a1:99'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

And Firewall Config:

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user

I also have some sort of connection up and running:
iup

In Network config, on interface wan, option ifname is wrong. it should be DSL0.101 not DS10.101 (small letters).
Other than that, better follow the guide in the site that @bill888 posted and report here if something doesn't work.

1 Like

You have a FTTC service as confirmed by G.993.2 (VDSL2) in status page you posted.

Thinking about it, BT dropped the 'Infinity' branding late last year and now call it 'Superfast Fibre'.

There is a typo error for the ifname as pointed out by @trendy.

btbroadband has been misspelt in the username. ie. Not @btbroaRdband.com
Correction: should use: bthomehub@btinternet.com

Oh, guys, I feel such an idiot with that typo! :blush:

Yeah, I did log in and check as I have not heard of Infinity for a good while, your right. It is super fast fibre instead.

I will re-check the settings and report back.

Thanks a lot to you both for helping.

Still no joy for me.

I mean which protocol do I need to use the guide tells me about PPPOE and PPPoAM?

I don't use the WAN wire in the hub it is just a straight phone line jack into my "smart hub". So I plug that same jack into the BT Hub 5A.

I have tried both, they both get a connection and "up" from the overview page but no connection to ISP to go out onto the Internet.

Also the instructions say to use bthomehub@btinternet.com but on my router settings its btbroadband.com - I have tried both.

I'm going bald here pretty fast haha!

Follow exactly what it says in section 7.5/9.1 of the guide for PPPoE for FTTC. (PPPoA is only used for ADSL upto 17mb connections)

I notice you didn't delete the ATM bridge section as instructed in the guide, but that does not usually affect FTTC connections if left in, so I'm wondering how far you deviated from the instructions?

The guide does say to use: bthomehub@btinternet.com

The guide does quote to check Status->System log for errors if line is up but there is no connection. What does it report?

Hi Bill,

I will re-check and go back through every single detail on the guide and if it does not connect I shall post the log here.

Thanks. :slight_smile:

Perhaps factory resetting the hub to erase all settings again, and start from scratch.

Repost the /etc/config/network file if you still have issues, but the one you posted earlier looked correct except for ifname typo error, and perhaps wrong BT username. As far as I'm aware, BT has not changed the username - check your BT Smart Hub for what is used?

There is no need to post the /etc/config/firewall file.

I presume you are a consumer customer of BT Retail and not a BT Business customer ?

Hi again,

First of all here is the log.... it does look as though it is connecting but maybe BT are refusing something?

Thu Aug 16 11:19:20 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:20 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:20 2018 daemon.notice pppd[8432]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: PPP session is 5541
Thu Aug 16 11:19:20 2018 daemon.warn pppd[8432]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:20 2018 kern.info kernel: [  385.400087] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: Using interface pppoe-wan
Thu Aug 16 11:19:20 2018 daemon.notice pppd[8432]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:20 2018 daemon.notice pppd[8432]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: LCP terminated by peer
Thu Aug 16 11:19:20 2018 daemon.notice pppd[8432]: Modem hangup
Thu Aug 16 11:19:20 2018 daemon.notice pppd[8432]: Connection terminated.
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: Sent PADT
Thu Aug 16 11:19:20 2018 daemon.info pppd[8432]: Exit.
Thu Aug 16 11:19:20 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:20 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:20 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:20 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:21 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:21 2018 daemon.err insmod: module is already loaded - ppp_generic
Thu Aug 16 11:19:21 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:21 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:21 2018 daemon.notice pppd[8603]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: PPP session is 5542
Thu Aug 16 11:19:21 2018 daemon.warn pppd[8603]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:21 2018 kern.info kernel: [  386.743985] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: Using interface pppoe-wan
Thu Aug 16 11:19:21 2018 daemon.notice pppd[8603]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:21 2018 daemon.notice pppd[8603]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: LCP terminated by peer
Thu Aug 16 11:19:21 2018 daemon.notice pppd[8603]: Modem hangup
Thu Aug 16 11:19:21 2018 daemon.notice pppd[8603]: Connection terminated.
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: Sent PADT
Thu Aug 16 11:19:21 2018 daemon.info pppd[8603]: Exit.
Thu Aug 16 11:19:22 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:22 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:22 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:22 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:22 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:22 2018 daemon.err insmod: module is already loaded - ppp_generic
Thu Aug 16 11:19:22 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:22 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:23 2018 daemon.notice pppd[8778]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: PPP session is 5543
Thu Aug 16 11:19:23 2018 daemon.warn pppd[8778]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:23 2018 kern.info kernel: [  388.382088] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: Using interface pppoe-wan
Thu Aug 16 11:19:23 2018 daemon.notice pppd[8778]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:23 2018 daemon.notice pppd[8778]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: LCP terminated by peer
Thu Aug 16 11:19:23 2018 daemon.notice pppd[8778]: Modem hangup
Thu Aug 16 11:19:23 2018 daemon.notice pppd[8778]: Connection terminated.
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: Sent PADT
Thu Aug 16 11:19:23 2018 daemon.info pppd[8778]: Exit.
Thu Aug 16 11:19:23 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:23 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:23 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:23 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:24 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:24 2018 daemon.err insmod: module is already loaded - ppp_generic
Thu Aug 16 11:19:24 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:24 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:24 2018 daemon.notice pppd[8942]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: PPP session is 5544
Thu Aug 16 11:19:24 2018 daemon.warn pppd[8942]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:24 2018 kern.info kernel: [  389.657579] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: Using interface pppoe-wan
Thu Aug 16 11:19:24 2018 daemon.notice pppd[8942]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:24 2018 daemon.notice pppd[8942]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: LCP terminated by peer
Thu Aug 16 11:19:24 2018 daemon.notice pppd[8942]: Modem hangup
Thu Aug 16 11:19:24 2018 daemon.notice pppd[8942]: Connection terminated.
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: Sent PADT
Thu Aug 16 11:19:24 2018 daemon.info pppd[8942]: Exit.
Thu Aug 16 11:19:25 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:25 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:25 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:25 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:25 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:25 2018 daemon.err insmod: module is already loaded - ppp_generic
Thu Aug 16 11:19:25 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:25 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:25 2018 daemon.info pppd[9110]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:25 2018 daemon.info pppd[9110]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:25 2018 daemon.notice pppd[9110]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:25 2018 daemon.info pppd[9110]: PPP session is 5545
Thu Aug 16 11:19:25 2018 daemon.warn pppd[9110]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:25 2018 kern.info kernel: [  390.882589] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:25 2018 daemon.info pppd[9110]: Using interface pppoe-wan
Thu Aug 16 11:19:25 2018 daemon.notice pppd[9110]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:25 2018 daemon.notice pppd[9110]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:26 2018 daemon.info pppd[9110]: LCP terminated by peer
Thu Aug 16 11:19:26 2018 daemon.notice pppd[9110]: Modem hangup
Thu Aug 16 11:19:26 2018 daemon.notice pppd[9110]: Connection terminated.
Thu Aug 16 11:19:26 2018 daemon.info pppd[9110]: Sent PADT
Thu Aug 16 11:19:26 2018 daemon.info pppd[9110]: Exit.
Thu Aug 16 11:19:26 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:26 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:26 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:26 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:26 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:26 2018 daemon.err insmod: module is already loaded - ppp_generic
Thu Aug 16 11:19:26 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:26 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:26 2018 daemon.info pppd[9271]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:26 2018 daemon.info pppd[9271]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:26 2018 daemon.notice pppd[9271]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:27 2018 daemon.info pppd[9271]: PPP session is 5546
Thu Aug 16 11:19:27 2018 daemon.warn pppd[9271]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:27 2018 kern.info kernel: [  391.993906] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:27 2018 daemon.info pppd[9271]: Using interface pppoe-wan
Thu Aug 16 11:19:27 2018 daemon.notice pppd[9271]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:27 2018 daemon.notice pppd[9271]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:27 2018 daemon.info pppd[9271]: LCP terminated by peer
Thu Aug 16 11:19:27 2018 daemon.notice pppd[9271]: Modem hangup
Thu Aug 16 11:19:27 2018 daemon.notice pppd[9271]: Connection terminated.
Thu Aug 16 11:19:27 2018 daemon.info pppd[9271]: Sent PADT
Thu Aug 16 11:19:27 2018 daemon.info pppd[9271]: Exit.
Thu Aug 16 11:19:27 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:27 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:27 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:27 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:28 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:28 2018 daemon.err insmod: module is already loaded - ppp_generic
Thu Aug 16 11:19:28 2018 daemon.err insmod: module is already loaded - pppox
Thu Aug 16 11:19:28 2018 daemon.err insmod: module is already loaded - pppoe
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: Plugin rp-pppoe.so loaded.
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Aug 16 11:19:28 2018 daemon.notice pppd[9451]: pppd 2.4.7 started by root, uid 0
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: PPP session is 5547
Thu Aug 16 11:19:28 2018 daemon.warn pppd[9451]: Connected to 84:26:2b:a1:c6:98 via interface dsl0.101
Thu Aug 16 11:19:28 2018 kern.info kernel: [  393.619084] pppoe-wan: renamed from ppp0
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: Using interface pppoe-wan
Thu Aug 16 11:19:28 2018 daemon.notice pppd[9451]: Connect: pppoe-wan <--> dsl0.101
Thu Aug 16 11:19:28 2018 daemon.notice pppd[9451]: peer from calling number 84:26:2B:A1:C6:98 authorized
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: LCP terminated by peer
Thu Aug 16 11:19:28 2018 daemon.notice pppd[9451]: Modem hangup
Thu Aug 16 11:19:28 2018 daemon.notice pppd[9451]: Connection terminated.
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: Sent PADT
Thu Aug 16 11:19:28 2018 daemon.info pppd[9451]: Exit.
Thu Aug 16 11:19:29 2018 daemon.notice netifd: Interface 'wan' is now down
Thu Aug 16 11:19:29 2018 daemon.notice netifd: Interface 'wan' is disabled
Thu Aug 16 11:19:29 2018 daemon.notice netifd: Interface 'wan' is enabled
Thu Aug 16 11:19:29 2018 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 16 11:19:29 2018 daemon.err insmod: module is already loaded - slhc
Thu Aug 16 11:19:29 2018 daemon.err insmod: module is already loaded - ppp_generic

In my Smart Hub it uses this:
Screenshot%20from%202019-01-13%2011-55-36

Yes, I am just a normal retail customer. My speeds are low because I live out in the middle of nowhere haha. The joys of the countryside.

Also,

Here is my network log again:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdce:b4ff:58d8::/48'

config dsl 'dsl'
        option ds_snr_offset '0'
        option tone 'a'
        option annex 'b'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'c8:91:f9:25:a1:98'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'dsl0.101'
        option ipv6 'auto'
        option username 'bthomehub@btinternet.com'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr 'c8:91:f9:25:a1:99'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch                                     
        option name 'switch0'                     
        option reset '1'                          
        option enable_vlan '1'                    
                                                  
config switch_vlan                        
        option device 'switch0'           
        option vlan '1'                   
        option ports '0 1 2 4 6t'         
                                 
config switch_vlan               
        option device 'switch0'  
        option vlan '2'          
        option ports '5 6t'      
                             

You need to provide any non-empty password with the login. As it seems your current configuration does not have any pap/chap password, causing your peer to rejects the connection. In Bill's manual the recommended password is ' ' (a space), which can cause confusion. Anything non-empty should work, e.g. 'BT'.

1 Like

Also, if you have ssh access to the router, try adding to your wan section of /etc/config/network the line
option pppd_options 'debug'
It will provide more detailed information about the pppoe connection process.

1 Like

Long shot.

Do you log into the Smart hub and press a button to disconnect 'cleanly' from BT internet, or are you just powering off the Smart hub and swapping over to HH5A?

The /e/c/network seems to look correct.
I note there is no 'option password' entry in 'interface wan' section is only anomaly. Perhaps try any password, then try again after deleting it.

Is the System log any different if you use bthomehub@btbroadband.com instead of bthomehub@btinternet.com ?

1 Like

I will login via SSH and use Vim to place an empty password in savostyanov, good thinking!

I will also add the debug line whilst in there, thanks buddy.

Bill, I actually do not connect or disconnect it at all I literally just pull the DSL line from the router and plug it into the Hub 5A did not think it would make a difference to be honest with you.

I did try both passwords yes and still the same, but I will try again now with both of your methods and see if that does the trick. Fingers Crossed

Update!

All working guys, Thank you so much for helping me!

The fix was placing this:

options password ' '

Into the network config file. I find it incredible how something so simple can give you a three-day headache.

Again, I thank you all :slight_smile:

Great, thanks for confirming! I suspect that Luci web interface wipes one-space password before it is passed to the configuration? Perhaps, it's best to change the example password to anything non-empty in @bill888's manual?