Use any of pre-selected number of WiFis, as a repeater/A

Hello,

I have two phones at home, both of which support Hotspot mode. I want to configure my OpenWrt to be repeating/sharing any of the two hotspots, whatever is available at the time.

The idea being, I want the 'clients' at home to only know about one WiFi - the OpenWrt and I want it to feed whatever 'underlying' wifi is available at the time - hotspot1 or hotspot2. In other words, I want to be able to turn off one of the hotspots and turn on the other and that should work seamlessly to the client of the OpenWrt.

I have managed to 'join' one of the hotspots, however I can't figure out how to make it join a second and switch between the two based on availability. Also, I have probably miscofigured it somehow, because unless the hotspot is up and running, OpenWrt doesn't show as an available wifi.

Help?

This is normal and expected behavior. A client association must be up before an AP-master can come online. It was just recently answered here:

this went slowly a bit embarrassing ...:smile: ... Travelmate should fulfill your needs, see here

2 Likes

Still unclear on how to make the OpenWrt connect to either available client wifi.

It would be priority based. If the one you list as most preferred is not found, the other one would be tried.

Another approach would be to set the phones to both use the same SSID and encryption in hotspot mode. You can then configure the router as if there is only one network to connect to. If both are in range and on the air at the same time the router would choose one more or less "randomly".

Using two ISPs at once is a whole different ball of wax.

Yes, the first approach is what I want to get working.

So on the 'radio' I scanned again, joined the second hotspot and it made me create a new interface. I then stopped the first hotspot and the openwrt did not join the second hotspot :frowning:

I noticed that for whatever reason openwrt was refusing to store the changes for the second hotspot. I guess that's why it didn't join the second hotspot.

I am sorry, I don't know the first thing about Unix.

Did you try using travelmate? There you manage simply a list of possible uplink stations - the rest is done by the program as soon as the uplink is available/in range, in the following example the uplink with the lowest priority is in range and gets the connection - all others are disabled:

stations

1 Like

No, I haven't tried Travelmate.

My understanding is what I need is AAP. So I should rephrase my question as "Is there a way to utilize AAP in LuCi"?

Try it then.

1 Like
  • Do you mean Autonomous AP??? Otherwise, no clue why or what this means in context (you haven't noted a central control/autencation of the device, so it is "Autonomous").
  • Please rephrase better. (Describe what "AAP" means to you in this use case.)
  • Anyways, Travelmate, as others have told you multiple times - is known to solve the exact issue you describe

Ok, I am trying to, but I know almost next to nothing about Linux.

root@OpenWrt:/tmp# opkg install luci-app-travelmate
Installing luci-app-travelmate (git-19.079.57770-b99e77d-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/luci/luci-app-travelmate_git-19.079.57770-b99e77d-1_all.ipk
Installing travelmate (1.2.2-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/packages/travelmate_1.2.2-1_all.ipk
Collected errors:
 * wfopen: //usr/lib/opkg/info/travelmate.conffiles: Read-only file system.
 * wfopen: //usr/lib/opkg/info/travelmate.control: Read-only file system.
 * wfopen: //usr/lib/opkg/info/travelmate.postinst: Read-only file system.
 * wfopen: //usr/lib/opkg/info/travelmate.prerm: Read-only file system.
 * wfopen: /etc/config/travelmate: Read-only file system.
 * wfopen: /etc/init.d/travelmate: Read-only file system.
 * wfopen: /usr/bin/travelmate.sh: Read-only file system.
 * pkg_write_filelist: Failed to open //usr/lib/opkg/info/travelmate.list: Read-only file system.
 * opkg_install_pkg: Failed to extract data files for travelmate. Package debris may remain!
 * opkg_install_cmd: Cannot install package luci-app-travelmate.

Look, I know how this sounds. I am a newb, ok, I don't know Linux and I know barely enough about OpenWrt to get it to work with my tethered Android connection. All I want is for it to be able to switch between phones. If Travelmate (whatever that really is) is the solution, sure. If only I could install it.

Also, I may have 48kb free. OpenWRT says:
Free space: 15% ( 48.00 KB )

Yes, you have overfilled the flash. It needs 2 or 3 free erase blocks of 64k each for it to work.

This is difficult to recover from gracefully. The best bet is to run firstboot which will reformat the flash and start with default settings. Then install only what you must have. If it is a 4MB flash model, there is very little space to install anything.

2 Likes

So the OpenWrt network disappeared, naturally. Now I'm trying to remember how to setup a fresh OpenWrt installation. I don't see the OpenWrt network up.

I think the device is now somehow messed up, after the firstboot. This is the last I saw from it

Your JFFS2-partition seems full and overlayfs is mounted read-only.
Please try to remove files from /overlay/upper/... and reboot!
root@OpenWrt:~# firstboot && reboot now
This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
/dev/mtdblock3 is mounted as /overlay, only erasing files

Now I remember, I think I'll need a network cable to connect and setup the OpenWrt again. There's no default wifi up from what I can tell.

It's just like when it is first installed. There is no default wifi for security purposes. Connect by wire and configure it.

1 Like

Ok, well, I did that. I still have only like 56kb free but it seems to be working. I did install travelmate.

But I just don't get it. OpenWrt is simply disregarding my commands. I am enabling travelmate, it says 'unsaved changes', I save them, then without any kind of error or message the old settings are back - travelmate disabled. I have added a client network which I can't get rid of. I 'remove' it and it is still there. I remove the interface and it stays there too.

What's really driving me crazy is not being able to delete a client network. I mean... what the heck? I remove it and it stays there and the OpenWrt is connected to it. I disable it and it stays enabled. I remove the master connection (as to disable my router over Wifi) and it still remains.

Alright, I guess at the bottom of that behavior is the lack of free space. This is ridiculous. We're talking about applying text changes to config files in the magnitude of a less than a kb delta. Why would it fail to save the files? How can I apply the pending changes through SSH?

Is there anything I could do here?

root@OpenWrt:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 2304 2304 0 100% /rom
tmpfs 13936 664 13272 5% /tmp
/dev/mtdblock3 320 264 56 83% /overlay
overlayfs:/overlay 320 264 56 83% /
tmpfs 512 0 512 0% /dev

What's /tmp, it has a ton of free space?

You're out of space. You're describing common behavor seen in other threads, when a user runs out of space on a 4 MB flash device.

It's generated from RAM upon boot, it is not persistent storage - therefore unusable for your purposes. See:

Thanks for your help. Just ordered a GL.iNet GL-MT300N-V2

When it arrives I may smash the poor TL-WR802N to pieces.

1 Like

If you (or someone else) runs into space problems in the future, one option is to assemble or build your own images. The “custom” packages are compressed in the ROM and that sometimes can be just enough.

That said, the GL.iNet units I have work very well and have sufficient flash and RAM for more that I personally would run on a router. Enjoy!

1 Like

Just so you know - GL provides their own connection priority/reconnect functionality. So you don't necessarily need Travelmate on your new device. If you do want to use Travelmate you may want to re-flash with vanilla OpenWRT so that the GL stuff is not there to conflict.

I had some trouble with wifi dropping and not reconnecting, but on the latest testing firmware it has been working very well. So if you see this problem (connects ok to your hotspot, then later it drops and the router page shows no internet connection), then you may want to try firmware v3.022 or later.

2 Likes

Thanks. Yeah, I friend has that router and I saw how easy it is to add multiple client networks and switch dynamically between them. So it would be plug and play mostly.