Client mode wireless connection Drops out

So if I am understanding you correctly, since eduroam stops transmitting because say there are no clients, then this causes the radio to turn off because it doesn't which channel to select to since there is no upstream?

The travelmate package? I have not heard of this before

I haven't used it myself, but it seems to have quite a following with people that want to connect to another wireless service, then have their own AP for their own devices.

Thank you for the link! The devices are able to still connect to the router even when the connection between the router and eduroam drops.

The main issue is that the connection between my router and the AP of the university drops and there is no internet.

As a side note, I see that the connection status for eduroam on my router keeps dropping to 0% then shoots back up to 97%. Now this shoot up usually occurs when the traffic is higher (I tested with and then it shoots down when there is very little traffic. So far, I am assuming that this is some sort of energy saving mode. But just in case that it isn't, is this behavior normal?

Any other thoughts?

So new update. I installed travelmate last night and the connection did end up dieing. However, this morning the connection was back up!

I will be waiting to see if the connection dies again (hopefully it does not) but in the mean, has anyone else ran into something similiar to this?

Ok so the connection is repeatedly dieing over and over again. Eventually, the connection comes back online but it then later dies. Is there anything that I can do to keep the connection up?

Inactivity is a common reason for wireless connections to be terminated. Perhaps a ping a minute or two (or five, or ten or ...) to a host on the other side of the link?

This would be a reason that your AP drops.

Ok, great, thanks @jeff

For the ping, would that be a simple cron job?

Edit: Ok, so I created a cron job that will ping google's servers every 15 minutes. Let's see if that will work.

Looking at your log file it looks like the failure is tripped off by the eduroam middle process being unable to renew the DHCP lease. This causes eduroam to shut down, which triggers a client initiated disconnection (deauthenticated by local choice) from the college AP. A few seconds later it reconnects successfully.

@mk24 @jeff

Thank you for your feedback. I did implement Jeff's recommendation where I am pining google's servers every 15 minutes. unfortunately, this did not work and the connection still went down.

Now, is it possible that my AP glitches and cannot renew the DCHP lease causing eduroam to permanently go down? If this is the case, then how cna I fix the issue?

Hello all,

Does anyone have any feedback on fixing the DHCP lease? I am still having the issue and I have attempted to use travelMate, a heartbeat ping, and changing the settings of the router to no avail.

I haven't quite figured out how to fix this DHCP lease.

Could it be the wireless AP is shutting the down network?

I am bumping the post because I really need some assistance

  • I gave you a good reason your connection likely drops, did you address that?

  • Travelmate was suggested by @jeff above.

This has also been covered in 2 more threads:

Hi, just to check the progress cuz I am facing the same problem, have you solved this issue?

@MakerX, welcome to the community!

You may wish to make a new thread in the future.

To be clear:

  • you're saying that you setup an upstream WiFi connection for Internet; and
  • you also have an SSID for LAN
  • furthermore, that your client connections on that SSID drops

If so, to solve you issue, let the Internet SSID connect first. Additionally, the upstream WiFi can NEVER loose connection!

Also, please see Post No. 16 for other links and information.

Hi, thanks for your reply, and I've created a thread here.
To reply to your description, my router does loss connection to upstream WiFi (WISP) completely, though "connected" but without Internet access. I often had to reboot the radio to reestablish the connection.

1 Like

Try to add T1 and T2

Wow, I just got a notification that this thread is active?

Anyways, this was really old so I am not sure if I posted the solution. At any rate, what I ended up doing was that I created a cron job that would reset the wireless connection at select times. Not the best solution but at least there are no more drop outs

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.