Urgent assistance required

Please need your support on helping me out making my router PPPoE alive again. After upgrading my Openwrt firmware and filling in my username and password for the PPPoE protocol I then can connect to the wifi and can see that the internet provider has assigned an external ip address to my router but i still can't have internet connection. I don't know if there is anything related to the firewall. I have made reset the to the router and reconfigured it from scratch but still no internet connection. Can you please assist on that? Thank you.

You could start by posting logread output (use the code brackets < / > on top of the edit window of your post).

Did you try reloading the firewall? Can you ping stuff? See e.g. if you can ping from your client. If so, you have internet connectvity, then try pinging e.g. google.com, if that does not work, then you have a DNS issue.

can you ping for instance openwrt.org from the router or any client ? or

I’m pretty sure that it’s an issue of firewall or bridging. The packets are not going out or in from the Lan to the wan. I tried another old router i have and it worked just by filling in my PPPoE credentials.
I’ll try to ping from the client to precisely identify where the problem is. What do you suggest more?

depends what the outcome of your pings are ...

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

That's all fine and dandy... But that doesn't answer the questions we raised here, or the suggestions (like restarting the firewall) that we suggested.

1 Like

Thank you guys for being always available to offer support, it's really impressive how quick your support is.
I'll tell you a funny thing, I made reset using the external button as I did several times before and found out that it is just working without doing anything. This is very weird.
I really appreciate your support, and sorry for making you busy with my rookie knowledge in linux and openwrt configuration. I will surely need your future support in anything that may occur. Thank you again...

1 Like

I am afraid that I still need your recommendations on an issue that I'm facing. I need to configure traffic rules on schedule basis to block traffic from certain devices during certain times. I went to traffic rules in the firewall and selected the MAC addresses and configured the schedule as required, then selected the source to be the Lan and the destination is the Wan. I selected the action as 'Reject' but after applying nothing is taking effect, I still see that the blocked device is still able to access the internet despite all mentioned above.
Please advise.

did you follow this ?

I actually followed the " Time restriction of internet access " in the same article you sent me since I am only concerned about blocking the kids devices from accessing the internet during specific times. But in order to select the MAC addresses I had to go to Advanced settings in the firewall traffic rules where I can select the MAC addresses but unfortunately I couldn't succeed making it working.

I cannot test this myself, I run OpenWRT on my APs, not the main router, so there's no
WAN interface involved on the APs.

What you could to is to add the MAC address for one of your devices to /etc/ethers, or run a
fping session ( Associated stations list in AP, how to show host names? ), to be able to skip the advanced settings part.

After some researches I found that there is a package related to internet Access Control which will add a section in the Network section in the Menu and will allow selecting MAC addresses linked to schedule times for internet access control. Do you know the name of this package?

it's already there for me by default ...

In Firewall -> Traffic Rules (Add), I get a device list.

But I also have /etc/ethers filled in, but I think I get devices not listed in ethers listed in the add rule dialog.

1 Like

I tried it and wasn't successful for me, maybe the firewall package needs to be updated since I just discovered that there's an upgrade for it in the opkg manager. I will make the update and try again.

Don't upgrade packages unless you know what you are doing.


I made the upgraded using the opkg manager and upgraded all installed packages and the traffic rules worked fine now. Thank you for the follow up and support.

This is exactly what the forum never recommends anyone do for various good reasons. You are lucky if it worked. Search forum for upgrading packages to see many explanations why not to do this.


I just read some reviews in the forum about the packages upgrade via Luci as I did and it sound like I did a crime by shooting someone but hopefully he made it and stayed alive :smile: . I wonder how they made the upgrade feature so exposed to normal users like me while it is this much dangerous. I’m glad I made it without any backfire but I’m wondering how would I overcome my problem if it is not recommended to normal users like me doing such step.
Thanks for the support.

upgrading a few individual packages that are non-critical is generally safe, but when there are dependencies and libraries and etc it can be a big nightmare. If you ever bork the router, safe-mode and a first-boot will restore it.

When you want to do a big upgrade, you install a new image.

1 Like