Upgrading Openwrt from 17.01.1 to 19.07 (ZBT WE826 T 16m version)

I tried uploading the sysupgrade image to upgrade my openwrt from 17.01.1 to 19.07 but gives the following.. I dont want to brick the router and hence not sure if I must proceed

Architecture etc is same as the firmware is of the same router..

What device?

"Keep settings" is not best idea.


It'ss a ZBT WE826 T 16m version ... the website does not have any image other than the sysupgrade so I don't have a choice ... I tried building it too but that also generated just the sysupgrade. Can you suggest what can be done ?

Can you run a ubus call system board to verify?

Give output of cat /proc/mtd
You should write sysupgrade-image using mtd command into correct partition.

dev:    size   erasesize  name
mtd0: 00030000 00001000 "u-boot"
mtd1: 00010000 00001000 "u-boot-env"
mtd2: 00010000 00001000 "factory"
mtd3: 00fb0000 00001000 "firmware"
mtd4: 00135f3c 00001000 "kernel"
mtd5: 00e7a0c4 00001000 "rootfs"
mtd6: 009c8000 00001000 "rootfs_data"

root@LEDE:~# ubus call system board
        "kernel": "4.4.61",
        "hostname": "LEDE",
        "system": "MediaTek MT7620A ver:2 eco:6",
        "model": "ZBT-WE826-T",
        "release": {
                "distribution": "LEDE",
                "version": "SNAPSHOT",
                "revision": "19.0822_180546",
                "codename": "reboot",
                "target": "ramips\/mt7620",
                "description": "LEDE Reboot SNAPSHOT r0-5e6ce99"

Download the firmware and verify with sha256 sum utility that the file is intact (should be f0d20a9b44ff21c16e39af4504c9e98a7dfc58bbd9498134d3f46904c7ed5d7d as mentioned in the download page)
Going from 17 to 19 major version is advise not to keep settings, as there have been changes in the configuration over the years that can cause the device not to boot properly.

It looks like 16M version (https://openwrt.org/toh/zbt/we-826). Download sysupgrade-image into /tmp directory, let it be e.g. sspg.bin, after that:
cd /tmp; sha256sum sspg.bin
check sum;
mtd write sspg.bin firmware
write firmware,

@ulmwind @trendy Can you suggest which way of upgrading would you recommend and why in this case
sysupgrade or mtd ?

I always do mtd. It should work for normal flash (not NAND). For devices with NAND flash do sysupgrade (command in command line).

1 Like

You can try with sysupgrade first. This is close to the web interface upgrade function.

1 Like

Hello I tried doing a sysupgrade and I got this

So I tried with a newer image and this one I downloaded from the openwrt website and this is what I got

Make sure, you are not touching Bootloader, study recovery function, and do mtd.

okay I am thinking to change to /etc/opkg/distfeeds.conf file as it has all this

src/gz reboot_core http://downloads.lede-project.org/snapshots/targets/ramips/mt7620/packages
src/gz reboot_base http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/base
src/gz reboot_luci http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/luci
src/gz reboot_packages http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/packages
src/gz reboot_routing http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/routing
src/gz reboot_telephony http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/telephony

can you tell me what I can update it with as I tried updating it with

src/gz openwrt_core https://downloads.openwrt.org/snapshots/targets/ramips/mt7620/packages

and it seems like it doesnot support https and only supports http and ftp

So I am kinda confused here ... My thought is if it gets updated then I will download modemmanager and not upgrade it to 19.07

Upgrade to last supported version.

The links work fine and the non-https urls are intentional. You won't be able to make a package from current snapshot work on 17 version though, so upgrading is the only option.

1 Like

ya @trendy I understand that upgrading is the option but with sysupgrade I was not able to upgrade it .. I tried the latest version and I also built a firmware with 17.01 version and tried upgrading with sysupgrade and even that didnt happen and I am kinda scared doing the mtd upgrade ... its not that I doubt what you are saying @ulmwind .. Its just the thought that what if it bricks.. ...

I downloaded the mtd3 block and run binwalk on the firmware built / downloaded from openwrt and the one downloaded from mtd3 and the one downloaded from mtd3 has an added jffs2 block ..

mtd3 block downloaded one

openwrt 17.01 built firmware

Not sure if you could tell anything from this... Please share your thoughts ..

mtd blocks are beyond my expertise, maybe @dlakelan, @mk24, @hnyman, @vgaetera have something to suggest.

1 Like

Make sure, you can use emergency function of bootloader.

After that write to firmware partition, NOT TOUCHING BOOTLOADER.