Upgrade ZBT-WE1326 Help!

Hi all.

I am a new subscriber.

Since 2018 I have been using LTe routers. I first had a WE3926, which I ended up bricking from wanting to update it. Then I have for two years, approximately, a ZBT-WE1326. I installed a Quectel EP06 modem, instead of the original Quectel EC25-E.
I can't remember what the original firmware was, but I remember updating to version 19, which worked fine automatically.

I would like today to flash the WE1326 which is under 19.1101, around 21.02, but I am not reassured following my misadventure with the WE3926.
I tried through the browser interface, but when I load the Ramips firmware, my router tells me that the program is incorrect for my device.

I searched just about everything, I think, on your forum, various sites and pages, but I didn't find many explanatory tutorials.

I'm far from being a computer whiz, as most of you here must be. As I do not master either the "command lines".

As I also pointed out in my description, I also have huge gaps in English, which does not make my case any easier.

Thank you in advance for your answers.

Best regards.

Start by posting a screen shot of the error message you're getting...

1 Like


Thank you for your reply.

Many thanks.

Try using an older image.


I just tried with the two available, from the link you sent me. Either way, I always get the same result.


Try reaching the web recovery described in ZBT WE1326 crashing with 18.06 image

Is that regular OpenWrt or a manufacturer build?

Upgrading a MT7621 device from 19 to 21 entails migrating from swconfig to DSA. That means you will need to force the upgrade and completely reconfigure the router starting from the defaults. An alternative Internet connection will be needed to install the modem drivers, since the modem not work without them.

I use BREED to upgrade OpenWrt reliably on a ZBT WE1326.

Hello everyone.

Sorry for these few days of "total" silence!
I would like to begin by thanking you all for paying attention to my discussion.

I finally managed to install version 21.02.1 X-WRT. I had already come across this sort of interface when I tried to upgrade my WE3926.

Unfortunately, my level of computer knowledge is very far from allowing me to configure it successfully.

To answer mk24, I think my build is manufacturer's. I tried to load the drivers for the EP06 modem, from my ADSL connection, but without success. I don't have your talent and your involvement, at all.

I will therefore try to return to the original ROM, of which I had made a "Backup" and which is within my "technical" range. (Hoping not to make irreparable mistakes)

Thank you, very humbly, to all, for your information and your voluntary assistance.

Best regards.

Good evening everyone.

If anyone on this earth has a "stock firmware" WE1326 that hasn't been flashed and can do a system image of their device, I would be delighted.
I will never try to upgrade again!
But I must be utopian.

Thank you all. :sweat_smile: :slightly_smiling_face:

The WE1326 is on this list: ROOter by Of Modems and Men

Bonjour Ă  tous.

Après avoir laissé mon routeur à l'abandon un bon moment, je m'y suis remis dessus. J'ai mis mon amour-propre de côté et je me suis résolu à contacter le vendeur market-place à qui j'ai acheté le ZBT WE1326.
Celui-ci, dans sa grande bienveillance, en contournant les restrictions du service de messagerie de la plateforme, m'a envoyé le firmware natif du routeur, à la date où je l'ai acheté.
J'ai donc pu flasher et revenir au firmware que je parviens à paramétrer facilement.

Je partage ici, un lien vers le firmware initial, car je ne dois pas être le seul à être confronté à ce problème.

ZBT WE1326 initial firmware

Je trouve dommage, que l'informatique et la programmation, ne soient pas en voie de démocratisation, ou du moins, à rendre ce genre d'opération plus accessible et facile au plus grand nombre.
J'espère que beaucoup, dans le même cas que moi, pourront avec ce lien récupérer leur routeur avec simplicité.
Je ne suis pas prèt de retenter, de reflasher!


Hello everyone.

After leaving my router abandoned for a while, I got back on it. I put my pride aside and decided to contact the market-place seller from whom I bought the ZBT WE1326.
This one, in his great benevolence, bypassing the restrictions of the messaging service of the platform, sent me the native firmware of the router, on the date when I bought it.
So I was able to flash and return to the firmware that I manage to configure easily.

I share here, a link to the initial firmware, because I must not be the only one facing this problem.

[The link above]

I find it unfortunate that computing and programming are not being democratized, or at least making this type of operation more accessible and easy to as many people as possible.
I hope that many, in the same case as me, will be able with this link to recover their router with simplicity.
I'm not ready to try again, to reflash!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.