Upgrade to version 21.02.0 for Mi Router 3 Pro Failed


Was running 19.07.7 version on this router and noticed in the wiki (https://openwrt.org/toh/xiaomi/mi_router_3_pro) new 21.02.0 was already available.

Decided to do upgrade for this version keeping the configuration.

Upgrade was accepted by router but the switch and wan stopped to work, seems it have different device names in this version.

Then I decided to procced with a factory install bin to have it clean and reconfigure all by hand and here is where starts the weird part.

It simply failed and router could not boot (brinked), it got stack with kernel panic error (unfortunately deleted by mistake the serial logs to share)

Moved then to TFTP restore and loaded initramfs.bin and worked fine except for Wireless, no wireless at all but at least all RJ45 worked.

Then decided to give it a new try and revert back to 19.07, restore backup, upgrade to 21.02 and correct manually the wrong config and finally got it all working

cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt 21.02.0 r16279-5cc0535800'

Can you tell me if I did something wrong or this version is not yet stable in this device?

Good to hear that you were able to recover the device.

The mt7621 has been changed to DSA switch architecture in 21.02. There is no guaranteed working migration path to take over existing switch config from older OpenWRT installations. If you upgrade an older version to 21.02 and do not wipe configuration, the switch sometimes does no longer work properly, as you have experienced. There must have been a warning displayed, recommending to not take over config.

You could have tried OpenWRT factory reset https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset, to reset the OpenWRT config to sane 21.02 defaults afterwards, to reenable the switch (but OpenWRT factory reset is not the same as flashing a factory image).

A device, which is already flashed to OpenWRT, most likely will brick, if you try to flash a factory image via OpenWRT flash function. You must only flash a sysupgrade image via OpenWRT flash functions. There must have been a warning that you have chosen to override.

The initramfs image purposely does not persist configuration, to avoid wearing down the flash memory with many writes during testing. When you reboot an initramfs device, it will always start with OpenWRT factory default config (LAN on, WiFi off)

1 Like

Thank you it makes sense.

After all reached the same, seems the main issue was after all the DSA switch architecture.

With this new mechanism switch config (tagging/vlan) is not allowed anymore?

It is allowed, but configuration is done differently than earlier.

1 Like

there are also some DSA wiki pages with work in progress.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.