Upgrade firmware on BT Home Hub

I had a BT Home Hub 5A and had OpenWrt 18.06.2 installed by an eBay seller some time in 2019. Been using it with PlusNet with no problems. Can I do an upgrade to 20.03.3 without any hassle? I do have computing experience but new to this. Many thanks.

probably need to reset the config, in the process, perhaps go to 19.07 1st.

I guess 20.03.3 = 22.03.3 ?

Many thanks. Yes, I did mean 22.03.3

@RickO88 , you should probably seriously think about it before updating to 22.03, because there is a serious bug with BT HH5A and 22.03 leading to an endless bootloop:


You may end up in transforming your nice BT Hub into a nice decoration accessory for your room :slight_smile:

Unknown when this bug is going to be resolved (probably the 27.xx release is a safe bet). I can't see much interest from others in doing so.

The latest stable release that is advisable to use in BT HH 5A is 21.02.5.


Should I just leave it at 18.06.2 as it is working well?

As @pstlr78 said, go to 21.02.

If I look for 21.02.5 I get the following:

Download OpenWrt Firmware for your Device
Type the name or model of your device, then select a stable build or the nightly "snapshot" build.
No model found!



Great! Many thanks.

One last question. Should I still update installing 19.07 first then 21.2.05?

Yes the release notes say

An upgrade from OpenWrt 19.07 to OpenWrt 21.02 is supported in many cases, including preserving configuration. A configuration backup is advised nonetheless when upgrading from OpenWrt 19.07.

Make sure you make backups along the way, just in case!

Having trouble. Can’t find proper 19.07 for this device. Can you help again? Thank you


I went to the root of releases and worked my way up


Many thanks again. I hope to learn this eventually!

I have upgraded BT Home Hub 5 as listed earlier going from 19.07 first then 21.2.05. Now when I try to log on to LUCI I get:
This connection is not private This website may be impersonating " to steal your personal or financial information.
So I cannot log into the router settings. Everything else is working, web, email, wi-fi etc.

I can log in to router settings but only if I say visit this website.

That is a browser warning about the self-signed certificate. If you see that when trying to visit a site on the Internet such as a bank, there is definitely a problem. But a local IP like must use a self-signed certificate. Depending on the browser there are ways to tell it to trust this particular site and you won't see the warning again for your router.

1 Like

The upgrade has meant your Luci is now using HTTPS. As mk24 mentioned, it's because the certificate used is a self signed certificate.

I just leave it as is and ignore the warning.

There are ways to generate your own certificate and make your browser trust it.

1 Like

[Solved] Many thanks to all for your help.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like