Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.3 (broken)

Edit 2020-05-22T16:02:04-07:00: Turns out this release was broken. See the new release linked at the bottom of this thread.

Device Support Status

This device is end-user ready. Wired and wireless works, LEDs work, buttons work, and factory image installation works. Testing has shown the system to be stable under load. I have a small collection of these devices operating in personal and business environments and they have proven to be reliable.

This document applies only to the 1.0R version of hardware. Other hardware revisions are not compatible nor supported by this release.

OpenWRT/LEDE Project leaders previously rejected all of my patches and I didn't see any situation where it was possible to get them merged so I gave up trying. If someone else wants to take my work and move on with it, you are welcome to do so.

Currently Known Issues

There are no significant issues specific to this device.

Factory installation via the OEM web interface is not supported yet because the install will revert after next reboot due to the Safe Upgrade/redundant partition system. However, there is a Recovery Loader in u-boot which is easy to use, so we can and should install our image that way instead.

The "LED on/off" button can't be made to work because we currently can't shut off the ethernet switch port LEDs. This may be fixed in the future if I am able to support it. The button currently does nothing, but it is configured in the DTS so you can write a script to use it if you want to. This button doesn't work under the OEM image either, so nothing lost.


The latest builds are based off the OpenWRT v19.07.3 (patch set v17) releases.

Minimal image files are here:

Minimal+luci image files are here:

You can download older builds and patches here:

The minimal builds have a basic bare-bone package set just like you would get from an official OpenWRT release image. You have roughly 45MB of free space on the overlay to work with. No LuCi web interface or anything else. Install the packages you want with opkg.

Luci builds are like the minimal builds, but with luci-ssl added to provide a web interface.

Recovery and Installation Instructions

Installing OpenWRT/LEDE on this device is very safe, relatively speaking, and it's easy to restore the OEM image if you want to go back.

This device offers three methods for installing images: The uboot http Recovery Loader, the OEM http upgrade tool, and console uboot tftp. However, installation by the OEM http upgrade tool is not yet fully supported.

Most users should use the uboot http Recovery Loader because it's easy and safe to use.

DO NOT use the OEM web/http upgrade page at this time. While the OEM upgrade tool will accept and install the OpenWRT/LEDE image, we don't yet support TRENDnet's "Fail Safe"/safeupgrade dual boot system, which means that the device will revert to the old OEM image after the second reboot.

Finally, you can install images via serial console uboot and tftp.

Be sure to download a copy of the OEM installation images in case you want to go back. See this post for more details.

uboot http Recovery Loader

Connect an ethernet cable from your PC/switch to any one of the ethernet jacks on the router. The Recovery Loader will not start if one of the ethernet ports doesn't go active/up during boot, so make sure you have a live cable plugged in before starting.

Manually configure your computer with an IP on the network. The router does not offer DHCP services in this mode.

Press and HOLD down the RESET button on power-up for five seconds. Then release the reset button.

The recovery page will be at at

The page should say "TRENDnet Recovery Mode" in blue text at the top and there is a "Choose File" button and "Upload" button.

If installing OpenWRT/LEDE, then upload the factory image file.

If you want to go back to the OEM image, use the OEM 1.00b11 firmware file (TEW827DRU_FW100B11.bin), then update to the latest version.

While the file is uploading, the Internet LED will blink. You can watch progress on the serial console too. Beware the progress/percent animation on the https Recovery Loader page is fake/placebo.

That's it. OpenWRT/LEDE should be up and running within 30 seconds of uploading the file. The OEM image takes about two minutes and boots very slowly (due to DFS).

If you are unable to access the Recovery Loader page, or if you upload a factory image and it doesn't install, be sure to read this post. The Recovery Loader is known to be a bit buggy.

OEM http upgrade tool

DO NOT use the OEM http upgrade tool at this time. While our factory image file conforms to the OEM requirements to be accepted and installed, we don't yet support TRENDnet's "Fail Safe"/safeupgrade redundant partition boot loader scheme. The result is that the device will successfully boot into OpenWRT/LEDE after the first reboot, but upon the second reboot it will revert to the old OEM system.

I plan to work on supporting the OEM http upgrade tool and the redundant partition system in the future, but I have not gotten around to it yet.

Console uboot tftp

The serial console on this device is fairly easy to access. A 3.3v/TTL serial port can be found in the corner next to the USB ports. You will need to soldier in header pins. Disassembling the chassis is not difficult.

JP1 = Rx
JP2 = Tx
JP3 = Ground
baud = 115200

uboot gives a 2-second "Hit any key to stop autoboot" prompt, so that's easy to break. No special key combo required.

This device uses a FIT archive file, which includes an installer script, a bootconfig image, and the UBI (kernel+squashfs+ubifs). All we really need to do is tftp the factory image into memory and execute the script embedded within it.

setenv ipaddr
setenv serverip
setenv netmask
tftpboot 0x42000000 openwrt-ipq806x-trendnet_tew827dru-squashfs-factory.bin
setenv imgaddr 0x42000000
source 0x42000000:script

Future Plans

JTAG recovery is something I want to do some day. It may be possible to recover from JTAG by booting from RAM or programming the NAND flash on this device. I've already experimented with this and had some progress but I've not yet figured everything out and I regret that I don't have time to work on it right now.

Expand the NAND partitions, or otherwise fully use the NAND flash space. The default "rootfs" partition is 64MB in size, but there is 108MB of completely-unused space on the NAND flash, outside of smem/mtd partitions. There is also an additional 64MB of space used by the redundant rootfs_1 partition. It may eventually be possible to have a rootfs file-system of 228MB in size. If you want to use that 108MB of free space right now, see this thread on how to set up and use the "freespace" partition.

Custom u-boot. This depends upon being able to safely recover. We would need either TRENDnet's broken "Fail Safe" system to be fixed, or JTAG recovery. Otherwise the risk of permanently breaking the device is too great.

Boot from USB. This is not possible right now because the OEM u-boot wasn't built with the right modules. This would require building a custom u-boot.

Previous Forum Threads and Old Development Info

In May of 2018 the old OpenWRT forum died due to negligent administration. Previously, this is where I had kept a running log of changes and updates for this device.

This new thread replaces and supersedes any information on the old forum, but you can still read the old thread for background information on how I ported the device, previous issues, and additional technical information.

The old forum thread can be read here:

The original (now potentially invalid) URL to the old forum was:

Then in 2019 the powers that be decided that it was a good idea to prevent the editing of forum posts after a short period of time, to combat some spam mechanics. Thus I intend to start a new thread for each new release since I can no longer edit my posts.

Previous release threads can be found here:

Hello fellow Jmomo! I was in version 19.07.2 working excellently but when I saw your new compilation 19.07.3 I decided to perform the update with the file squashfs-sysupgrade.bin ... Well it happens that the file is wrong or something is wrong because I go back to my version 19.07.2 after the process says it completes correctly, (with the factory settings without any configuration for a clean installation) what may be happening ??? Thank you! :cowboy_hat_face:

That sounds very strange. You are saying that the upgrade didn't upgrade, but that your settings were restored to defaults (overlay wiped).

I don't know what could cause that.

The strange thing about your statement is that you said the upgrade didn't work, and yet you also lost your configuration. That doesn't make sense based on the way I understand the sysupgrade process working.

I have about seven tew827dru routers that I upgraded a few days ago and they upgraded correctly.

Have you tried upgrading again? I hope you made a backup of your config before you ugpraded.

If you have any more info that might help me figure it out for you, please share.

Perform an update keeping the settings and did not go to version 19.07.3 only returned to 19.07.2 where it was. then I made an update but without preserving the configuration and the same thing happened I came back from where I never went which is 19.07.2 with the factory settings. I will try one more time.

I tried again and returned it was in OpenWrt 19.07.2 r10947-65030d81f3 / LuCI openwrt-19.07 branch git-20.057.55219-13dd17f

Please verify the sha256sum of the downloaded sysupgrade file to make sure it is not corrupted.

There is an interesting forum post here on recent troubles with sysupgrade:

You might want to try running a "sysupgrade -v" from the command line to get more information about why your sysupgrade is failing.

Unfortunately I don't have any idea why you might be having this trouble, given the information I have to work with.

Well do the following, I went back to the factory state of trendnet v1 using uboot http Recovery Loader, everything was correct you can see the original interface, then I went back to uboot http Recovery Loader and load openwrt-ipq806x-generic-trendnet_tew827dru-squashfs-factory.bin 2020-05-18. It loaded but not the v19.07.3 version but the v19.07.2 version tell me that the file hosted at is not the correct version, because I do not know what to think :stuck_out_tongue_winking_eye: ! Excuse me for bothering you Mr. Jmomo :innocent:

xfx, I want to make sure that I understand you correctly and that nothing has been lost in translation:

1.) You installed the OEM TEW827DRU_FW100B11.bin Trendnet firmware from the Recovery Loader.

2.) You verified that the OEM firmware was installed because you could access it's web interface and it was the Trendnet software.

3.) You then used the Recovery Loader to install my OpenWRT v19.07.3 firmware as documented in this post.

4.) After rebooting you found that the older OpenWRT v19.07.2 firmware was installed and running on your router, when you expected the newer v19.07.3 version to have been installed.

Is that all correct?

1 Like

what you affirm is 100% correct

Okay, thanks for the confirmation. Yes, that sounds confusing.

I don't want to get into too many deep technical details about how this device works, but it's possible that what you described is true. This router has a dual/redundant partition system, so both my OpenWRT and the OEM Trendnet firmware are on the NAND flash storage device at the same time, on separate partitions. I can imagine a few ways that we might end up in a situation like you are experiencing, but I don't have any idea how that is actually happening.

I want to get my test router out and try to find a way to reproduce your problem. I will respond in the next few days to let you know if I was able to do that.

If you technically qualified/knowledgeable enough to connect a serial console to get debugging output, that would be helpful.

1 Like

I really don't understand about programming or linux in general and I don't have a serial console. I understand what it explains because in the past when I installed openwrt for the first time I had to do it twice so that it could record, so to speak, because when I restarted openwrt it forgot the stock firmware in a magical way, I think that in one of your posts you mentioned something on this topic. After installing openwrt its version 19.07.2 twice or something like that I do not remember well, it was installed I thought it was due to the new firmware carried by you that worked. surely what happens with the NAND flash storage happens. I thank you for your time, I will try uboot http Recovery Loader a couple of times, if I succeed I will let you know! I will be looking at your project on a regular basis as I usually do to see if I can solve this problem! Thanks a lot!

Do this:

0.) A reset 30-30-30

1.) Install Trendnet OEM firmware TEW827DRU_FW100B11.bin from the recovery loader.

2.) He verified that the OEM firmware was installed because he could access its web interface and it was the Trendnet software.

3.) Then officially upgrade to Trendnet OEM TEW827DRU_FW105B01.bin firmware.

4.) After being in FW105B01 it restored the factory values officially. I am working as well.

5.) Then he used Recovery Loader to install my OpenWRT firmware v19.07.3 as documented in this post.

6.) After rebooting, you discovered that the old OpenWRT firmware v19.07.2 was installed and running on my router, when I was expecting the latest version of v19.07.3 to install.

I don't know what else to do ... I'll stay on 19.07.2 until a new compilation comes out. I hope this information is useful for you.

Well, this is embarrassing.

There is something wrong with my images. They are, in fact, based on v19.07.2.

Something must have gone wrong when I built them and I mistakenly used the wrong build source.

My apologies for having wasted your time. I will be building new images and publish them soon.

Thank you for reporting this.

1 Like

I have posted a new set of images here:

1 Like

Mr. Jmomo! problem solved use squashfs-sysupgrade.bin 2020-05-22 and I'm already running OpenWrt 19.07.3 r11063-85e04e9f46. Don't apologize it is a mistake that can happen to us, we are human. Thank you for making a new compilation so fast and for giving Openwrt to our router. Until another opportunity colleague. :partying_face: