Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R)


The latest builds are based off OpenWRT v23.05.3. My patch set is v20.

Sysupgrade and Factory image files are here:

You can download older builds and patches to build your own here:

My build has a basic bare-bone package set just like you would get from an official OpenWRT release image along with luci-ssl added to provide a web interface. A fresh install will have roughly 45MB of free space on the overlay for packages and files.

Device Support Status

This device is end-user ready. Wired and wireless works, LEDs work, buttons work, and factory image installation works. I have a small collection of these devices operating in personal and business environments and they have proven to be reliable.

This document applies only to the 1.0R version of hardware. Other hardware revisions are not compatible nor supported by this release.

OpenWRT/LEDE Project leaders previously rejected all of my patches and I didn't see any situation where it was possible to get them merged so I gave up trying. If someone else wants to take my work and move on with it, you are welcome to do so.

Currently Known Issues

There are no significant issues specific to this device.

Factory installation via the OEM web interface is not supported yet. However, there is a Recovery Loader built into u-boot which is easy to use, so we can install our image that way instead. The Recovery Loader isn't perfect, but it's safe and bricking this device is rather difficult to achieve.

The "LED on/off" button can't be made to work because we currently can't shut off the ethernet switch port LEDs. This may be fixed in the future if I am able to support it. The button currently does nothing, but it is configured in the DTS so you can write a script to use it if you want to. This button doesn't work under the OEM image either, so nothing lost.

I have seen some stability issues over long periods of time. Every once in awhile (30-90 days) I'll see a sudden reboot of one of the devices I manage. I don't think this issue is specific to the tew827dru hardware because I've seen similar reports on other ipq806x devices.

The ath10k 802.11/WiFi radio firmware and drivers have been very reliable for me. Ben Greear of Candela Tech (and other contributors) are constantly improving the code and there's been a lot of progress over the years.

Recovery and Installation Instructions

Installing OpenWRT/LEDE on this device is very safe, relatively speaking, and it's easy to restore the OEM image if you want to go back.

This device offers three methods for installing images: The uboot http Recovery Loader, the OEM http upgrade tool, and console uboot tftp. However, installation by the OEM http upgrade tool is not yet fully supported.

Most users should use the uboot http Recovery Loader because it's easy and safe to use.

DO NOT use the OEM web/http upgrade page at this time. While the OEM upgrade tool will accept and install the OpenWRT/LEDE image, we don't yet support TRENDnet's "Fail Safe"/safeupgrade dual boot system, which means that the device will revert to the old OEM image after the second reboot.

Finally, you can install images via serial console uboot and tftp.

Be sure to download a copy of the OEM installation images in case you want to go back. See this post for more details.

uboot http Recovery Loader

Connect an ethernet cable from your PC/switch to any one of the ethernet jacks on the router. The Recovery Loader will not start if one of the ethernet ports doesn't go active/up during boot, so make sure you have a live cable plugged in before starting.

Manually configure your computer with an IP on the network. The router does not offer DHCP services in this mode.

Press and HOLD down the RESET button on power-up for five seconds. Then release the reset button.

The recovery page will be at at

The page should say "TRENDnet Recovery Mode" in blue text at the top and there is a "Choose File" button and "Upload" button.

If installing OpenWRT/LEDE, then upload the factory image file.

If you want to go back to the OEM image, use the OEM 1.00b11 firmware file (TEW827DRU_FW100B11.bin), then update to the latest version.

While the file is uploading, the Internet LED will blink. You can watch progress on the serial console too. Beware the progress/percent animation on the https Recovery Loader page is fake/placebo.

That's it. OpenWRT/LEDE should be up and running within 30 seconds of uploading the file. The OEM image takes about two minutes and boots very slowly (due to DFS).

If you are unable to access the Recovery Loader page, or if you upload a factory image and it doesn't install, be sure to read this post. The Recovery Loader is known to be a bit buggy.

OEM http upgrade tool

DO NOT use the OEM http upgrade tool at this time. While our factory image file conforms to the OEM requirements to be accepted and installed, we don't yet support TRENDnet's "Fail Safe"/safeupgrade redundant partition boot loader scheme. The result is that the device will successfully boot into OpenWRT/LEDE after the first reboot, but upon the second reboot it will revert to the old OEM system.

I plan to work on supporting the OEM http upgrade tool and the redundant partition system in the future, but I have not gotten around to it yet.

Console uboot tftp

The serial console on this device is easy to access. A 3.3v-TTL serial port can be found in the corner next to the USB ports. You will need to soldier in header pins. Disassembling the chassis is not difficult.

JP1 = Rx
JP2 = Tx
JP3 = Ground
baud = 115200

uboot gives a 2-second "Hit any key to stop autoboot" prompt, so that's easy to break. No special key combo required.

This device uses a FIT archive file, which includes an installer script, a bootconfig image, and the UBI (kernel+squashfs+ubifs). All we really need to do is tftp the factory image into memory and execute the script embedded within it.

setenv ipaddr
setenv serverip
setenv netmask
tftpboot 0x42000000 openwrt-ipq806x-trendnet_tew827dru-squashfs-factory.bin
setenv imgaddr 0x42000000
source 0x42000000:script

Future Plans

JTAG recovery is something I want to do some day. It may be possible to recover from JTAG by booting from RAM or programming the NAND flash on this device. I've already experimented with this and had some progress but I've not yet figured everything out and I regret that I don't have time to work on it right now.

Expand the NAND partitions, or otherwise fully use the NAND flash space. The default "rootfs" partition is 64MB in size, but there is 108MB of completely-unused space on the NAND flash, outside of smem/mtd partitions. There is also an additional 64MB of space used by the redundant rootfs_1 partition. It may eventually be possible to have a rootfs file-system of 228MB in size. If you want to use that 108MB of free space right now, see this thread on how to set up and use the "freespace" partition.

Custom u-boot. This depends upon being able to safely recover. We would need either TRENDnet's broken "Fail Safe" system to be fixed, or JTAG recovery. Otherwise the risk of permanently breaking the device is too great.

Boot from USB. This is not possible right now because the OEM u-boot wasn't built with the right modules. This would require building a custom u-boot.

Previous Forum Threads and Old Development Info

In May of 2018 the old OpenWRT forum died due to negligent administration. Previously, this is where I had kept a running log of changes and updates for this device.

This new thread replaces and supersedes any information on the old forum, but you can still read the old thread for background information on how I ported the device, previous issues, and additional technical information.

The old forum thread can be read here:

The original (now potentially invalid) URL to the old forum was:

Previous release threads can be found here:

TRENDnet AC2600 (TEW-827DRU v1.0R)

Then in 2019 the powers that be decided that it was a good idea to prevent the editing of forum posts after a short period of time, to combat spam mechanics. As a result I started making a new thread for each new release since I could no longer edit my posts.

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v18.06.5

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v18.06.6 and v19.07.0

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v18.06.7 and v19.07.1

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v18.06.8 and v19.07.2

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.2 (ipq_nand fail fix)

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.3 (broken)

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.3 (working)

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.4

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.5

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.6

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.7

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v19.07.8

Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v21.02.0

And in late 2021 I am back to doing a single thread, which you are reading now.


Today I made this new thread. I'm going to be doing a single-thread again, so subscribe to notifications on this one if you want to get notified for new releases.

The latest build is based off OpenWRT v21.02.1.
My patch set is v18.

Hi, Thank You for your work! i'm facing problem with installation. With http recovery i'm getting error

"mime_content_body 360: Current_Length: 6295010 content_len: 6296408
mime_content_body 360: Current_Length: 6296034 content_len: 6296408
mime_content_body 360: Current_Length: 6297058 content_len: 6296408
Error: End boundary wrong
http_appcall() : send count down page
httpd_appcall 414 : Send file later len:1135:
Hit any key to stop autoboot:  0
## Executing script at 42000000
Bad FIT image format
resetting ..."

while by tftpd router not downloading image. tried newest factory and 19.07. can You help me? Thanks

Bad FIT image format

Can you try installing an older image version, and then you can sysupgrade to the newest version.

I have not tested the factory image in awhile. Maybe there's something wrong with v21.02 that I don't know about.

I'll do a test later today or tomorrow.

EDIT: Nevermind, I see that you tried v19.07 too.

I'll look at my documentation to see if I have any notes on your type of issue, but nothing comes to mind right away.

I've never seen errors like this before.

I would suggest you verify the hashes of the files to make sure you are downloading them correctly. Then, make sure there's nothing wrong with your local network which might be causing the file uploads to fail. The fact that TFTP also isn't working for you is a strong indication that this is a local-environment problem of some kind.

These errors make me think the file isn't being transferred across the network correctly, or the file itself is corrupt.

Hi, best new year wishes.
Finaly had some time to play with my trendnet, tried new cable and it went without any trouble with uart method. All work nice but speeds are not right since there is no hw offloading.
Thanks for Your work with adding suport for this nice router .

New build available.

The latest builds are based off OpenWRT v21.02.2. My patch set is v18.

Sysupgrade and Factory image files are here:

1 Like

Hi jmomo,

When you have some time, could you please take a look at adding NSS hardware acceleration support and build a separate image with NSS (for performance).

Thank you very much for wonderful builds for TEW-827DRU v1.0R.


Hi jmomo,

Do you have instructions on how to build images for TEW-827DRU v1.0R? I'd like to build my own images with my most commonly used packages.


I am aware of that project but my intention is to release an image that matches what you would get upstream in a standard OpenWRT release. It would be a lot of work to merge in all of that code and test it, and there's been a lot of stability quality problems with that project.

The NSS project should be working to get it's code upstreamed, but last I knew there was significant doubts that would ever happen because of the switch to DSA and other issues.

Google around for instructions on how to build a custom image. It's not that hard to do.

First you need your dependencies and the right environment. Probably the last major LTS version of Ubuntu should be your best bet. Then add whatever packages are needed. Again, google around for that.

git pull the OpenWRT repository, then download and apply my patches:

rm -f v??-0000-cover-letter.patch
for P in *.patch ; do echo "$P" ; git am < $P ; echo -- ; done ; unset P

Once you've applied my patches it's exactly like building any other ipq806x device.

Make sure to build with all kernel mods because your modules are specific to your kernel. You can't use the official package repos for kmods when you build your own.

Sample diff config here:

Googling around can tell you everything else you need to know. Good luck.

Hi Jmomo,

Thank you so much for the information. I will try it on my Archlinux laptop later this week.

Best regards,

Hi Jmomo,

I noticed that your TEW-827DRU images don't seem to work with IPv6. My ISP supports IPv6 but the TEW-827DRU's WAN interface can never acquire an IPv6 address. If I use r7500v2 / OpenWrt, it gets IPv6 address.


IPv6 is a required component of the base system, so it's not like anything is missing from my builds (as far as I know!).

Here's the official diffconfig:

Compare that to mine and it's basically the same for packages and the important stuff.

Maybe there's something special about your r7500v2 config that makes it work by default?

New build is up. v21.02.3. Same old patches. It's just security updates.

1 Like

Hi jmomo,

Have you tried to build images based off the recent 22.03 RCx branches using the existing patches v18? I plan to build new images using the 22.03 branch.

Thanks a lot.

I have not tried, and I doubt that the patches will apply because there's some significant differences.

I don't plan on building for any of the beta releases, but when the official release comes out I will start looking into it.

Thanks jmomo.

Please start looking into updating the patches soon since I believe that the official 22.03.01 will come out in several weeks. There have been some recent significant fixes (reverting the virtual time-based airtime scheduler back to the round-robin scheduler, plus enhancements, and multicast fixes) for WIFI to prevent high latencies in a few scenarios.

The excessive latency problem exists in 21.02.2, 21.02.3 when the VTBA scheduler was introduced into the mac80211 driver after the 21.02.1 release. I asked the developer (Felix/nbd) to commit his fixes to 21.02 branch as well so the next 21.02.4 will also have the fixes. Unfortunately, I don't think he will do so.


22.03.0 has become official.

I pulled source today and started looking at the diffs. It doesn't look too bad but I'm really busy right now. It might be a week or two but I'll get new builds and patches out soon.