Unable to Ping MT7628 OpenWRT 23.05.2 Server from A Client Despite Correct Network Configuration

Hello everyone,

I'm encountering an issue with my network setup where I cannot ping the OpenWRT server from a client device despite having configured the network settings correctly. Here are the details:

Issue Summary:
The network client cannot establish communication with the OpenWRT server at 192.168.1.1 despite being on the same subnet and connected via a direct CAT5 cable connection.

Network Configuration:

cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option force_link '1'
        option type  'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option igmp_snooping '1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'phy0-sta0'

config interface 'wwan'
        option proto 'dhcp'

ifconfig output:

ifconfig -a
br-lan    Link encap:Ethernet  HWaddr DA:A4:03:9D:2A:25
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::d8a4:3ff:fe9d:2a25/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:2386 (2.3 KiB)

eth0      Link encap:Ethernet  HWaddr DA:A4:03:9D:2A:25
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:118343 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74978 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10500444 (10.0 MiB)  TX bytes:24804443 (23.6 MiB)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:14255945 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14255945 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:968592362 (923.7 MiB)  TX bytes:968592362 (923.7 MiB)

phy0-ap0  Link encap:Ethernet  HWaddr 90:91:64:78:45:04
          inet6 addr: fe80::9291:64ff:fe78:4504/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:2560 (2.5 KiB)

wlan1     Link encap:Ethernet  HWaddr C4:31:6C:C5:42:3F
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

client cannot see the IP address 192.168.1.1:

ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4

Not sure where I got it wrong. I would appreciate it if you could shed some new light on my issue.

Thanks,
Steven

I see likely errors in the OpenWrt config... but before I suggest anything, I want to make sure we know what we're working with.

What is the output of

ubus call system board

Here is the output:

root@Mango_6246:/# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "Mango_6246",
        "system": "MediaTek MT7628AN ver:1 eco:2",
        "model": "Mediatek MT7628AN evaluation board",
        "board_name": "mediatek,mt7628an-eval-board",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}

This is up to date, but the config file that you posted in your first post is not consistent with the syntax of 23.05. Did you upgrade from a previous version and keep your settings?

The fastest way to fix this is to reset to defaults.

After restoring to the default version using the pre-compiled sysupgrade file - openwrt-23.05.2-ramips-mt76x8-mediatek_mt7628an-eval-board-squashfs-sysupgrade.bin, the issue is fixed.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.