Unable to block google ads

I am unable to block google ads. I have installed adblock+luci-app-adblock but still ads are not blocked. I am using Linksys ea8100 v2 snapshot.
Please suggest.


the client(s) run ?
what app(lication) ?

have you, if using android, blocked outgoing DoT and DoH requests in your FW ?
same goes for hardcoded DNS IPs, like

Google shares some of it's ad hosts with other, "relevant" content, if you block to much, you'll miss out on some the content, you might actually be interested in.

I used this a few months ago.. It's a pita. Read the dedicated support thread.

next post down izi is manually tagging items that slip through the block lists he has activated.

There was a bug with curl and wolfssl that causes packages like DNS over HTTPS and Adblock to stop working. They have fixed that meanwhile, make sure to use the latest snapshot!

I have reset my router configuration 2 times and tried multiple devices for ad block, no device blocking ad. It happens after i install usb configuration. If I tried it with fresh installation,it works, after apply usb share configuration, it stopped.

what usb configuration ?

opkg install kmod-usb-storage
opkg install kmod-usb-storage-uas
opkg install block-mount
opkg install kmod-usb-storage
opkg install kmod-fs-ext4
opkg install luci-app-ksmbd
opkg install ksmbd-utils
then reboot

so you're saying if stopped working, just because you installed all those modules ?

... and then told adblock to use the storage for cache????

1 Like

Yes, on first i have already installed adblock,
opkg install kmod-usb-storage
opkg install kmod-usb-storage-uas
------------- so on...

it works before usb installation after usb done its not working

I did the same and it killed my USB drive and soft bricked my MikroTic.

Once I got the 'Tik back up way back in March, I didn't have storage kmods installed and cared less about logging..

I just manually tagged items till I got tired of being on my router for something @frollic mentions above concerning ensuring my client browser were configured not to use DoT or DoH.

Ended up fresh installed w/o Adblock on the Tik and run in one NAT down on a Tomato router.

Long story short, don't log to USB/SD..

So @Bill & @frollic, what is the instruction to me working both usb+adblock?
I am not much technical.

the usb, dunno, but I'm sure there's an error message somewhere, you can dig into.
the blocking link is in the 1st reply.

are you guys have clear idea, which package giving issue here, so I'll try after uninstall the same

Cpu ~ Flash ~Ram
880 128NAND 256

Not Sure..
What do you intend to do with the USB kmod?
You obviously want to block ad's, that's what your thread is about.
Follow the advice and don't use large block lists, and don't write anything to removable memory from Adblock.

If you never configured Adblock to write to memory, I misunderstood you.

You could run dmesg and logread when you have both sets of packages installed, and post the results when you see things not working as expected.

Or you can search for different adblocking packages, remedies on the forum.