Ubiquiti Unifi UAP-AC-M

I have 2 new Ubiquity Unifi AC Mesh UAP-AC-M devices. I need a specific open wrt firmware (which I have) installed on them. I give up, locked boot loader etc. I have installed this several times in the past on Pico2 and on this same model(with pre 3.8 fw). Ubiquti will not let me downgrade. Willing to ship to you and pay via PayPal if there are any takers that KNOW how to accomplish this task.

To be used at an exiting mesh set up with Worldspot FW is a custom ver. openwrt-18.06-20180816-1

What methods have you tried? If you can't downgrade with CLI try TFTP recover an old version with the reset button.
I think that direct flash writing with the bootloader still works. That requires opening the case and using serial port. On other models there is also an enhanced TFTP recovery that can be started from the serial port which does more than starting with the reset button.
Of course the last resort would be to program the flash chip directly to replace the bootloader. You can dump the old bootloader from one of your working units.

Using 18.06 you're missing out on a lot of improvement to ath10k that has happened since then, unless it has been backported to that firmware.

I have read so much about this that I am over it. I have tried every method that I see available. PUTTY, SSH, SCP, TFTP. Everything that even seems to be close to working gives an error of wrong FW version. I would gladly ship these 2 units to you. The firmware I want is only due to an existing setup with Worldspot at an 85 acre campground. All but 1 unit is just a mesh repeater and the whole system works as is. I just need to add these 2 nodes. If i could just get original firmware to take below I believe ver 3.8. FILENAME: BZ.qca956x.v3.7.58.6385.170508.0957.bin
VERSION: I think I could install what I actually want. Thanks for you reply. I have read several of your previous posts etc.

Ideally try to find someone in your city or at least in your country to do it for you because for private parties to ship things tends to cost a lot.

Any desire to remote desktop. Video conference walk through? I would compensate for you time.

I'm not sure if it can be done without hardware intervention.

Though I do own a couple of those units which I have flashed back and forth between stock and OpenWrt and I don't remember it being any more complicated than downgrade to the 3.7.58 then flash, all via SSH.

If you're willing to keep trying I'd be glad to offer directions here.

I am willing and hardware intervention does not scare me at all. It will not allow me to downgrade following any instructions I have found. Every reboot goes back to stock.

Tell me what UniFi version is on yours now. If I have time tonight I'll flash one of mine to that version and then verify what needs to be done to get it to OpenWrt.

Is it possible me could text, FB messenger or any other way? I will power it back up and get version now.

current version

I've tested that, and had no problem downgrading to 3.7.58 with either the fwupdate.real or TFTP methods, and from there a straightforward mtd based install without opening the case. I have edited the device page. https://openwrt.org/toh/ubiquiti/unifiac

If your PC is Windows I would recommend the CLI ssh, scp, and tftp built into late versions of Windows 10 (though they need to be enabled with the control panel, which is beyond the scope of this forum and my limited Windows experience). These operate nearly identically to the Linux versions.

1 Like

This worked perfect. Thank you very, very much.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Cool I was wondering what happened to you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.