Trying to activate 802.11k and 802.11v with 19.07.6

Hi all,

as I find the support in hostapd.sh for v and k I like to activate it. But if I try to activate v my wifi driver will not start. k seems to be fine. But also some of the parameters seems not available in hostapd. Is this still not supported in stable release 19.7.6?

I am using a Netgear R7800 and like to support better roaming between 2.4 and 5Ghz wifi for Apple devices.

This configuration seems to work /etc/config/wireless

        option ieee80211k '1'
#       option ieee80211v '1'
        option wnm_sleep_mode '1'
        option bss_transition '1'
        option time_advertisement '2'
        option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'

This error occurs with ieee80211v enabled

 daemon.notice netifd: radio1 (2617): command failed: Not supported (-95)
Sun Feb 14 10:09:11 2021 user.notice mac80211: Failed command: iw phy phy1 set distance 0
Sun Feb 14 10:09:11 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Sun Feb 14 10:09:11 2021 daemon.err hostapd: Line 40: unknown configuration item 'wnm_sleep_mode'
Sun Feb 14 10:09:11 2021 daemon.err hostapd: Line 41: unknown configuration item 'bss_transition'
Sun Feb 14 10:09:11 2021 daemon.err hostapd: 2 errors found in configuration file '/var/run/hostapd-phy1.conf'
Sun Feb 14 10:09:11 2021 daemon.err hostapd: Failed to set up interface with /var/run/hostapd-phy1.conf
Sun Feb 14 10:09:11 2021 daemon.err hostapd: Failed to initialize interface
Sun Feb 14 10:09:11 2021 daemon.notice netifd: radio1 (2617): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 2374 path ()
Sun Feb 14 10:09:11 2021 daemon.notice netifd: radio1 (2617): Device setup failed: HOSTAPD_START_FAILED

Cheers,
Nils

According to 802.11k, 802.11v not working on 19.07.3
it does not work in 19.07, but maybe ask @Xtreme512 directly.

What packages have you installed for wpad/hostapd ?

Ok, as I found coding for this parameters I hoped it was implemented to a new release.

Hostapd-Common and wpad-Basic: 2019-08-08-ca8c2bd2-5

I do not think wpad-basic is enough. I would try with package wpad.

Hi, you are right. With wpad package the Wlan is running with that parameters. Do you know why is that not in the standard-firmware and perhaps how I can check what is transmitted by the AP to the clients?

I guess that is a matter of size. The image is kept as small as possible.

About your 2nd question:

Sorry, just saw that the github link points nowhere :frowning: .

I still tried to log wlan packages with wireshark but it is not possible with my AC wifi. The Airpcap driver is not updated so I have to buy one like Acrylic Wi-Fi Sniffer. I tried this before switching to OpenWRT as my Fritz.Box has problems with its Mesh and Apple Devices. So at least a log entry is enough but I cannot find any (but I am a OpenWRT beginner :wink: )

There has been quite some work on 802.11v/k in the master branch, it's probably fully working there.

1 Like

You have to use snapshot, it won't work on stable 19.07, maybe they are planning it for 20.00 releases. You can install wpad or wpad-openssl. No need for hostapd or wpa_supplicant because they are included in wpad.

80211k '1'
80211v '1'
option bss_transition '1'

You only need those parameters, these 2 will activate other needed parameters automatically. You can check hostapd manual on the web.

Some scripting is required for steering, I'm using my own script and I'm making it to be capable of running automatically on all APs then I will publish it here. In the meantime, you can try DAWN package or searching the forum you can do your own scripting.

2 Likes

Thanks, good to know.

Some questions to understand the procedures with OpenWRT snapshots:

  • Is it somehow possible to install snapshot package of wpad only in stable release to avoid problems with stability
  • Is it fine to simply install sysupgrade snapshot to avoid reconfiguring everything on top of the stable? I do not like to lost everything configured everytime I install something. But I documented it well with VPN, etc. :slight_smile:

I still read something about helper-script, will spend some thoughts before what is a better solution. But actually I am going to implement a script as I read many posts that DAWN is not stable (and also perhaps oversized with a single AP)

snapshots have always been stable for me and others afais. so just flash to it.
yes it can be frustrating to lose configs and reapplying them, so my recommendation is backup what you want and do a clean install, it might at first seems fine to run snapshot after stable release w/o clearing, but stability problems may occur on some settings being changed or added with the snapshot.

for backups, don't do the restore thing, copy and paste the lines to appropriate files instead. this is a bit longer but better for coming from stable release imo.

there's also a package (forgot its name) i never used it but it helps you to build a new snapshot fw with the existing packages you've installed, gets backup and flash it automatically. very convenient for people who try new snapshots often.

1 Like

Option ieee80211v was removed some time ago. This was the commit:

git.openwrt.org Git - hostapd: remove ieee80211v option

Hi.

As I understand configuration of the detailed setting will be enough to activate 802.11v with newest snapshot?!

By the way...using 802.11v and k with 19.7.6 will destabilise bad connections with Apple devices. My iPad will roam continuously between 2.4 and 5 GHz if Connection quality is bad. So I would not recommend to activate it with that version as it has not only no function it also influence reliability negatively.

Yes. I personally use option bss_transition '1' only, as the others are not really important. Don't forget to use fast roaming too. This is my relevant wireless config for 802.11k/r/v:

	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option ft_over_ds '1'
	option ieee80211k '1'
	option bss_transition '1'

There are a few users reporting instability problems with the ath10k ct firmware, particularly with Apple devices. I never had problems myself with Apple devices usind ath10k ct version but I switched to ath10k mainline driver+firmware a few months ago and it seems faster for me. Your R7800 is ath10k based (same router as mine), then maybe you may want give it a try?

Interesting, v and k option were enabling bss transition and neighbor, beacon reporting respectively. anyways, they can still enable those themselves, no big deal.

They just don't need to bother with wnm_sleep_mode, time_advertisement and time_zone.

And yes I forgot to tell that, please enable your 80211r, it is for fast transition between same ssid bands, after all you need 2 or more same ssid bands to steer in the first place.

You can enable it via gui, it's very easy, just tick the option in wireless setting for each radio that has the same ssid.

edit: I don't have problems with apple devices using steering, with or without ath10k-ct.
edit2: For range steering problems (client stuck on 5GHz even though signal is very bad etc.) you can check my thread for that, just set up basic_rates and supported_rates manually to higher for 5GHz. Recently, this option is added to snapshot GUI to my surprise as "cell coverage" but its setting is limited.

Hi,

I installed the snapshot it on a cheap TP-Link C6 to not loose internet. :slight_smile: But it works fine there. My Ipad roamed (range steering) between the bands without any interruption. I take it back to the router and after 30 seconds it switched back to 5Ghz. So looks good configured like above with 802.11r. But I did not checked if Wifi management packets are send or if it was simply luck. With that behaviour dawn is not necessary for me. But will install the sticky client script for "helping" my Alexas.

Cheers,
Nils

So what are the wireless settings that you used ( with respect to 802.11 r,v,k ) on this c6 ?

The same @rog listed in his post.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.