802.11k, 802.11v not working on 19.07.3

Archer C7 v5, I did:

uci set wireless.default_radio0.ieee80211v=1
uci set wireless.default_radio0.ieee80211k=1
uci set wireless.default_radio0.bss_transition=1
uci set wireless.default_radio1.ieee80211v=1
uci set wireless.default_radio1.ieee80211k=1
uci set wireless.default_radio1.bss_transition=1
uci commit

I have 802.11r turned on for both bands, same SSID and key etc. My Galaxy S9 which supports these protocols, doesnt go to 5GHz from 2.4GHz when the signal is excellent. Is there any other config that Im not aware of?

Would you be able to confirm which Galaxy S9 you own?
Mike Albano confirmed via pcap that the G960U version does not support the 802.11v bss transition: https://sites.google.com/a/mikealbano.com/clients/home

960F exynos eu model.

so i went to snapshot to try out DAWN for this. not sure if its working but phone cant go to 5ghz when i close to the AP, it needs wifi off and on again to connect 5ghz. going from 5ghz to 2ghz is very smooth though. im writing to the developer to get it working.

i also tried anom3's php script but it didnt even run on my device at all, giving php related errors no file or folder found -2.

nevermind, I just tried hostapd cli options and see it for myself, wrote a small script that just does what I want.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.