Travelmate support thread


#102

New URL: https://openwrt.org/toh/hootoo/hootoo_ht-tm05
The old page is for archival purposes only and doesn't receive any updates any more.


#103

Thanks! This is exactly what I was looking for. There are so many pages for openwrt. With the forums, wiki, main page, etc I was not sure really where to look for things or what's the latest. Except for the wiki, I could tell that was no longer being maintained.

Is there a good place to look for comments made by users that have installed it? Trials and tribulations that they have gone through. Things they like and/or don't like... Things that just simply don't work etc.

Thanks again for the link to what I needed!


#104

Hello,
I’m using Travelmate 1.0.2 on OpenWRT 17.01.5 and I have a doubt about keeping the connection active to prevent the captive portal request.
in fact Travelamet works vero well, but few minutes After my devices Don’t use the network, the captive portal is requested again at the next reuse.

Is there a way in which Travelmate can keep the connection active even without being used by devices connected in wifi?

The setting “Enable 'automatic' mode“ is on, but I don’t understand if it is this function (which in my case does not work).

Thanks in advance.


#105

Not in ancient 1.0.x release ... later travelmate versions keep the connection (behind a captive portal) alive. As a workaround (if OpenWrt 18.06 is really no option for you), you can add the following crontab entry (/etc/crontabs/root):

*/1 * * * *   /bin/uclient-fetch --timeout=10 --spider http://captive.apple.com >/dev/null 2>&1

After that change restart your cron service (/etc/init.d/cron restart). From now on every 60 seconds your router will request this captive portal URL to keep your connection alive.

Hope this helps!
Dirk


#106

I loaded OpenWRT into my TM-02 about a year ago using this image:

openwrt-ramips-rt305x-ht-tm02-squashfs-factory-r42649.bin

I have an alarm system connected to the ethernet port on the TM-02 which is connected to my WI-FI router. I am using this setup due to the difficulties of running an ethernet cable from my home router to the alarm panel location.

Every couple of days, the TM-02 looses its connection to the WI-FI router. The only way it reconnects is if I reboot the TM-02. I suspect this is happening because of the distance between the TM-02 and my main WI-FI router.

Is there any solution to this, so that the TM-02 will automatically reconnect to the WI-FI router if the connection drops?


#107

Sorry, Chaos Calmer is not supported.


#108

What is Chaos Calmer?


#109

Log in via ssh and you will see something like that:
cc

Quite old & unsupported ...


#110

Sorry, but I'm not a tech wizard. Can someone explain in non-gargon English what is going on with my TM-02 and if there is any solution to this?


#111

Does your problem have anything to do with the Travelmate package?


#112

I am not an Openwrt guru. I loaded the following image into the TM-02 using the instructions in another support thread about a year ago:

openwrt-ramips-rt305x-ht-tm02-squashfs-factory-r42649.bin

The problem that I am having is that with OpenWRT running, the TM-02 regularly drops the WI-FI connection to my home router (probably due to a marginal signal), and then never reconnects. The only way that I have figured out to reconnect is to reboot the TM-02.

Is there any solution to this (new version of OpenWRT??? or something else), that will automatically reconnect the WI-FI connection after it is dropped?


#113

Hi,
I have a doubt about the criterion of Travelmate (version 1.0.2 on OpenWRT 17.01.5) for selecting the network between multiple networks saved.
I have 2 networks saved in "Wireless Stations"; the first my favorite network (faster), the second is a network that I would use as backup.
if for a time the first network isn't available, Travelmate activates the second network and this is right.
But when the first network becomes available again, I would like that Travelmate leave the second network and go back to connect to the first.

Is it possible automatically go back to using the first network as soon as it is available again?

Thanks in advance


#114

No, an active WLAN switch is not (yet) implemented.


#115

I think that I found small issue. I have added third interface "radio2" (USB stick) and add on top of the list. It looks like it is not checked - not mentioned in the logs? What could be the reason? What I can check ?
Some logs:

Wed Oct  3 23:25:24 2018 user.info travelmate-1.2.3[1043]: travelmate instance started ::: action: start, pid: 1043
Wed Oct  3 23:25:29 2018 user.debug travelmate-1.2.3[1043]: f_jsnup::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -
Wed Oct  3 23:25:29 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: initial, name: -, status: false, quality: 0, connection: -, wait: 1, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:25:30 2018 user.debug travelmate-1.2.3[1043]: f_prep ::: config: default_radio0, mode: ap, network: lan, eap_rc: 0, radio: radio0, trm_radio: -, disabled:
Wed Oct  3 23:25:30 2018 user.debug travelmate-1.2.3[1043]: f_prep ::: config: cfg043579, mode: ap, network: lan, eap_rc: 0, radio: radio1, trm_radio: -, disabled:
Wed Oct  3 23:25:31 2018 user.debug travelmate-1.2.3[1043]: f_prep ::: config: cfg063579, mode: sta, network: trm_wwan, eap_rc: 0, radio: radio2, trm_radio: -, disabled: 1
Wed Oct  3 23:25:31 2018 user.debug travelmate-1.2.3[1043]: f_prep ::: config: cfg073579, mode: sta, network: trm_wwan, eap_rc: 0, radio: radio1, trm_radio: -, disabled: 1
Wed Oct  3 23:25:32 2018 user.debug travelmate-1.2.3[1043]: f_prep ::: config: cfg083579, mode: sta, network: trm_wwan, eap_rc: 0, radio: radio0, trm_radio: -, disabled: 1
Wed Oct  3 23:25:32 2018 user.debug travelmate-1.2.3[1043]: f_jsnup::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -
Wed Oct  3 23:25:47 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: dev, name:  radio0 radio1 radio2, status: running / not connected, quality: 0, connection: -, wait: 12, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:25:47 2018 user.debug travelmate-1.2.3[1043]: f_main ::: iwinfo: /usr/bin/iwinfo, dev_list:  radio0 radio1 radio2, sta_list:  cfg063579_radio2 cfg073579_radio1 cfg083579_radio0, faulty_list: -
Wed Oct  3 23:25:50 2018 user.debug travelmate-1.2.3[1043]: f_main ::: dev: radio0, scan_list: , cnt: 1, max_cnt: 3
Wed Oct  3 23:25:58 2018 user.debug travelmate-1.2.3[1043]: f_main ::: dev: radio0, scan_list: , cnt: 2, max_cnt: 3
Wed Oct  3 23:26:07 2018 user.debug travelmate-1.2.3[1043]: f_main ::: dev: radio0, scan_list: , cnt: 3, max_cnt: 3
Wed Oct  3 23:26:13 2018 user.debug travelmate-1.2.3[1043]: f_main ::: dev: radio1, scan_list: 70,96:0C:6D:AA:AA:EE,"GG1566364",67,94:0C:6D:AA:AA:EE,"PiotrWifi",50,34:CE:00:63:2C:C5,"GG1566364",47,A4:CA:A0:A0:BC:8E,"Huawei",44,F0:B4:29:59:41:AE,"GG_1566364",41,F0:B4:29:59:41:AF,"GG1566364",, cnt: 1, max_cnt: 3
Wed Oct  3 23:26:13 2018 user.debug travelmate-1.2.3[1043]: f_main ::: scan_quality: 70, scan_bssid: 96:0C:6D:AA:AA:EE, scan_essid: "GG1566364"
Wed Oct  3 23:26:25 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: sta, name: wlan1, status: true, quality: 64, connection: -, wait: 9, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:26:28 2018 user.debug travelmate-1.2.3[1043]: f_jsnup::: config: @wifi-iface[3], status: connected (net ok/64), sta_iface: trm_wwan, sta_radio: radio1, sta_essid: GG1566364, sta_bssid: -, faulty_list: -
Wed Oct  3 23:26:28 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: initial, name: wlan1, status: true, quality: 64, connection: net ok/64, wait: 1, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:26:28 2018 user.info travelmate-1.2.3[1043]: connected to uplink 'radio1/GG1566364/-' (Xiaomi MiWiFi Mini, OpenWrt SNAPSHOT r8216-885052fbfb)
Wed Oct  3 23:34:04 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: initial, name: wlan1, status: true, quality: 67, connection: net ok/64, wait: 1, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:35:05 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: initial, name: wlan1, status: true, quality: 70, connection: net ok/64, wait: 1, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:36:07 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: initial, name: wlan1, status: true, quality: 67, connection: net ok/64, wait: 1, max_wait: 30, min_quality: 20, captive: 1
Wed Oct  3 23:37:08 2018 user.debug travelmate-1.2.3[1043]: f_check::: mode: initial, name: wlan1, status: true, quality: 67, connection: net ok/64, wait: 1, max_wait: 30, min_quality: 20, captive: 1

#116

In first place travelmate iterates through the (hardcoded) radio list - radio0 up to radioN. Currently you can't change or prioritize that. As long as travelmate already found an uplink on radio1 your defined uplink on radio2 will never be reached. As a workaround you can limit travelmate to a dedicated radio, e.g. set trm_radio to 'radio2'. To make long story short, it's a known limitation and already on my todo list ...:wink:


#117

it works - thanks


#118

just a quick update: release 1.2.4 is now in master, which also provide the possibility to change the overall radio scanning order (e.g. 'radio1 radio2 radio0') via config option 'trm_radio'


#119

Hi guys,

Am I allowed to ask for an advice with regard to travel routers ?

Situation: As a happy travelmate user I'm actually using all time OpenVPN connections (split tunneling) to make sure my line is safe in hotels etc. My Archer c2600 is actually powerful enough but it's pretty big... my wndr3700v2 get's quite hot when using openvpn permanently at video streaming. And I'm a fan of connecting via 2.4GHz (WAN) and using 5GHz for my clients.

Question: I've seen the list of routers tested and it seems GL-AR750 and TP-Link WR902AC (v1,v3) could be candidates. But I'm not sure about the openvpn (AES-128/256-GCM) throughput.
Could you recommend me a tiny travel router ? (Do these get too hot or too weak antennas, hotels tend to provide lousy signals ?)

Thanks a lot in advance !

cheers blinton


#120

or should we wait until wireguard gets a standard ?


#121

Personally I use an AR750 with wireguard and mullvad vpn - works fast & quite stable. But I am using the vpn only for (not very demanding) business access, not for video streaming ...:wink: