Travelmate support thread


#82

Hi there.
I got a new glinet ar300m and installed the snapshot version of travelmate.
I had to manually setup the interface and wifi. Assigned it to the firewall but it says it isn't running. Internet access through the hotspot is working fine.
The log says: wwan uplink still connected
What can I do and what further information do you need?


#83

If something not working for you, please enable debug logging, restart travelmate and send the full travelmate related log via PM to me. Thanks.


#84

@stangri I've pushed Travelmate 1.2.1 just now (see https://github.com/openwrt/packages/pull/6600). Travelmate no longer rename faulty uplinks in /etc/config/wireless, but save uplink state in json runtime information. To reset the saved state simply restart travelmate processing. For further details & screenshots check the referenced PR.


#85

I can confirm that it works on the HT-TM02/Ravpower WD-02 device.

I do have a comment in that it seems to save the current AP status (connected/disabled) to Flash, which could cause wear, especially with the very small modifiable FS on this particular device.

I was once working independently on a project similar to this one (my code has since gone missing; I forget what computer had the most recent copy), and I managed to get it to make the change to the connection status, but leave it as an unsaved change (according to LuCi's status screen). (The issue I had was that it ALWAYS disabled WiFi; I never managed to get it to actually check if it was connected)

I'm pretty sure it was by leaving off the UCI Commit Wireless line and calling /sbin/wifi up instead. I'll be the first to admit that I have little idea how all the UCI stuff works in the background with the actual daemons, so that might not have been the working solution, though.


#86

I've reduced the commits to /etc/config/wireless to the absolute minimum (maybe there are even better approaches, of course). For a reliable solution/package which just works for most users you need at minimum one commit ... running with uncommitted changes is not a reliable way, at least in my opinion.

Just a personal note regarding wear levelling: In times of forthcoming OpenWrt releases like 18.06, I flash my travel router several times a day for intense testing ... so I really don't care of one commit to /etc/config/wireless ... :wink:


#87

Just for your information: the current travelmate version 1.2.1 (backend & frontend) are in mainline 18.06 tree, too and part of the next stable release - 18.06 will probably official announced in the next few hours.


#88

i'm checked into a hilton hotel tonight and for unknown reason i'm unable to reach the captive portal page even when travelmate shows i'm fully connected to the hotel wifi. i'm still on the travemate 1.20 and usually i can connect and reach the portal captive page without problem.

i know i will not be able to troubleshoot this since i will be checking out tomorrow morning. i won't be able to use the router tonight hence each individual device will have to connect directly with the vpn service. each of the devices browser was able to reach the captive portal when connected directly with the hotel wifi but not via travelmate. any thoughts?


#89

Just a rough guess: maybe an ip address conflict between hotel/cp subnet and your configured LAN network on the router.


#90

i'm connected directly to the hotel wifi with one of my devices and the device has been assigned an ip address of 172.20.9.110. the subnet mask looks a bit different than what i normally see, 255.255.240.0. default gateway is 172.20.1.1. how do i configure the LEDE router LAN network to match the hotel wifi subnet?


#91

That's a misunderstanding: hotel wifi subnet/cp and configured router LAN must differ, otherwise you'll run into multiple routing issues. Next time you stay at a hilton hotel (unaffordable in switzerland :smile: ), please provide the full travelmate debug logs via PM - thanks.


#92

Hi,
Had the same "phenotypical" problem like wrtboy during my vacation.
The captive portal didn't pop up via router (TP-LINK c2600, LEDE 17.01.4, tm 1.2.0?).
Neither on:

  • iPad 2017, iPhone SE with latest iOS
  • Android phone (with 7.1.2), 2 Android tablets (4.4.4 & 6.0)
    i.e. 5 possible devices and "OS-es"
    So I had to in via captive portal via a tablet and copy that MAC address "into the router"... meaning I sacrificed a device in order to get internet access.

I verified network and played around with various DNS providers (cloudflare, google, VPN providers' DNS,...)

and I'd love the travelmate would work because it's a great app !

What did I do wrong and what could have gone wrong ?

Thanks and cheers Blinton.


#93

I don't know ... :wink:
Please provide a full travelmate debug log and your /etc/config/dhcp (suppose you're using dnsmasq!?) via PM. Thanks!

Edit: Just curious, you're using a TP-LINK c2600 as travel router!? :wink:


#94

Hi dibdot,

Thanks for your quick reply. Let me see if I can retrieve the log (I doubt, because it's a few weeks ago... and I found a quick workaround...If I knew I would have taken attention to it...shame on me, but maybe I'm lucky :slight_smile: )

I need the c2600 dual core power as I use a permanent VPN connection as well as VPN tunnel splitting for specific WAN network ranges :slight_smile: through whatever WAN IP I get.

cheers Blinton


#95

OK, thanks for the quick follow up. Next time you run into these kind of troubles please provide the output of

uclient-fetch --timeout=10 --spider http://captive.apple.com 2>&1

as well. Thanks again.


#96

Hi dibdot,
perfect, thanks for the hint !
cheers Blinton


#97

Hi, I am trying to set up my travel router for the first time and having an issue getting it to connect to an AP that has 802.11w Management Frame Protection set to Required. I did install full wpad/hostapd: is there an option I am missing? The AP with frame protection set to Required is displayed red; switching the AP frame protection to Optional fixes the issue.


#98

A working 802.11w setup requires proper support for it on client & AP side ... e.g. one of my old notebook chipset doesn't support this properly, therefore i keep the wireless security option on AP side always "optional" to prevent connection issues - which are unrelated to travelmate.


#99

Yeah, likely not related. I thought that the client settings were wrong somehow, but I never considered that the driver/chipset might not be supporting this functionality to begin with. Thx for the clarification.


#100

I'm a first time user of OpenWrt. I have setup dd-wrt on an old router in the past and found it easy to do. I'm hoping OpenWrt is going to be just as easy. Browsing the forms and wiki I can not seem to find a tutorial of any type to walk me through the process. My device is the HooToo TM-05 Titan travel router. I was reading that Travelmate support my device and has a large following. So I was going to try and install that on my device (knowing it's a one way trip and hoping it does everything the stock firmware can do and then some). My main hope aside from avoiding making my device more useless is to be able to connect to a wifi network with the tm05 and use the NIC port built into it as a local lan (basicly making a cat5 to wifi adaptor).

The page I have been looking at was the Travelmate README.md page. Although straightforward, the readme page (Installation & Usage section) is very light on instructions for installing. Even the first step is daunting to me just because the package releases page has tons of files and I'm not sure what I need for my specific device.

I'm using a Windows 10 box to do the install with tools like Putty. Is there a good tutorial somewhere that walks a newcomer through the process of installing Travelmate (OpenWrt) on their HooToo TM-05 Titan device by chance?

Thanks!


#101

Well, that device was never officially supported by OpenWrt ... of course, you could flash an image for the GL-MT300n (which uses the same hardware) via TFTP. Installation instructions are here, last chapter "WIP OpenWrt install". After that you can upgrade via usual "sysupgrade" to latest 18.06.1 release - the suitable firmware is located here.

Said that, this is (very) challenging for a newcomer ... anyway, good luck! :wink:

Edit: Updated the first link, thanks @tmomas