Transmission always reports listening port closed?

I'm not sure what I am doing wrong here, but I've installed Transmission and I cannot get it to see the listening port as open. The one snafu in my config is that my Transmission device is not the same hardware as my router. Regardless, I would expect it to work, as my router has port forwarding setup to the IP of my transmission device. Both run LEDE. Ideas?

some ideas:

  • You may have additional firewall in the other device (where transmission runs).
  • If you test the openness locally, you need also a working reflection rule, so that the test packet from transmission first goes out to the router's outer internet interface (not 192.168.1.x, but 234.234.whatever...) and then travel back via port-forwarding. Otherwise transmission may just misdetect the open port as closed. (I think that reflection rule is usually added automatically for port-forwards, but if you have more complex network structure, something may be missing.)

..or just double NAT or something fun. :slight_smile:

I am running transmission on my router and have the same issue. No idea how to solve the problem. It worked fine on dd wrt with the same firewall rules.

Yeah, strange. I have no firewall, and have a static IP assigned to my transmission device - no NAT afaik. That said, it downloads torrents pronto, so I'm going to ignore it.

There was a bug in Transmission that falsely reported open port as closed. Are you sure that the port in question is really closed?

I can test the port with GRC and it shows as open. There is a forwarding rule on my gateway device that sends those packets to my Transmission machine. Transmission is set to run on that port, so it should be fine. Transmission says the port is closed, but it is working just fine.

I still have the same problem - Transmission says port is closed no matter what I do.

What version of TRansmission had the bug that always listed the port as closed? When did they fix it?

I also have the same problem with OpenWrt CC, has anyone solved it ? Please mention my name if any of you has solved it. Thank you

I still have the issue, even after updating both routers to LEDE 17.01.2.

Well, I kinda gave up. I am having this problem for past ..... Id say 4 years. Back in a day when I was using dd-wrt I had IDEANTICAL problem and after about 100 posts about and people simply had no idea what to do I found solution. One day out of blue someone PM me a code and guess what, it worked. Right away I saw port open in web interface and using transmission-remote -pt command.

Code was:

/usr/sbin/iptables -I INPUT 1 -p tcp --dport 60180 -j logaccept

At that time I had 60180 port in my transmission. And everything was LALA Land. And then I switched to OpenWRT because of MAAAANY issues with dd-wrt and that code no longer worked and since then no matter what I did and whoever I asked.
Only answer I've got so far is: "this is a bug in transmission-daemon" it's incorrectly showing open port as closed. But in reality I am getting 0 seed / 0 peers when same torrent get like 400 seeds and 1200 peers on my utorrent.
So I am not buying it that transmission people can't fix it's program for over 4 years now.

Way I see it we need simply syntax that will REALLY open port we need, because that firewall GUI is not working , I mean it never worked because in dd-wrt without code I had same issues ......

So, anyone can help ? (I lost hope but who knows) .......

chees !

Hm, that is weird. when I disable firewall: it does not start working, so I doubt this has anything to do with that, but who knows. Just for the record, I did manage to download something with transmission on my router.

Hello once again. Download was never a problem, Seeding is. Basically after download is complete noone see you. I mean I tried something like Ubuntu ISO seed. Guess what, I managed to give out like 100 meg in 1 hour when my utorrent or any other windows torrent client full blasting if I let it. Really big problem for years now. I don't understand what is happening.

Does anyone have a solution ? I mean why noone can't figure our why ports are always closed in transmission even if no firewall or open port in settings and canyouseeme showinfgall good and you're indeed visible.

Anyone ?

I don' t have an answer, just the same a question. How to forward ports? Same closed port problem for me, this is my first post and my first LEDE and any other modem/router custom install.
LEDE is on my 2nd router, without DHCP with a static IP, DHCP and DNS is on the 1st modem/router. Port 51413 is open on the 1st and 2nd router, TCP/UDP both routers. But Transmission Remote GUI (transgui) says 51413 is closed. My PC takes LAN from the 1st and has it' s own port open for Transmission (transmission-gtk), which works fine letting upload torrents.
I hope if someone finds a solution will post it, Transmission is one of the reasons I flashed LEDE.
iptables -L | grep 51413
returns nothing for me...

It should not be an input rule, it should be a forward rule, unless the Transmission client is on the router itself.

Can the OP post their firewall rule?

All my port forwards, including for Transmission, work.

Like I said, I am a non-expert, just a little-advanced user. So I don't understand the difference between input rule and forward rule. I found:

root@LEDE:~# iptables -L | grep 51413
ACCEPT tcp -- anywhere anywhere tcp dpt:51413 /* !fw3: tr /
ACCEPT udp -- anywhere anywhere udp dpt:51413 /
!fw3: tr */

Port is open, but transmission says it’s closed
and I thought that this command would give me some extra information about my open ports, but it didn't return any result (positive or negative).
Also, you say:

How did you do that, can you provide some helping advice?


Very simple:

  • input rules allow traffic to the LEDE router itself
  • forward (or 'redirect') rules send traffic to downstream devices need a forward rule.

config redirect
option target 'DNAT'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '51413'
option dest_port '51413'
option dest_ip ''
option name 'BitTorrent'


I just made a Port Forward (see above). I also make sure that the firewall is open on the PC running Transmission. Hope this helps.

OK... now I see I 'm not even "a little-advanced user", because I was asking:

while I should ask "How to set input rules?"
I should make more clear that I have trouble just with Transmission running on the 2nd router itself, not with Transmission at any PC.
I don't know which is and how to print the file that keeps these rules, just playing I did:
root@LEDE:/usr/sbin# nano iptables
root@LEDE:/usr/sbin# cat iptables
but the file seems encrypted...
Some previous posts where also about port problems with Transmission running on the LEDE device, so I 'll have the solution when they have it too.

@lleachii Are you running transmission on the router itself? That is the problem of this thred. Port forwarding for Transmissoin running on clients is working. See that attached screenshot, are you able to get hte port open there? Screenshot from 2017-12-15 13-29-29

I am not.

Not exactly...

  • Did you make a port forward on the first router, and the correct input rule on the second device?
  • If you have it setup on device 1 and device 2, are you using different port numbers for each?