Traceroute: NO OPT x!


If i try to do traceroute i am getting the following error:
traceroute: NO OPT x!
Ping is working

If i do the same trace from attached computer it is pass through the router so not a firewall issue.

I wonder what is the problem?

thank you

where do you get it, doing what ?

1 Like

It means that the software is likely receiving an ICMP - Administratively Prohibited message in reply to traces.

Good question!


But do you get an error???

  • Not necessarily you have a VPN or some other kinda tunnel or network interface, backup ISP, etc.?
  • The ICMP - Administratively Prohibited messages likely come from a far-end device

What are you pinging?

This leads me to further believe it's the far-end blocking you.

  • You may need to use the -s or -I arguments to specify the correct IP or interface, respectively.
  • :warning: You may need to use the -p argument to change the port range to pass thru - they're likely blocking commnon port ranges used in traceroute - I know because I silently drop them in thru network except for known users :wink:

Does help?

1 Like

well same:

root@BPRT-OWrt-01:~# traceroute -I
traceroute: NO OPT x!
root@BPRT-OWrt-01:~# traceroute -s tun0
traceroute: NO OPT x!

there is nothing in tcpdump
If i ping it is there

15:59:32.555784 IP > ICMP echo request, id 4373, seq 1, length 64
15:59:32.620213 IP > ICMP echo reply, id 4373, seq 1, length 64

so playwithtoys might be right with a bug. Just strange only me having it.

Depends. Which device are you using, and which build? A snapshot build, or a general release build?

If you're using a snapshot build (and bear in mind that bug was reported within the last day or two), is it possible that you're merely the first OpenWRT user of that particular build to notice the problem?

No, incorrect. That command would be:

traceroute -s

I based this from your working ping.

  • Please explain why you think the source IP is
  • You have -I on your OpenWrt version of traceroute (it's -i on my screen)???
  • :warning: Does you your firewall allow output from the interface?

snapshot for DLINK dir-882 and dir 842

openwrt-ramips-mt7621-dlink_dir-882-a1-squashfs..> 05-Mar-2021 11:37 5903836
openwrt-ramips-mt7621-dlink_dir-882-a1-squashfs..> 05-Mar-2021 11:37 6029904

openwrt-ath79-generic-dlink_dir-842-c1-squashfs..> 04-Mar-2021 07:00 5636148
openwrt-ath79-generic-dlink_dir-842-c1-squashfs..> 04-Mar-2021 07:00 5636404

both same behavior

without -I should use that ip
The other router know all the IP

root@GA-OWrt-01:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface         UG        0 0          0 br-lan UH        0 0          0 tun0 U         0 0          0 eth0.30   U         0 0          0 br-lan   U         0 0          0 br-VLAN_2_OM   U         0 0          0 br-VLAN_10   UG        0 0          0 tun0   U         0 0          0 br-VLAN_4_B_OM
root@BPRT-OWrt-01:~# traceroute -s
traceroute: NO OPT x!

also everything else working i can ping i can open web page ssh .....

  • So this is a VPN?
  • Does your router itself have a policy to use the device?
  • Again:


  • "The other router"?!??!?
  • What does this mean???

You are aware the SRC IP in your working Ping is describe your config.


It is not a routing issue. the direction where traceroute is done, know the network .Ping is using that as a source IP. Actually traceroute not use any of them it is not in the tcpdump. i done traceroute towards every attached network even for local ip, exactly same behavior.

traceroute: NO OPT x!

Both of my dir-882/dir-842 router has the same behavior.
Both updated there snapshot at 05-Mar-2021

I assume this is the problem
It was reported on busybox March 06, 2021,

I would try the fix as it is described but no tce-load, patch and make command on the router.

1 Like

I can confirm this is a regression of the latest busybox version 1.33.0.
Even running traceroute without any parameters prints the same error message instead of help message.

root@OpenWrt:~# traceroute
traceroute: NO OPT x!
root@OpenWrt:~# traceroute6
traceroute6: NO OPT x!

Same error here.


They closed it though....

Presumably because of, is my guess.


Busybox 1.33 branch log shows that the fix has been backported to 1.33 branch today :wink:


My patch to fix the issue has been merged to OpenWrt master and 21.02 today.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.