TP-LINK WR740N Can't install luci-app-sqm package

Hi guys,I am new to all this and have no experience with linux. So after installing LEDE on my router I tried installing luci-app-sqm for SQM and I got an error saying No space left on device! please I really need SQM. I tried to reset the device and no luck. Anyway to fix this?

two things:

  1. I think the router is to slow for sqm
  2. I also think you should get a new router with more ram and flash

I do have Sagem F@st2704N with usb support , But it's bricked.
would it suit the SQM? and how can I unbrick it? thank you for responding.

After you have overfilled the JFFS, your best bet is to re-flash and start over.

You will need to use Image Builder to make a custom image, take something out and make space. Or enlarge the flash.

Suggested reading regarding devices with low flash/RAM (yes, you should read them all and thoroughly.):

1 Like

It has 8MB flash (you will not get "No space left on device"), but only 333MHz CPU.
I doubt that this is better than 4/32MB and 400+MHz CPU in the TL-WR740N.

If you are looking for a new device suitable for SQM, take a look at

1 Like

The performance you need depends on the ISP speed. I have 6/0.75 Mbps ADSL lines with which a 200 MHz MIPS can readily keep up. And SQM is essential to optimize performance.

1 Like

It would be great if I could rebuild my image into a more fit version... But I'm not familiar with coding and using SDK. I'll try to learn how to but I doubt I'll be able to edit that image anytime soon. Thanks for the advices anyway.

Yes actually I have 9/1 Mbps ADSL. But the issue remains in space...

As this router doesn't have a USB port, so you have only one option that is installing package on network storage. I guess that would help you..


It's because of space issues, check my custom builds include SQM with support for TP-LINK routers with 4MB Flash

LEDE 17.01.6 complete custom build
Optimized build LEDE 17.01 / OpenWrt 18.06 / libreCMC for "small devices"