TP-LINK TL-WR841nd v8/v7 30dBm hack - OpenWrt 18.06.1

Ciao,

I initially wanted to build an OpenWrt 18.06.1 custom build for WRT841 v7/v8 with "wpad" instead of "mini-wpad" to support IEEE 802.1x/EAP. I need to convert this indoor router to an outdoor router wit 802.1X support.

That went well with all posts around and then i read that we can ArtHack the eeprom to increase
txpower power.

So as written, i created a custom build with unlocked art partition and flashed it.
Afterwards i executed "mtd -r write /tmp/artHACKED.bin art" to update the art partition.

On the reboot WIFI was not started:
Sat Sep 29 21:03:38 2018 daemon.notice netifd: radio0 (1834): Could not find PHY for device 'radio0'
Sat Sep 29 21:03:39 2018 daemon.notice netifd: radio0 (1841): WARNING: Variable 'data' does not exist or is not an array/object

I tried Openwrt 15.05 same result (as this is the one which was referenced in the original post which is now archived https://forum.archive.openwrt.org/viewtopic.php?id=64111).

@TAKV wrote that:
It is working and these are the results:
841nd v7 ht-20 ch6 426.58mw
841nd v8 ht-20 ch6 332.005mw

@j.lefebvre59 wrote that:
I haved fixed the problem of wifi not starting. The artHacked force the country to US. If your global country is 00 ( World ) it doesn't start the WiFi interface binding.

I was not able to findout what he did and how this issue was solved.

Can anybody help ?

Thanks
Attaros

If it doesn't work, restore your backup.

The calibration data isn't there just to annoy you, besides being a legal requirement (you are voiding FCC/ ETSI/ … certification this way, which may incur hefty fines or even jail time) it does contain device specific correction factors at different operating points (frequency, temperature, delta, etc.) - and it also prevents the hardware from damage (it's very unlikely that the tl-wr841nd would be able to transmit at dBm, regardless of your setting - it's not unlikely that you overpower its amps, resulting in a distorted signal or even permanent hardware damage though).

1 Like

Thanks.

Well, i know that already.
I have a backup of the eeprom and restoring it then brings the wrt841 to work again.

This is not what i asked though (regulations depend on country, not everybody is in US or EU). Moreover this is a technical question which i am asking for which solution was already found and i am seeking it.

Your question violates the Community Guidelines. Modifying the radio post-manufacture is illegal in most countries, not just the US and in the EU; and for multiple reasons other than just power. For more information, see:

RADIO REGULATIONS - International Telecommunications Union - 2016 Edition - VOLUME I
CHAPTER I - Terminology and technical characteristics
ARTICLE 3 - Technical characteristics of stations

http://handle.itu.int/11.1002/pub/80da2b36-en

Also see: Reghack works in the latest stables versions of LEDE?

and: Linksys WRT1900AC v2 Reghack

You will have to, I understand this doesn't work in newer Kernels, anyway. So, you'll be running an outdated firmware with an illegal transmitter. I advise against that.

Can you share the hard hack build for wr841 v7 / v8 please!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.