TP-Link TL-WR841N(D), WA701N(D), WR740N(D), WR741N(D), WR743N(D), WR940N, WR941N(D) - LADUS / JULIA / Ultra Lite / VPN builds


#61

@hmd61551 maybe I dont need PPTP then hmm :confused:

Right what I want to do is make my network hidden for example from my ISP etc.... and then set-up a way to VPN in to my network from my works office. So I wasn't to sure how that works with me being connected to a VPN server and then still tunnelling in to my network that why I fought I needed PPTP as well. If I'm wrong remove the PPTP then.

And okay ill try that updated version, thanks again.

Update* I could ping 8.8.8.8/8.8.4.4 but couldn't ping google.com but when I uploaded my backed up config from Ultra Lite version i can connect to internet fine and ping address again(which has no changes apart from named WiFi and set Password and activated Wifi ( I'm plugged in to Ethernet tho so that shouldn't be issue))

Update-2* Just re flashed the Ultra Lite Build and even with no configuration what so ever so just flash image and leave it it works and can surf web fine etc.. So definitely something off with that build out of the box. due to fact I can ping a IP but not a web address I think there is something wrong with the DNS setup on that build but I dont really know that much about it to say really. but hopefully I have given you better understanding to try fix this. :stuck_out_tongue:


#62

@ykno
I found the problem and it should be fixed now. There was a DNS configuration problem.
Use the link in previous post.
I tested the connection and it pings just fine now. I just tested the build without setting up vpn connection and it worked so in theory you should be able to succesfully use it.
The updated build is with openvpn, ddns and pptp. If this works I could easily bring back sqm because it wasn´t the cause of the problem.


#63

Hi, I'm having issues with configuring VLAN for wan(eth1) interface.
The luci switch GUI doesn't have wan or eth1 j terrace to tag

Anyone can help?

Thanksl you


#64

@hmd61551 sorry I Havant got back to you sooner been long weekend. but ye I got it installed all working fine WiFi is strong as well no drops. as for basic function seems to be a working build, DDNS works I can ping to it all good. Havant tested VPN yet nor PPTP. will be testing PPTP this week.

In reference to adding back in SQM what is it like I have basic understanding of it but what benefits does it have and why would I need it?


#65

@ykno
Here you can find more information about SQM.

Let me know how vpn testing went.


#66

Builds are updated.

Check out the poll in the first post.


#67

@hmd61551 After looking more in to it I think we can remove PPTP from this build as it seems I can do everything I need with OpenVPN so I believe.

So yeah lets remove PPTP and add back in SQM,


#68

@hmd61551

Thanks for the update.
Can you explain what you call " master branch of LEDE" on JULIA build?
What is the difference between LADUS and LADDUS builds?

Regards.
Juliano


#69

Can U reduce the router boot time?


#70

@ykno Ok, tomorow I will make updated build with sqm. You will be able to use the original link in previous posts.

@julianocs Hey Juliano, I really appreciate your feedback. Bellow every download link in first post there is a button called Features. When you click on it, the list of features will come out and you can see what I did to make them.
LADUS is without IPv6 and with DNSCrypt(I use this build on my router); LADDUS is with IPv6, without DNSCrypt and with DDNS.
Master branch is similar to rolling linux distro, it is always updated and there are no releases, you can consider it development branch with bleeding edge software and patches. Here we have master branch and 17.01 branch and 17.01 branch is considered stable.
Someone correct me if I am wrong with this explanation.

@pra Can you make a sugestion on how to reduce boot time and I will try to implement it. I will also do some research and will see what I can do.


#71

Hi,
Any chance of squeezing mwan multiwan into this build?

Thanks


#72

Hello @hmd61551.

The minimun that i can to thanks your work is give this kind of feedback. :slight_smile:
When i ask the difference between the builds, i wasn´t talking about included features (you already explained this to me before), just about LEDE Branch. Your answer was very good and now i understand the difference.

Will continue use JULIA build...

Regards,
Juliano


#73

@hmd61551 Hi mate, Guessing you got busy,
but still haven't seen updated version with:
PPtP removed.
SQM added.


#74

Builds are updated.
Updates are late because there were internet issues in my building for past couple of days.

Ultra Lite is now with IPv6 support for better compatibility.
If you are upgrading from older build, do not keep settings.


#75

I released new OpenVPN build based on master branch.
It has OpenVPN, DDNS, SQM, UPnP, disabled IPv6...
Check it out in first post.

Feedback and sugestions are welcome.

@ykno Check out this new build in first post and let me know if it works for you.


#76

@hmd61551

Hello.
Thanks for update. Installed yesterday and everything is working.

About your new build with VPN, do you think that is possible include Ipv6? There's enough space?

Regards.


#77

Hi hmd61551,

Thanks is for the build you have share. Is there any chance to share your source code?

I'm trying to install mwan3 into your firmware but failed everytime due to out of memory

Hope to hear from you soon


#78

@julianocs
Thank you for your feedback.
I will try but I would like to get some feedback first from other users too.

EDIT: I tried and there is not enough space. Something has to go if I leave IPv6.

@lithoc
Source code? LEDE is open source, you can get it on github page of the project.
I include diffconfig in my download link if you were thinking about that.
Let me know which build and hardware version you are using and I will try to build it and give you a download link.


#79

Thanks for the feedback @hmd61551.
In this case, i will continue using JULIA build...

Regards.


#80

with your config.seed from ultra lite build I compiled LEDE for tplink 740n v4, all i did was change from multiple targets to my router. it is working without any problems so far. if anyone wants to try it dropbox . so thanks for config.seed, could you add this target to future builds since its same hw (minus one antenna)?

compared to ddwrt the luci webinterface is much slower(few seconds to load page), is that normal?