TP-Link TL-WR1043ND cannot be pinged after upgrade

LOL, as expected I cannot ping the TP-Link TL-WR1043ND after flashing from

OpenWrt 18.06.1, r7258-5eb055306f

to OpenWrt-19.07.7

1409f344a152c178ec14fac5d56e56d7 openwrt-19.07.7-ath79-generic-tplink_tl-wr1043nd-v1-squashfs-sysupgrade.bin

When flashing the router had the IP-address, the notebook got an IP-address via DHCP and I could connect via LUCI.

After half an hour I still see:

## System - Flashing...
The system is flashing now.
Wait a few minutes before you try to reconnect. It might be necessary to renew the address of your computer to reach the device again, depending on your settings.
![Loading]( Waiting for changes to be applied...

But for a very short moment something popped up like "network disconnected".

I assume after flashing and rebooting the router gets a new ip address. Default IP with openwrt is

I changed the notebook to a fixed ip: and see "ping not reachable"
Not sure what I have to enter for gateway. Tried and too as gateway.

Router was reset by plugging out / in the cable after a long time.The LEDs on the router do not blink, PWR and SYS is constant green.

What did I wrong?

Should have wiped the settings, since you migrated to ath79.

It should however still reply using the old IP.

1 Like

You are right, I could connect with the old ip now, but no idea, why this didn't work for the 1st time. It worked simply with going to DHCP back from the static address and removing all entries from the static part.

ssh root@
root@'s password: 

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 19.07.7, r11306-c4a6851c72

I was asked, if I want to migrate. I said yes. If I look at the files at /etc/config I can see the correct option key, but the wireless bridge doesn't work anymore,


you changed the wifi part, by switching to ath79.

If I were you, I'd run firstboot from ssh, to wipe the settings, and start from scratch.


Ok, done. But now I am unsure how to setup a wireless bridge, looks like there have been changes since the last years.

I found:

Using relayd as instructed in this article isn't guaranteed to work and only supports IPv4
The most common problem is that the client router cannot pass the DHCP message between the main router and the client connected to the client router. Currently it seems to be the hardware/SOC limitation (related to MAC cloning?)

I don't want to start with trial and error. Would be nice,, if you tell me or post a link how to setup a wireless bridged router.

The master, a Netgear R7800 uses OpenWrt 18.06

Use the Scan button, then join the network you want to be connected to.

1 Like

Thanks, I know the join-part, but there are other options, eg in interfaces, which have to be changed. I discussed this years ago and can't find this thread with google. I remember there was an old wiki or something like this which was partially wrong. Maybe the options were related to my situation only.


but you can always search for post made in your user name.

One thing you might need to install is relayd, perhaps it rings a bell.

What's the current status, what works, and what doesn't ?

I didn't find the thread I remember, but I found

I remember, that I have to do some other settings too.

I am very confused, it looks like everything works, but WDS-master and WDS-client are changed.

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/180c0000.wmac'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option key 'secret'
	option encryption 'psk2'
	option wds '1'
	option mode 'ap'
	option ssid 'Pa52'

config wifi-iface 'wifinet1'
	option wds '1'
	option ssid 'PaW4'
	option encryption 'psk2'
	option device 'radio0'
	option network 'lan'
	option key 'secret'
	option mode 'sta'

I didn't get it work with Luci, so I edited /etc/config/wireless and compared to the old configuration.

Pa52 is the wireless bridge client and PaW4 ist wireless bridge master. Luci tells me, that Pa52 is the master and PaW4 is the client.

If I change the fields in option mode it doesn't work anymore.

Here are other configurations I have changed:


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix '....:....:....::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask ''
	option ip6assign '60'
	option ipaddr ''
	option stp '1'
	option dns ''
	option gateway ''

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

I think the value of this option is new compared to 18.06 and therefore the migration didn't work, seems the rest is the same as before.

option path 'platform/ahb/180c0000.wmac'