Wireless Bridge with TP-Link TL-WR1043ND v1.8

OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
Atheros AR9132 rev 2
Kernel Version 4.9.120

I had a working wireless bridge with TP-Link TL-WR1043ND v1.8 and Backfire (10.03.1, r29592)

Now I flashed 2 TP-Link TL-WR1043ND v1.8 with OpenWrt 18.06.1, r7258-5eb055306f. I can't get it work and I am very confused, because I tried so much.

The situation is:

1st TP is connected with a LAN Port to a Fritzbox, which is connected to the internet. I call this router TP1

2nd TP has no connection to the Fritzbox and therefore I need a wireless bridge from TP2 to TP1.

The 1st goal is, to connect a mobile phone to TP2 which connects to TP1 and then to the Fritzbox to the internet

The 2nd goal is to connect a TV without Wifi to the LAN-Port of TP2, so the TV can connect to the Internet.

Lets talk about the mobile phone connection with TP2 1st.

DHCP is deactivated with TP1 and TP2, static addresses are used.

TP1 should work, I can connect a mobile phone and surf with the mobile phone in the internet.

Is there a howto for this situation? Especially how join should be used.

I have connected TP1 to a Linux-PC via Ethernet cable and have ssh-access.
I have connected TP2 to a netbook via Ethernet cable and have ssh-access.
So there is no wired connection between TP1 and TP2.

Given that they're on the same, current release and that they use Atheros wireless chips, you should just be able to connect them using WDS -- https://openwrt.org/docs/guide-user/network/wifi/atheroswds

Unless you've got good knowledge of what is and isn't needed in /etc/config/wireless, I would try the LuCI-based configuration first, as much of the /etc/config/wireless information on that page looks to be outdated / unnecessary.

Luci says Atheros AR9132 rev 2. I am comparing now with my settings and https://openwrt.org/docs/guide-user/network/wifi/atheroswds

Should I remove the wlan-settings and create a new one?

http://192.168.178.51/cgi-bin/luci/admin/network/network (client-wds) shows me an interface WWAN with DHCP. Should I set this as unmanaged?

I am not talking of the Wireless configuration of the client like described at https://openwrt.org/docs/guide-user/network/wifi/atheroswds

The wireless mode should be Client (WDS) and the Network in Interface Configuration has to be changed from wwan to lan . (screenshot)

Thank you for the link. The 1st goal is reached. I have a wireless bridge with 2 access points and I can connect to them with mobile phones.

Now there is the 2nd goal:

"The 2nd goal is to connect a TV without Wifi to the LAN-Port of TP2, so the TV can connect to the Internet."

Probably I have to setup another "thing".

Very strange, after hours the tv is recognized. So it looks like, that everything works now as expected. Here is my configuration:

Access Point
Hostname 1043v18-50
Model TP-Link TL-WR1043N/ND v1.8
Architecture Atheros AR9132 rev 2
Firmware Version OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
Kernel Version 4.9.120

root@1043v18-50:/etc/config# cat **network** 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '---:---:---::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.178.50'
	option gateway '192.168.178.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'none'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'
root@1043v18-50:/etc/config# cat **wireless** 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ath9k'
	option channel '5'
	option htmode 'HT40'
	option country 'NZ'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option wds '1'
	option ssid 'Pa04'
	option encryption 'psk2'
	option key 'pw'

Remote wireless station

Hostname 1043v18-51
Model TP-Link TL-WR1043N/ND v1.8
Architecture Atheros AR9132 rev 2
Firmware Version OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
Kernel Version 4.9.120

root@1043v18-51:/etc/config# cat **network** 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '...:...:...::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.178.51'
	option gateway '192.168.178.50'
	option stp '1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'none'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

config interface 'wwan'
	option proto 'none'
root@1043v18-51:/etc/config# cat **wireless** 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ath9k'
	option disabled '0'
	option channel '5'
	option legacy_rates '1'
	option country 'NZ'
	option htmode 'HT40'

config wifi-iface
	option ssid 'Pa04'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid 'aa:bb:cc:dd:ee:ff'
	option key 'pw'
	option wds '1'
	option network 'lan'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'Pa14'
	option network 'lan'
	option encryption 'psk2'
	option key 'pw'