TP-Link TL-WA801ND v5 Bricked after wrong install of OpenWrt

Hi, i tried to install OpenWRT with the file "openwrt-19.07.2-ramips-mt76x8-tplink_tl-wa801nd-v5-squashfs-sysupgrade.bin" with the stock GUI. That obviously bricked my TL-WA801ND v5. I tried to reflash the correct file "openwrt-19.07.2-ramips-mt76x8-tplink_tl-wa801nd-v5-squashfs-tftp-recovery.bin" after renaming it to "tp_recovery.bin" like i found nearly anywhere. Then i started on my win machine "tftp -i PUT tp_recovery.bin", plugged my device with a patchcable into my ethernet port, which i set to use dhcp (i also tried with assigning an ip address like with no gateway to it), and hold down the reset key like in the tftp docs, the device and my pc communicate with each other (indicated by a blinking transmission led on the port of my pc) but the device just reboots and stays in a bootloop. I also tried with softwares like DD-WRT tftp GUI, but it still reboots with all leds blinking and the lock led turning red.
Any other idea? Im a missing something? Other that im an idiot?

You need set your windows machine ip-address to, install and start tftp server. Don't forget to put tftp_recovery.bin into tftp server data directory.

Im using the one from windows and the file path is correct (the rename to tp_recovery.bin is stated in the docs for the device). Setting the ip to doesnt work either. After a while, while doing the boot to the tftp mode thingy, its says "connection request failed" on my console.

The Windows Firewall (or third-party firewalls) will block the TFTP server from working, you need to shut down any firewalls on the PC temporarily.

I did that already. Its always deactivated.

Antivirus software sometimes block network exchange too.

Im not using any antivirus software. On my newly setup linux machine (manjaro) i also get no luck in downloading the firmware from tftp. I installed atftp, downloaded the correct bin file to flash openwrt and renamed it to "tp_recovery.bin", placed that into /tftpboot and started via sudo systectl start atftp the tftp server. the ethernet interface is also set to, i can test with atftp to connect to the server(which works) but cannot "get tp_recovery.bin", i always get timeouts. I also started the daemon with "atftp /home/tenn0/Downloads/ --daemon" (the folder where the .bin is located), but still timeouts.
Oh and i connected the laptop and the ap with a ethernet switch.

As I understand tftp server is not functional. Check firewall settings.
Or install tftp-hpa.

Oh boy, i finally got it to flash. I copied the tp_recovery.bin to /srv/tftp/ and did "sudo chmod 777 /srv/tftp" then started tftpd and conected to it via tftp. After trying to "put tp_recovery.bin" it didnt say anything about timeouts, so i set the device into tftp mode and it worked. Thanks for helping boys/girls!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.