TP-Link TL-MR-3420 V3 Build


#21

Auch.. I noticed I didn't include stripped org. firmware. It should be this;
http://s000.tinyupload.com/index.php?file_id=78497726953326790091

This is non EU version.


#22

Use TFTP Server http://tftpd32.jounin.net/ to flash OpenWrt/LEDE, It's work. Then if want to revert back , use my stripped firmware.


#23

Thank you @Dave_LB and @ahmadrasyidsalims

I was successful in flashing with tftp. It appears that, for some reason, the lan connection does not work whereas the router interface can be accessed via wifi (I tried changing the IPs etc.)

That said, my goal was to have USB Tethering of android phone to the router and I was unable to achieve that. Consequently I flashed back to the stripped firmware.


#24

Tethering with an android phone. Hhmm.. It sure is possible, this guys doing that to;
http://ofmodemsandmen.com/supported.html

But not on the V3 yet. Needs to have a driver package, no experience with this.. You can make a request to them if they can build a V3 image for you.


#25

Just added the driver package on compile. But TL-MR3420-V3 only 4MB Flash, Maybe, you should be use firmware added extroot package or upgrade RAM/ROM (Advanced)

Extroot : https://wiki.openwrt.org/doc/howto/extroot


#26

@oakkar7
Thanks for your hardwork but i can't access Luci after flash version 1.ipconfig don't show IPv4 Default Gateway.


#27

Hi, I've installed the first version but I can't see the usb 3g dongle! What can I do?

Thanks a lot for your work!

Otto


#28

Where is the firmware was you use ? Of course If you use LEDE. cause LEDE not include LuCI. Try SSH use PuTTY


#29

Flash size of TL-MR3420-V3 only 4MB you should use firmware include extroot package (USB HUB) then install package usb dongle (modem)


#30

I used first version of oakkar7's build.Seem it brick modem, I can't access Luci, ping or telnet.


#31

Debrick using TFTP and flash with my own firmware... It's already available at my blog: http://www.kuchikamizake.net


#32

#33

:+1: Perfect


#34

Sorry for late reply.
My 1st version supports 3G usb dongle. I have tested with Huawei, ZTE (with Qualcomm chipset). This is my 3G interface config. Your may be differ on which usb dongle model/version. Please refer old openwrt wiki for 3G config.

https://wiki.openwrt.org/doc/recipes/3gdongle

config interface 'ppp0'
option ifname ppp0
option proto '3g'
option service 'umts'
option device '/dev/ttyUSB0'
option apn 'internet'
option pincode '1234'
option username ''
option password ''

try "usbmode" command in SSH/Telnet/Console. Here is my command and output. If USB/GSM device is not found, your modem may not be supported or required driver for it.

root@lede:/# usbmode -l
Found device: 12d1:1446 (Manufacturer: "Qualcomm, Incorporated", Product: "USB MMC Storage", Serial: "????????????")

root@lede:/# usbmode -s
[ 250.806576] usb 1-1: USB disconnect, device number 2
root@lede:/# [ 252.083282] usb 1-1: new full-speed USB device number 3 using ehci-platform
[ 252.252698] option 1-1:1.0: GSM modem (1-port) converter detected
[ 252.259417] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 252.283617] option 1-1:1.1: GSM modem (1-port) converter detected
[ 252.290315] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 252.315099] option 1-1:1.2: GSM modem (1-port) converter detected
[ 252.321794] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[ 258.233428] 3g-wan2: renamed from ppp0


#35

Hi, sorry for late reply.
My 1st version supports both LAN/WiFi/3G and Luci. I've tested and flashed many time without no problem. When you power up devices, which LEDs are blinking? If more than 2 LEDs is blinking, your device may not brick.

Try failsafe mode.
https://www.youtube.com/watch?v=gqAYcR55wAk

(or) Debrick using TFTP like @ahmadrasyidsalims said.
http://forum.tp-link.com/showthread.php?81462-How-to-recovery-the-router-when-you-bricked-it

(3) Actually, I soldered UART terminal in JP1. It is more convenience in debugging. Pinout is as follows.
1 2 3 4
RX TX GND VCC

Here is the procedure flashing by UART/tftp.
https://techieilocano.wordpress.com/2015/02/22/howto-unbrick-mr3420-v2-and-most-tp-links-the-easy-way/

cheers,


#36

Hello,

Thank you for your hard work.

I've installed the first version too but when adding a new Network Interface I can't see in luci the UMTS/... protocol as an option to choose to configure a 3g connection.

Similarly I want to use mwan3 but it doesn't seem to be part of the installed packages.

Is there a firmware version with 3g and mwan support?

Tsara


#37

@oakkar7

Could you make a PR or so to add official support to LEDE?


#38

Hello.
I download these soft LEDE_TL-MR3420-V3_Luci_Bootstrap_3G_USB_Ext4_MWAN108 but i have a litlle problem. I have modem MF821 and i would like to install package like usb-modeswitch kmod-mii kmod-usb-net kmod-usb-wdm kmod-usb-net-qmi-wwan uqmi but i don't know where i find them.
Thanks
Have a nice day !


#39

Cause the image still not official support , yet. My suggest is if you want to install some package as you need, you should be build for your own or contact who was compile that firmware.

Or you can try this image http://www.mediafire.com/file/rok9992r7d6f04x/TL-MR3420-CC-3.18.45.zip . 500MB archive including kernel-module


#40

http://www.mediafire.com/file/rok9992r7d6f04x/TL-MR3420-CC-3.18.45.zip
I tried these image but I can't make exroot because i saw "out of memory". Could you make for me image etc. remove pppoe, ipv6 and other unimportant things. Meybe have you link to tutorial "know-how"? Package kmod-fs-ext4 and others take a lot of memory. Thanks for help.