TP-Link TL-MR-3420 V3 Build

I recently build TL-MR 3420 V3 firmware which was not yet supported by openwrt.
The board is very similar to V2 board but V3 is with new processor Qualcomm Atheros QCA9531.

My V3 Board specifics brief are as follows:

  • Qualcomm Atheros QCA9531 650MHz
  • 25Q32CS1G 4M
  • Zentel A3S56D40FTP -G5 32 MiB

I started with TL-MR 3420 V2 profile.
“Target System” ⇒ “Atheros AR7xxx/AR9xxx”
“Target Profile” ⇒ “TP-LINK TL-MR3420 v2”

Build success without showing any error.
Then I tried to build from stock web based firmware upgrade but failed with error 18005 because of TP-Link genuine firmware check hash.
So, I tried with serial/tftp flash method and flashing "lede-ar71xx-generic-tl-mr3420-v2-squashfs-factory.bin" was successful :slight_smile: . LEDE is booted checked from serial console.

Error : But when I check from serial console, ifconfig shows only lo interface. No Eth/Wan nor WLAN is up.

Tried ./etc/init.d/network reload and show error.

root@lede:/# /etc/init.d/network reload
Failed to connect to the switch. Use the "list" command to see which switches are available.
[   56.975151] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
'radio0' is disabled
'radio0' is disabled

Checked boot log and noticed errors.

[    0.115999] ar71xx: invalid MDIO id 1

[    1.414894] ag71xx ag71xx.0: invalid speed specified
[    1.420074] ag71xx: probe of ag71xx.0 failed with error -22
[    2.014883] ag71xx ag71xx.1: invalid speed specified
[    2.020033] ag71xx: probe of ag71xx.1 failed with error -22

Seem Switch/Eth driver is failed to load. How can I add network support for my board. If someone has experience on this series, also let me know.


Actually, I don't have this router but I try build the firmware using this patch >

I think you should be try :joy:

thanks, I will try it.

Hi ahmadrasyidsalims and all,

I re-patch this manually in current lede build.
In "menuconfig", there is an option for "TL-MR3420 V3" profile. Good!!

This patch works basically,

  • "lede-ar71xx-generic-tl-mr3420-v3-squashfs-factory.bin" was flashed and booted without any error
  • LAN & WAN configured and works well now
  • status LED works but other LED not
  • USB storage is detected but 3G dongle not tested


  • like other 4Mib flash router, space left in overlay/roots_data lefts only 492k
  • no space to install luci nor USB support package

seem extroot is solution but I want to use 3G dongle for usb.

Anyway, I have to rebuild firmware with removing some packages.
And any suggestion for which packages should be removed??


LEDE isn't recomended for device 4MB
If you want to try you should be compile the firmware included extroot

And then you can install the package as you need

1 Like

You can strip PPPoE support, that's a big chunk; also IPv6 if you do not need it.

If you want to strip either PPPoE or IPv6, make sure you deselect the top LuCI entry as well, so you can deselect LuCI's PPPoE support (and I think the same applies to IPv6).

1 Like

[quote="oakkar7, post:4, topic:855, full:true"]like other 4Mib flash router, space left in overlay/roots_data lefts only 492k[/quote]you should be able to fit packages if you select them with "y" so they are integrated on build time. Build time integration compresses packages, 500k should be enough for luci and usb if integrated like that.

[quote]seem extroot is solution but I want to use 3G dongle for usb.[/quote]There are 3G/4G dongles with a microSD slot, you can do extroot there and be happy.
For example Huawei E3372h.
You can keep 3g/4g dongle tools in the extroot, as even if it does not detect the dongle's modem it will detect the usb storage on it fine, so it will extroot and then detect the modem too.

1 Like

Finally, tried to manage packages to fit in 4MiB. After removing some packages, custom build firmware worked fine with V-3 hardware.

For those who want to try, I build two versions. One for standalone and another for extroot support. Both versions removed ipv6 and pppoe supports.

  1. This version supports
  • Luci+bootstrap,
  • 3G, usb, and
  • ext-4 file system. Like @bobafetthotmail said, this version can detect SD card inside 3G-dongle.
  • And I added mwan+luci-app-mwan3 for multi-wan support. Tested this also worked (Failed-over worked, load balancing is not tested)
    Leaving about 104k space after flashed. Good point is you can still use extroot with this build (with ext-4, no vfat)


  1. This version-2 is especially for extroot
  • Luci+bootstrap,
  • usb, and ext-4 and VFAT file system. This version can also detect SD card inside 3G-dongle.
  • No mwan3 and no serial, no 3G dongle support. You can install whatever after extroot :slight_smile:
    Leaving about 76k space after flashed.


By the way, Dear LEDE admin and developers, LEDE aimed for flash at least 8MiB, right!. But the problem is these cheap routers with USB support only have mostly 4MiB. Pls also consider for devices with 4M flash for some transition time.

I like this 3420 router because this one is dead cheap and full featured. Some alternative like 3020 and 703 are also cheap but very small and no feature like eth-switch and little gpio.

thanks all,

ChaosCalmer 15.05.1
TP-Link TL-MR3420-V3
Modified a litte patch from LEDE

You can try my image from here >

1 Like

Thank you very much, I am trying it out now.

So far so good but I would like to have my WN-722N supported so installing kmod-ath9k-htc_3.18.45+2016-01-10-1_ar71xx.ipk at the moment. Fingers crossed that everything works as expected on this lede-ar71xx-generic-tl-mr3420-v3-squashfs-factory.bin (luci-bootstrap-ext4-3g) ... No idea what this sysupgrade is, I am a total noob with openWRT... First contact today :wink:

Okay, I'm stuck. Have a couple of these routers running latest firmware: mr3420v3_eu_3_16_9_up_boot(160412).bin
Trying to upload any OpenWRT/LEDE firmware, tried every bin file I've found, but all result in Error 18005. Changed names, etc. Any ideas?

This router (TL-MR3420-V3) has two version ie EN and EU .
And code 18005 is the EU region code, but if you really want to try, I think you can try through serial (USB TO TTL)


Stripped Firmware is here

Here my version of LEDE MR3420 and WN722N USB support for people who want to try dual radio setup but don't know or cannot compile;

To go back to the original mr3420v3 firmware (with stripped boot) is also included for convenience. (same procedure is needed as described here; .. I tested it and this works)

1 Like

I am sorry to update that this firmware bricked my brand new MR3420 v3! :frowning:
The router has the power and LAN lights showing up correctly but no IP, SSH, telnet. I can't even get to fix it with TFTP.
Appreciate any help.

but no IP? Did you configured a static IP on your machine? And you cannot reach


Did you tried emergency rescue mode already? The 30-30-30 reset method. Then you can -only- telnet to the device. Power LED flashes like a disco light so fast when you are in this mode. =>

I needed to this a couple of times because I was messing about with bridge settings and made mistakes in IP numbering and couldn't get in.

But I've two of these MR3420 v3's and no problems here (other then own configuration mistakes in the admin panel).. Hm!

Thank you, the good news is I finally got to get back to factory through TFTP.
Emboldened, I am trying each of the builds here, but get a 18005 on all except yours - mine is EU :slight_smile:

Thinking of another try with your build... it should work on EU, right?

1 Like

Well.. I don't know.. I bought mine in the EU, Croatia to be exact.. But there is nowhere a sticker to be found that it's actually an EU model. So I am a bit confused about that. Does yours have it specified on the sticker?

(I actually ordered somebody else to buy this and didn't realize the antenna's on a V3 are designed to be permanent on this version. Wasn't amused with that discovery so I took a little saw to do some slight modification but it's not finished yet due to lack of pigtails...)

1 Like

Mine looks exactly same, though I bought it in India. But it appears that it is not possible to downgrade or flash with a different firmware once the latest tp-link EU one is applied. I get a 18005 with any firmware now!

The site says:

  1. For TL-MR3420(EU)V3.
  2. Your configuration will not be lost after upgrading this new firmware._
    3.The EU firmware was specialized for CE certificating and can’t be downgraded to other version, please click here for choosing your region and selecting the most suitable firmware version to upgrade.

Can you explain how to do this? I think I am now stuck with the latest EU tp-link firmware and can't flash anything else.