TP-Link TD-W8970B internet not working (LEDE v17.01.1)

I installed LEDE v17.01.1 on a TP-Link TD-W8970B router including a DSL modem. Everything went fine, WLAN is working. Anyhow, I cannot get the internet connection working. With the original firmware installed, it worked.

I think the most important lines in the log are the following:

Tue Apr 18 04:20:06 2017 daemon.notice netifd: Interface 'wan' is enabled
Tue Apr 18 04:20:06 2017 daemon.notice netifd: Interface 'wan' is setting up now
Tue Apr 18 04:20:06 2017 daemon.info pppd[25265]: Plugin rp-pppoe.so loaded.
Tue Apr 18 04:20:06 2017 daemon.info pppd[25265]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Tue Apr 18 04:20:06 2017 daemon.notice pppd[25265]: pppd 2.4.7 started by root, uid 0
Tue Apr 18 04:20:06 2017 daemon.debug pppd[25265]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Tue Apr 18 04:20:06 2017 daemon.debug pppd[25265]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Tue Apr 18 04:20:06 2017 daemon.debug pppd[25265]:  [service-name]
Tue Apr 18 04:20:11 2017 daemon.debug pppd[25265]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Tue Apr 18 04:20:11 2017 daemon.debug pppd[25265]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Tue Apr 18 04:20:11 2017 daemon.debug pppd[25265]:  [service-name]
Tue Apr 18 04:20:16 2017 daemon.debug pppd[25265]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Tue Apr 18 04:20:16 2017 daemon.debug pppd[25265]:  dst ff:ff:ff:ff:ff:ff  src 00:20:da:86:23:75
Tue Apr 18 04:20:16 2017 daemon.debug pppd[25265]:  [service-name]
Tue Apr 18 04:20:21 2017 daemon.warn pppd[25265]: Timeout waiting for PADO packets
Tue Apr 18 04:20:21 2017 daemon.err pppd[25265]: Unable to complete PPPoE Discovery
Tue Apr 18 04:20:21 2017 daemon.info pppd[25265]: Exit.
Tue Apr 18 04:20:22 2017 daemon.notice netifd: Interface 'wan' is now down
Tue Apr 18 04:20:22 2017 daemon.notice netifd: Interface 'wan' is disabled

My ISP is easybell.

My /etc/config/network file:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config dsl 'dsl'
        option firmware '/lib/firmware/lantiq-vrx200-b.bin'
        option annex 'b'
        option xfer_mode 'ptm'
        option line_mode 'adsl'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'ptm0'
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'XXX'                  
        option password 'XXX'       

config device 'wan_dev'
        option name 'ptm0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 4 5 6t'

My /etc/config/firewall file:

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan                    
        option proto            igmp                   
        option family           ipv4                   
        option target           ACCEPT                 
                                                   
# Allow DHCPv6 replies                                 
# see https://dev.openwrt.org/ticket/10381             
config rule                                            
        option name             Allow-DHCPv6           
        option src              wan                    
        option proto            udp                
        option src_ip           fc00::/6               
        option dest_ip          fc00::/6               
        option dest_port        546                    
        option family           ipv6                   
        option target           ACCEPT                 
                                                       
config rule                                            
        option name             Allow-MLD              
        option src              wan                    
        option proto            icmp                   
        option src_ip           fe80::/10              
        list icmp_type          '130/0'                
        list icmp_type          '131/0'                
        list icmp_type          '132/0'                
        list icmp_type          '143/0'                
        option family           ipv6                   
        option target           ACCEPT                 
                                                       
# Allow essential incoming IPv6 ICMP traffic           
config rule                                            
        option name             Allow-ICMPv6-Input     
        option src              wan                    
        option proto    icmp                           
        list icmp_type          echo-request          
        list icmp_type          echo-reply             
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big         
        list icmp_type          time-exceeded          
        list icmp_type          bad-header             
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation    
        list icmp_type          neighbour-solicitation 
        list icmp_type          router-advertisement   
        list icmp_type          neighbour-advertisement
        option limit            1000/sec            
        option family           ipv6
        option target           ACCEPT                 
                                                       
# Allow essential forwarded IPv6 ICMP traffic          
config rule                                            
        option name             Allow-ICMPv6-Forward   
        option src              wan                    
        option dest             *                      
        option proto            icmp                   
        list icmp_type          echo-request           
        list icmp_type          echo-reply             
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big         
        list icmp_type          time-exceeded         
        list icmp_type          bad-header             
        list icmp_type          unknown-header-type    
        option limit            1000/sec               
        option family           ipv6                   
        option target           ACCEPT                 
                                                       
# include a file with users custom iptables rules      
config include                                         
        option path /etc/firewall.user                 
                                                       
                                                       
### EXAMPLE CONFIG SECTIONS                            
# do not allow a specific ip to access wan             
#config rule                                           
#       option src              lan                    
#       option src_ip   192.168.45.2                   
#       option dest             wan                    
#       option proto    tcp                            
#       option target   REJECT                         
                                                       
# block a specific mac on wan                          
#config rule                                           
#       option dest             wan                    
#       option src_mac  00:11:22:33:44:66             
#       option target   REJECT                         
                                                       
# block incoming ICMP traffic on a zone                
#config rule                                           
#       option src              lan                    
#       option proto    ICMP                           
#       option target   DROP                           
                                                       
# port redirect port coming in on wan to lan           
#config redirect                                       
#       option src                      wan            
#       option src_dport        80
#       option dest                     lan            
#       option dest_ip          192.168.16.235         
#       option dest_port        80                     
#       option proto            tcp                    
                                                       
# port redirect of remapped ssh port (22001) on wan    
#config redirect                                       
#       option src              wan                    
#       option src_dport        22001                  
#       option dest             lan                    
#       option dest_port        22                     
#       option proto            tcp                   
                                                       
# allow IPsec/ESP and ISAKMP passthrough               
config rule                                            
        option src              wan                    
        option dest             lan                    
        option proto            esp                    
        option target           ACCEPT                 
                                                       
config rule                                            
        option src              wan                    
        option dest             lan                    
        option dest_port        500                    
        option proto            udp                    
        option target           ACCEPT                 
                                                       
### FULL CONFIG SECTIONS                               
#config rule                                           
#       option src              lan                    
#       option src_ip   192.168.45.2                   
#       option src_mac  00:11:22:33:44:55              
#       option src_port 80                             
#       option dest             wan                    
#       option dest_ip  194.25.2.129                   
#       option dest_port        120                   
#       option proto    tcp                            
#       option target   REJECT                         
                                                       
#config redirect                                       
#       option src              lan                    
#       option src_ip   192.168.45.2                   
#       option src_mac  00:11:22:33:44:55              
#       option src_port         1024                   
#       option src_dport        80                     
#       option dest_ip  194.25.2.129                   
#       option dest_port        120                    
#       option proto    tcp

Any help would be appreciated!

German use:

  1. ADSL2(+) ATM & VDSL2 use PTM
  2. Near all german provider use VLAN for easybell ist allways VLAN vid 7

I have this device to but never used it with adsl

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged

config dsl 'dsl'
        option annex 'b'
        option xfer_mode 'atm'
        option line_mode 'adsl'

config interface 'wan'
        option ifname 'nas0.7' 
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'XXX'                  
        option password 'XXX'

I dont now if this wan ifname "nas0.7" is supported this way its not working try nas0

Thank you very much for your reply!

I changed my configuration file, now it looks like this:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config dsl 'dsl'
        option firmware '/lib/firmware/lantiq-vrx200-b.bin'
        option xfer_mode 'atm'
        option line_mode 'adsl'
        option annex 'b'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'ptm0'
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'XXX'
        option password 'XXX'

config device 'wan_dev'
        option name 'ptm0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
                            
config switch_vlan
        option device 'switch0'                
        option vlan '1'                        
        option ports '0 2 4 5 6t'   
                             
config atm-bridge              
#       option unit '0'       
#       option atmdev '0'        
        option encaps 'llc'  
        option payload 'bridged'
        option vci '32'       
        option vpi '1'

Renaming to "nas0.7" or "nas.0" did not work, ifconfig did not show any interface anymore.

I'm afraid this did not help, the internet connection still is not working. The error message is still the same as before.

What does it mean that easybell uses VLAN 7? How can i configure my router to use VLAN 7?

Virtual Local Area Network (VLAN)
To make it easy to describe, it is to put one real network to divide into several virtual ones.
Internet pppoe work over VLAN id 7
Here a German weblink easybell

You get even a ADSL sync ?
Use option firmware only you put manual a firmware binary to /lib/firmware

config dsl 'dsl'
option xfer_mode 'atm'
option line_mode 'adsl'
option annex 'b' # this option setup the firmware for you

config interface 'wan'
option ifname 'nas0'
option proto 'pppoe'
option username 'XXX'
option password 'XXX'

config atm-bridge
option encaps 'llc'
option payload 'bridged'
option vci '32'
option vpi '1'

give me please output with this config after reboot ~ 3 min.

/etc/init.d/dsl_control status
ip link
opkg list-installed
logread # dont forget remove private date

The internet is working now, thank you very much!

I think the problem was the firmware I configured. I read the tutorial from OpenWRT, which was a little misleading. That is why I added the line

option firmware '/lib/firmware/lantiq-vrx200-b.bin'

to the config file. Without this line, it works! :slight_smile:

Good :slight_smile:

Hi guys, I have a very similar issue to the original poster. Wonder if you can help.

My ISP: Eir (Ireland)
My Router: Linksys E4200v2
Current Firmware: LEDE 17.01.0-rc2
Type of Internet: Fibre to The Home
Settings: From here

To connect your third party router to Eircom, you will need to apply the following settings.
Encapsulation PPPoE
Multiplexing	LLC
VPI	8
VCI	35
User name	eircom@eircom.net   (eir@eir.ie will also work)
Password	broadband1
VLAN tagging	Enabled
VLAN ID	10

Now, I have been trying various different methods to get this router to connect over PPPoE but fail each time.

Wed Jul 12 07:46:19 2017 kern.info kernel: [  167.292144] mv643xx_eth_port mv643xx_eth_port.1 eth1: link up, 1000 Mb/s, full duplex, flow control disabled
Wed Jul 12 07:46:19 2017 daemon.notice netifd: Interface 'wan' is enabled
Wed Jul 12 07:46:19 2017 daemon.notice netifd: Interface 'wan' is setting up now
Wed Jul 12 07:46:19 2017 daemon.info pppd[6151]: Plugin rp-pppoe.so loaded.
Wed Jul 12 07:46:19 2017 daemon.info pppd[6151]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Jul 12 07:46:19 2017 daemon.notice pppd[6151]: pppd 2.4.7 started by root, uid 0
Wed Jul 12 07:46:19 2017 daemon.debug pppd[6151]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 07:46:19 2017 daemon.debug pppd[6151]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 07:46:19 2017 daemon.debug pppd[6151]:  [service-name]
Wed Jul 12 07:46:24 2017 daemon.debug pppd[6151]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 07:46:24 2017 daemon.debug pppd[6151]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 07:46:24 2017 daemon.debug pppd[6151]:  [service-name]
Wed Jul 12 07:46:25 2017 daemon.warn dnsmasq[2492]: possible DNS-rebind attack detected: p28-ckdatabase.fe.apple-dns.net
Wed Jul 12 07:46:27 2017 daemon.warn dnsmasq[2492]: possible DNS-rebind attack detected: p28-contacts.icloud.com
Wed Jul 12 07:46:29 2017 daemon.debug pppd[6151]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 07:46:29 2017 daemon.debug pppd[6151]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 07:46:29 2017 daemon.debug pppd[6151]:  [service-name]
Wed Jul 12 07:46:34 2017 daemon.warn pppd[6151]: Timeout waiting for PADO packets
Wed Jul 12 07:46:34 2017 daemon.err pppd[6151]: Unable to complete PPPoE Discovery
Wed Jul 12 07:46:34 2017 daemon.info pppd[6151]: Exit.
Wed Jul 12 07:46:34 2017 daemon.notice netifd: Interface 'wan' is now down
Wed Jul 12 07:46:34 2017 daemon.notice netifd: Interface 'wan' is disabled

My network config:

root@E4200v2-4G-LTE:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda3:8d82:a9ce::/48'

config interface 'lan'
	option ifname 'eth0'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.66.77.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'
	option vid '2'

config route
	option interface 'lan'
	option target '10.9.0.0'
	option netmask '255.255.255.0'
	option gateway '10.66.77.5'

config route
	option interface 'lan'
	option target '10.8.0.0'
	option netmask '255.255.255.0'
	option gateway '10.66.77.5'

config interface 'udp_vpn0'
	option ifname 'tun0'
	option proto 'none'

config interface 'tcp_vpn1'
	option ifname 'tun1'
	option proto 'none'

config interface 'udp_vpn2'
	option ifname 'tun2'
	option proto 'none'

config interface 'wan'
	option proto 'pppoe'
	option 'pppd_options' 'debug'
	option ifname 'eth1.10'
	option username 'eircom@eircom.net'
	option password 'broadband1'
	option ipv6 'auto'

I am thinking, based on this thread, that my wan interface is wrong. I have it set to use option ifname 'eth1' because I know that the E4200v2 router uses eth1 for the physical wan port. But maybe that needs to point to a virtual VLAN? Eir state that the WAN needs to be set to VLAN 10 to get traffic.

Note that I also tried this config but get the same result and the same failed discovery in the logs:

config atm-bridge
	option unit '0'
	option vpi '8'
	option vci '35'

config interface 'wan'
	option proto 'pppoe'
	option pppd_options 'debug'
	option encaps 'llc'
	option vpi '8'
	option vci '35'
	option username 'eir@eir.ie'
	option password 'broadband1'
	option ifname 'eth1.10'
	option ipv6 'auto'
	option keepalive '5 20'

Actually it would seem my router just doesn't have a modem. Please ignore me :confused:

Those instructions you linked are for a DSL connection; you mention you have a FTTH connection, and your router does not support DSL. You need to find out how to configure your router for the FTTH connection from that ISP; I could not find any relevant info in their website, perhaps you should contact them, or ask in their user forums.

I am wondering if I need PPPoE at all? When I log into the Eir supplied router it simply says that it is connected by "IP Routing". So I image it is just a DHCP client to the device on the wall.

The yellow ethernet cable in the image is plugged into the WAN port of the Eir supplied F2000 router.

You definitively have a FFTH connection, and that box on the left is the ONT.

Now, to configure your LEDE router you might need to use VLAN and / or PPPoE, it depends completely on how did your ISP decide to configure their end of the connection. I will start trying to use PPPoE with the same parameters and no VLAN:

config interface 'wan'
	option proto 'pppoe'
	option pppd_options 'debug'
	option username 'eir@eir.ie'
	option password 'broadband1'
	option ifname 'eth1'
	option ipv6 'auto'
	option keepalive '5 20'

If that fails, you can try to use VLAN 10:

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option ports '4t 6t'

config interface 'wan'
	option proto 'pppoe'
	option pppd_options 'debug'
	option username 'eir@eir.ie'
	option password 'broadband1'
	option ifname 'eth1.10'
	option ipv6 'auto'
	option keepalive '5 20'

But all of this is just "shooting in the dark"...

Thanks so much for your help @eduperez

Yes, VLAN 10 is definitely a requirement. Eir recommend it on forums such as this one where the support person recommends:

Set encapsulation to IPoE, and set the VLAN (802.1q) tag to 10, leave 802.1p to 0 I do believe that should do the job.

Thank you for the settings you recommended, however is there any chance they will work since you mentioned my Linksys E4200v2 might not support it? Does my LEDE router require a VDSL modem perhaps?

Is IPoE just a fancy name for a DHCP client??

I am at work so I will try that config when I get home later....

Both VDSL and ADSL refer to the old telephone lines (cooper pair), and have nothing to do with the fibre line you have installed. As far as I know, you already have all the hardware you need, and your device should be perfectly capable of establishing a network connection. Your ISP is making things very confusing for everybody, because they call "Eir Fibre" both to FFTC and FFTH, hence the documents talking about fibre configuration with VDSL lines.

I could not find any document, or blob or forum post, indicating how to configure your FTTH line... perhaps you could have a look at the configuration pages in the device provided by the ISP, if those are accessible to you.

I agree. They don't make it simple!

Here are the settings on my ISP router:

When I press Save you can see this (I have removed partially the IP addresses):

I do not see any info about PPPoE in these settings; it is quite uncommon, but perhaps your ISP made things very simple, and you just need a DHCP client. Please try this, and report back:

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option ports '4t 6t'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1.10'
1 Like

Oh my g*d yes! That worked. Thank you so much! I had it bridged last night to my e4200, but now I can get rid of that other router. Thank you again!

Out of interest, can you explain how you decided on the numbers 4 & 6 in the switch_vlan section? '4t 6t'

I did not decide to use those numbers, it was you ;)! In the first comment you posted in this thread, your config had a VLAN entry for eth0 that comprises ports 0, 1, 2, 3, and 5, and a VLAN entry for eth1 that comprises ports 4 and 6.

I guess (and I could not find any documentation to support this) that ports 0, 1, 2, 3 correspond to the LAN ports, port 4 is the WAN port, port 5 is the eth0 interface, and port 6 is the eth1 interface. I just added the "t" after each port number on the WAN part, so we send and receive tagged packets on the outside (per your ISP decision) and keep them tagged on the inside (thus we configure the WAN interface as "eth1.10").

Speaking of this... if your ISP only provides internet access on that connection (some providers use the same fibre for internet + VoIP + IPTV), you only need an external interface, and could possible simplify your configuration to this:

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option ports '4t 6'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1'

Ah OK yes I think you are exactly right about the port and interface numbering.

I will play around with removing the t from the port 6 config as you suggest later. Thank you again.