[TP-Link RE650] How to get back to stock firmware?

Hi there!

I've installed recently OpenWRT on the TP-Link RE650 wifi extender but it does not live up to my expectations (I configured it as a wireless bridge, but the range and speeds are weaker than on the original firmware) and would like to restore stock firmware.

From what I've read I can do it via Luci or use Tftpd, but I'm not sure if I can just use clean firmware from tp-link site or if I need to "stripped" the file from bootloader first. If so how can I do it? I mean calculate the right offset to strip?

Does anyone can help me on this one?

It seems that only tftp is the way.

So that't the only option? To physically open the device and connect to the serial port?
From what it says I can't use clean vendor firmware and I don't have my original either :frowning:

Still don't really know what I supposed to do to flash stock firmware back :frowning:

I don't own the device, so I cannot be of more help. Hopefully someone might answer here. Otherwise do a forum search, see if someone else made it, and you could mention them here (like this @username)

Did you managed to revert to the original firmware?

Hi, have you managed to get the stripped firmware?

just bought one (before i found how difficult it is to roll back) and want to install openwrt. unfortunately i couldnt find an easy way to roll it back to tplink firmware just in case except via the console. also it looks like ppl are not satisfied with those openwrt snapshots as i could only see ppp asking for a way to reinstall the original firmware but no successful stories about the snapshots

hope someone can share his invaluable experiences

btw, since i have never tried to connect to a router via console, is it true that once i connected to it via the console i can do everything i want to with dd etc like a linux or android device?

thanks

Hi friends of OpenWrt,

I reverted my RE650 V1 (EU) back to stock today.

You can take a stock firmware file from the TP-Link Website, use the tplink-safeloader utility to convert to a sysupgrade file and then flash it from via ssh with "sysupgrade -F". One reboot later and you are back to stock.

Some more details:

Get the firmware file from https://www.tp-link.com/de/support/download/re650/v1/

Then, install the OpenWrt firmware-utils on your linux machine:

git clone git://git.openwrt.org/project/firmware-utils.git
cmake
make
./tplink-safeloader -h

I also had to install some dependencies, such as libssl-dev.

Once you have built tplink-safeloader and extracted the firmware zip file, you can run the following command:

./tplink-safeloader -z re650v1_en-up-ver1-0-7-P1\[20190521-rel52591\].bin -o re650v1-20190521-rel52591-sysupgrade.bin

Transfer the resulting file to your RE650:

scp re650v1-20190521-rel52591-sysupgrade.bin root@192.168.1.1:/tmp

Then, you can ssh to the RE650 and apply the upgrade:

ssh root@192.168.1.1
sysupgrade -F /tmp/re650v1-20190521-rel52591-sysupgrade.bin

Note that I used an older version of the firmware for this. I later updated to the latest via the TP-Link UI because I felt that would clean up any potential residue. Not sure if that did something useful :slight_smile:

And, of course, this whole approach will not help you if your RE650 is bricked and you can no longer log in to OpenWrt.

Disclaimer: this is what worked for me. If you break your RE650, you get to keep both pieces.

1 Like

Hi mhaas,

I would really appreciate it if you clarify these steps for a noob like me.

Thanks in advance & happy holidays

The steps are already quite clear and simple, therefore not much to clarify.

If you are having difficulties in understanding those steps, please explain what exactly you do not understand.

Hi thomas,

Don't know how to use 'cmake' & 'make' command.
Whats the

Wishing you a Merry Christmas and a Happy New Year and thanks for all your support

Hi all ,

I managed to reinstall the stock firmware.
This is what i did:

  1. Download firmware from https://www.tp-link.com/de/support/download/re650/v1/
  2. Now go to TP-Link Stock Firmware Converter https://argsnd.github.io/tp-link-stock-firmware-converter/
  3. Upload the firmware file downloaded from TP link website.
    4.Login to the RE650 via web interface and flash the converted file, check 'Force Upgrade'.

This is what worked for me to get back to stock firmware.
Hopefully this will work for others as well.

So as I mentioned in the first post, some time ago I installed OpenWRT on this Wi-Fi extender, but it didn't work as good as I thought it will be. Due to the lack of experience I bricked it to the point where I didn't have access to the bootloader and couldn't do anything with it (no way to log in, no LEDs, nothing). So I bought a new one, exactly same model, and put the old one in a drawer.

Recently, I decided to finally do something about it and bring the old extender back to life. For this purpose I purchased an EEPROM programmer ”CH341A EEPROM USB Programmer” (like this one AMAZON). Bellow are steps I performed to resurrect bricked extender.

  1. I read the original EEPROM from the new extender using EEPROM programmer I bought.
  2. Next, in hex editor had to replace mac address of the new extender with the one from old one.
  3. And finally that prepared firmware I flashed to the old extender and.... voilĂ ! It came to life! :smile:

I know how much I was struggling with this, looking for solution on web and failed. That's why I decided to share this backed up firmware, which should help bring your device back to life in case of problems. It isn't the simplest task, but also it’s not very very difficult :wink:

Some side notes:

  • This is a copy of the original firmware that has been read directly from EEPROM of TP-Link RE650 V1 (1.0.9-Build-20201112).
  • Before flashing, open it in hex editor and put your own mac address under the offset 0xE10008 (recommend “010 Editor” and use CTRL+G to go directly to that offset). Default mac at this offset is: 11 11 11 11 11 11. Replacing those numbers with your mac address make sure you ACTUALLY replacing those numbers and not adding extra bytes! (see screenshot below)
  • I suggest you do the whole flashing process in Linux, using “flashrom” utility, because in Windows I had some problems with reading the firmware. If you don’t know how to do it, you can always check on YT (https://www.youtube.com/watch?v=nKy57RmuxWM).

You can download this firmware from here: TP-Link RE650 EEPROM backup

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.