TP-Link RE450 v3 as wired Access Point

Hello people of the wireless freedom,

I am trying to get a TP-Link RE450 V3 running as a wired access point without its own DHCP server. I want it to forward DHCP and DNS and everything else ("dumb ap").

As far as I understand changes from the original state should be something like this:

  • connect via LAN cable to Luci
  • enable W-LAN interfaces
  • connect via W-LAN to Luci
  • set static IP for the LAN interface
  • disable DHCP server on LAN interface

What else am I missing?

How to tell the system to use the eth0 interface to route the wireless traffic.

Here is my current configs, these are the stock configs after reseting the device:

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd3:72f0:e802::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

if WLAN and eth0 are both lan, you shouldn't have to to anything else.

Note, if your device has been converted to DSA, the config snippets in the wiki will be incorrect.

Next day I tried again and succeeded within minutes.
I guess the automatic reversion messed me up. When I wait 30sec for it to pass and then apply unchecked everything went fine.
:upside_down_face:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.