TP-Link RE450 V2 ( F/W: 1.0.2 Build 20170626 Rel. 60833)

I have one, and am good with electronics. Give me a quick run what I need to do.

i'm not a developer, but afaik without a working serial connection we are flying blind; at first we need to find the UART/TX signal on the board.
Assuming that the GPL code posted by tp-link has anything in common with the actual firmware running in our devices, the u-boot uses GPIO18 and GPIO22 for UART (u-boot/include/config.h: UART_RX18_TX22); this doesn't mean much, as the mapping pin x GPIO is not public

Most likely UART is exposed as a header,but TP Link did not populate the resistors or cut the traces

good news it seems;a=commit;h=781ad46206ddaee74e40d7dbc68840fae1c0cc7c
atm i don't have the device and can not test it

Thank you John & Peter


I was working on getting the booting log through UART. Upon inspection I did find that R64 & R69 were missing, and that should they be shorted, will connect the header to the MCU. However, I did bridge them and try to connect to the UART and failed. I tried to connect a serial terminal to the MCU but couldn't get anything from it, even after switching the RX and TX pins.

Anyhow, glad they found a solution and that R64 and R69 were indeed key factor in the UART communication. I wonder why my UART attempt failed. Could R64 and R69 require a specific value, and not bridging them with 0 ohm?

Anyhow, I got the device to test it. Question is, I don't know how to compile the code into a working firmware, so if you can take care of that, I can do the testing.

i have asked in this thread

In the meantime, you could try my image built from the latest trunk, but really i wouldn't try it without a proper backup of the flash chip

Thanks for the links.

do you solve this problem ? if yes how you did ? I Have one RE450V2 and tried install openwrt and bricked now... i did as tutorial but bricked

Thanks for your help

best regards


Unfortunately, I personally haven't tried it. Maybe @alt10 can help you?

Best of luck.

Hi SamiHAIter

Thanks por your replay

Best Regards


Hi @alt10

you got back to stock firmware your RE450 v2 ?

Thanks for your help

best regards


Hi Juliano

i'm sorry to hear about your device :frowning:
unfortunately i no longer have a 450v2
if your router is stuck in the boot process (blinking power led indefinitely), afaik you could try to either solder two resistors and get access to UART, or remove the flash chip and program it externally


I'll try the TTL-USB cable, but you know the commands I need to do after (TPL enter) would you know what the commands are?

thanks for your replay

Best Regards


I got acess ssh, but firmware dont have luci, i search tutorial of how install luci off line in RE450 but without sucess, How install luci offline in RE450v2

Thanks for help


1 Like

I got acess webgui of RE450v2...
2.4ghz dont work;
update (opkg update) dont work;
5.0ghz Works Fine;

I am awaiting another firmware OpenWrt to update (No Trunk)

Thanks for help of community


1 Like

19.0x is expected soon. Though I don't know if there was a technical reason why v2 had only snapshot or of it is just not a common device.

1 Like

hello there! I've just got this unit and wanted to report that the current snapshot build works just fine. It's true that it doesn't ship with luci (as usual btw), but it's easy to install if you have a utp connection available.
This is my rough step by step:

  • pulled squashfs-factory from the techdata page and flashed it via the unit's factory webui.
  • to flash the image, I've connected the unit with the utp cable to my machine, it provided IP address via DHCP (your internet will go down on the machine due to the default route gets set to the RE450. it'll come back when you unplug).
  • the unit comes back online after a reboot with static ip address configured to, no root password.
  • You need to ssh to the unit and configure it to grab IP address via DHCP. See DumpAP tutorial. In brief, set /etc/config/network to:
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd52:c03e:9f0e::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'

(you can leave the ula_prefix and the localhost blocks unchanged)

  • and disable dhcp, ipv6 server and firewall:
/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop
/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop
/etc/init.d/firewall disable
/etc/init.d/firewall stop
  • Reboot the unit (unplug, plug). Pull the UTP cable from the machine and connect to your router. It'll provide ip address automatically. Check the router what address the RE450 got and ssh back to it.
  • in the ssh shell install luci:
opkg update
opkg install luci

Now you should have the minimal required luci webui access.

Note: I didn't need UART or any physical hacking around. Just pushed the snapshot image from factory webui.

Update: I've verified that both WiFi module works just great, over 2.4 GHz I got 300MBps and 5GHz with 866MBps.

1 Like

Signed up only to say thanks

Can someone confirm that latest 19.06 RC2 firmware contains LUCI for this device?
Also, is there a stripped version of stock available for "uninstall" if this go wrong? Thanks in advance!

just pulled the latest 19.07 RC2 firmware and checked its content. Luci files are there, so it should have LUCI service and app running after you flash it.

1 Like