TP-Link RE450 V2 ( F/W: 1.0.2 Build 20170626 Rel. 60833)

Good Evening,

I've just bought 2 x the above devices, having spent sometime researching ease of installation and compatibility with LEDE. Unfortunately, when I come to install the latest stable release for the device, the existing firmware reports 'Checksum Error'.

I have tried multiple TP-Link Firmware ( Regional) variations to try any bypass the check but to no avail.

Before I give up and return my purchases; are there any suggestions?

Many Thanks in Advance.

Try using TFTP.

TFTP tutorials…

Rename the binary to re450v2_tp_recovery.bin or a short name like factory.bin

Well V2 is not supported in LEDE.
It looks like it is new.

Do not just flash V1 image on it since differences can be big

I've got a V2 also and the serial port exists on the board, but my ttl 3,3 USB serial cable couldn't get anything on boot...

I tested for the ground pin with a multimeter and then tried all combinations by the layout of V1...

By long pressing power on boot of RE450 you interrupt the boot process... Power led blinks faster than usual...

But no tftp upload possible during that...

Can you take pictures of V2 PCB and serial port?

Sure, here you are...

Lemme try to post a picture from the from of the PCB too...


Front doesn't work, because of the power plug... I'm sorry...

Nothing interesting in the back.
Looks like everything is on the other side

Poor thing...

Seems there comes life to the OWRT Thread of RE450


More beer... more courage...

For details on certain chips just tell me where to focus...

Can you take a image of flash,it is just next to serial header.
Also can you verify that switch used is AR8033?
And it would be good to take a picture of SoC.
It should be under those cans.

Also having a bootlog would be really helpfull

Switch is AR8033 next to serial

Too less beer for removing cans...

Device performs really good on stock...

Bootlog keeps silent for me as I stated some posts before...

Hm, that would be the first TP-Link device that I know that does not have serial output.
Can you get to serial console when the device is fully booted?
Not much I can do without flash size confirmation and bootlog

No, I don't deny serial port... those four pinheaders can't be anything else...

But I don't get any output... neither puttytel on win32, nor screen on unix...

But thats me with my cheap ttl cable...

J1 is most likely the UART, but as on several of their newer routers, TP-Link has probably cut the trace (missing zero ohm resistor) to the SOCs, probably under the EM shield over the SOC.

Usually they do that for RX

For reference, specs of RE450 v2:

I haven’t got a serial cable or the like; but if there is anything I can do to contribute I’m willing!

New to LEDE but but not to Linux in general.


I have basic support for V2 done but GPIOs and LEDs most likely changed because SoC was changed.
I can build the image but without serial there is no way to see whats wrong if it wont boot.

I have not been able to find a single bootlog to check partition layout.

I’m willing to give it a go?! Am I right in thinking that even if the new firmware only partially flashes the new boot loader should be accessible via Ethernet and SSH?

Ok, but I gotta write each file with SGMII instead of RGMII currently used for the switch.
Also LEDs and reset button will not work since I do not know which GPIOs are used for them.
Cant fully configure since I dont know reset GPIO of AR8033 switch.

If TFTP recovery works than you should be able to always recover.