Tp-Link RE305V1 save doesn't work. Reboot, and they're gone

The current firmware for the TP-LIINK RE305V1 appears to work, but saving doesn't preserve settings over a reboot. Making its support very questionable.

let's see the following:

ubus call system board
df -h

Tp-Link RE305V1 is now bricked and in the trash. There does not appear to be a method that can unbrick it at this point. I have tried all recommended un-bricking methods and have tossed it.
If someone else wants to give this a whirl, my post is meant to give them a heads up before they brick the device.

What changed between the first post and your second?

I attempted to restore the factory firmware. That didn't end well.
It's a moot point now. The RE305V1 is dead, and my post is just a hint for others that just because the model is listed as "supported" doesn't mean that it works completely, or correctly for this particular model.
I've had much better experience with openwrt, just not in this one case.

That may or may not be true universally. It's not clear exactly what happened in your case, and we probably won't be able to figure out the cause of the problems you experienced since it is now bricked.

Sorry that you had so much trouble, though.

For the purposes of the forum (even though we never got to a real solution) -- If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

I hope everybody reading this will recognize that you have provided practically zero information about your issue and the rootcause. Could very well be that your issue is based on user error, but we will never know.


The install of openwrt on the tp-link RE305V1 went perfectly. I was able to configure it and everything worked, up until I rebooted. At that point I re-configured, and clicked "Save and apply" and that seemed to work. But, on the next reboot al the settings were gone again. Repeated the reconfig and reboot multiple times being sure to "Save and apply" each time. Every attempt failed with exactly the same problem, all configuration was lost. Since the device is now bricked, and blinks 4 lights forever, and does not support tftp, I don't see how one could provide any further information. I could disassemble and possibly get some pc-board silk screen info, it that would help.
If someone wants to debug this further, I'd be happy to send the bricked unit for their post-mortem analysis.

Note: This only happened with the TP-LINK RE305V1. I have not had any problems with other TP-Link routers, or Netgear, or Linksys routers, and am delighted with the GL-inet devices (also running openwrt)

1 Like

Two things here:

  1. the silkscreen and other information you can gather by looking at the inside is not useful. This is already known.

  2. The value that can be found by opening the device in your case is related to connecting the serial console and performing some debug. We might be able to figure out went wrong and/or even debrick the unit. However... :warning: You should never open this device unless you have experience working on live mains-powered devices. The voltages inside can deliver serious electric shocks that can cause injury or even death. Do not attempt to do any further debugging unless you have the requisite experience and safety skills. The rest of the warnings are here.

We still have no way to determine if there is a bug with OpenWrt, or if there was user-error (possibly as simple as the flash memory completely filled up due to packages being upgraded or installed -- did you do anything of that nature?). That is why I asked for the information in post #2 above. But just because you had difficutly with this device (and ultimately managed to brick it) doesn't mean that it isn't fully supported and compatible with OpenWrt.

1 Like

There were no additional packages installed. The RE305V1 was running tp-link factory firmware before the upload of openwrt. After the upload of openwrt, the unit seemed to work great. Was able to configure and bring it online. Everything worked. both radios worked and was able to connect and use the unit for traffic. Was careful to always Save and Apply, but whenever the unit was rebooted, or power cycled, all configuration parameters were gone. (Behaved like the params were not stored in NvRAM)
I could indeed open the unit and connect up an RS232 interface, ( I have not gone there yet ) others in this forum tried that and were unsuccessful on this model. The usual tp-link hold reset during powerup does not activate a TFTP comm link. Have examined with Wireshark and there is no traffic at all coming from the unit.
Any other info that I could send that might help ?

1 Like

Please be extremely careful if you do open the unit. And understand you will be doing so at your own risk.
Also, the serial UART connection is not RS232 -- make sure you have a TTL (usually 3.3V) serial adapter. RS232 is usually much higher voltage and may damage the device.

1 Like

Right, TTL 3.3v not a problem. Not sure it's worth the time, as others have already tried this.
Has anyone been successful in using the serial console to recover the RE305V1 ? AFAICT, that doesn't seem to work either. The answer seems to be, once bricked, it's game over. If that is the end game, then perhaps that is the "Solution " ? So, folks with this same model can quickly resolve this issue, should it happen to them. :slight_smile:

Well, again, that all depends on what caused the brick. If the bootloader is hosed, yes, game over. Same with the wifi calibration data from the factory. But if the bootloader is running and you can reflash, typically there are methods to recover.

It is your device and your time+energy. You're the only one who can really make that call.

A question perhaps might help. " Has anyone successfully loaded openwrt on the tp-link RE305V1 and had the configurable parameters survive a reboot ?" If yes, then something went wrong in my situation and this is an outlier. Case closed. If the answer in No, then perhaps someone might want to try that and if they see similar issues, then consider updating the "Hardware supported table" with some indication that this may be problematic. :slight_smile:

Looking at the forums, it appears that people have succesfuly used this device with OpenWrt. But, you'll also find threads with problems -- this can be a biased sample because of the tendancy for people to post only when they are having issues and not when everything is working properly.

1 Like

I'll have a USB to TTL cable tomorrow and can solder on some pins and see if I can get the serial console working. That might provide some light on the patient's issues. :slight_smile:

(Note: TP-link distributing a unit that doesn't support tftp boot is not helping their customers. Then again replacing their firmware and bricking is not their primary market )

At least one user had success in getting some serial output (although not much since his device did not boot up completely), so in priciple it should be possible.

Incuding this one? Unbricking RE305 v1 - #18 by petitess

OK, probably way out of the comfort zone of many users, but in principle doable.

1 Like

If you have a serial cable, you may try to connect the flash chip with few external components and write it without the router. Some adapters do offer multiple interfaces like UART, I2C and SPI and could be connected directly. For example CH341a - You can also connect a 8-pin clip to it. It is possible something to be wrong with the flash chip itself. I had one with a read-only area. After some 20-30 attempts I replaced it. Your chip looks like a regular SPI EEPROM likely replaceable with W25Q64/W25Q128. Over the device page the flash layout is present, so you may try to preserve some of the original data.

Keep in mind that you are going to connect electrically to the device. If the embedded power supply is faulty, you will have the AC mains all over the PCB. The Ethernet port should have a transformer, so it's not connected electrically. It is advisable to test it for Mains leak before attempting to connect the adapter.

The serial port is working. But alas, after trying every image on the vendor's web site, the unit
does not permit loading the firmware via TFTP. :frowning: Every attempt ends with bad checksum and retries and no success.
Thoughts, suggestions ?

Making some progress, but not quite there yet.
Replaced the Windows + tftpd64 connection path with a Linux box + minicom + tftp-server
Using the Linux connection path, the download of the OEM firmware now succeeds.
No more checksum errors, just nice #### and .... and then the final output on the console is now: "Starting Kernel"
But alas, that's all that happens. No lights, no traffic over the NIC or console.
Thoughts, suggestions ?