TP-Link MR3020 v3 build problems


Do we know how much Flash and Ram are provisioned on the MR3020 V3?


to make this as simple as i can for anyone with a little knowledge

go here -
and download pulpstone-tplink_tl-mr3020-v3-squashfs-tftp-recovery-rev2.bin
Rename it to tp_recovery.bin

go here -
i downloaded the latest portable version (so i didnt have to install it) v4.62 tftpd64 portable edition

create a folder C:/MR3020
extract to it
copy tp_recovery.bin to it

change the network adapter of the pc to press enter so subnet mask auto fills then apply
run tftpd64.exe from C:/MR3020

plug MR3020 lan cable into pc - dont power it on
hold the reset button and plug the power cable in. keep holding the reset button until tp_recovery has been copied across.
once the copy window has disappeared release the reset button and change your network adapter back to obtain automatically.
close the programs
user/pass root:root

job done

3g usb stick just works automatically, S7 works when connected as usb tether (just make sure wifi is off it your connected to wifi)

1 Like

Does anyone know how to use the MR3020 as a "modem" for my main router? ie set it as bridge mode
so the mr3020 connects to the phone/usb stick gets the internet connection but my main router connects to the mr3020 like the NBN NTD and handles all the dhcp etc?

im guessing its double NAT atm and everything is running slow

can i put the lan port into dmz to the router wan or bridge something or what can i do to get rid of this double nat while letting my main router handle everything.

Seems the answer the how much Flash and how much RAM ... is here.

memory: 04000000 @ 00000000 (usable), that is 64MB RAM

m25p80 spi32766.0: gd25q64 (8192 Kbytes), that is 8MB Flash

A big improvement! :slight_smile:

I wanted WDS client functionality, working nicely here so far. I have yet to test 3G/4G dongles but they're detected fine. Upgrading packages via opk fails with "I wanted WDS client functionality", is this device so low on space that only full firmware upgrades will work?

A post was merged into an existing topic: TP-LINK TL-MR3020 + E3372 dongle

Hello. Anybody using this device - can you confirm how WiFi working on it? Any problems with weak signal, etc?
Thank You.

someone will tell why in firmware /cgi-bin / pingloop? Because of this, the system-Startup in luci menu does not work. only when this pingloop is disabled, the startup menu is displayed in the web

After building the image, router works. But lan port is not responding on! (pulpstone image works fine)
Need help.

ifup ifdown commands not work (

all works! thanks You! )

anyone have information about gpios for USB power switching (as gpio8 in v1) ?


I installed pulpstone on mr3020 v3 with no problems. But then i tried to install php(
There is only php7 in repository, and it installs fine. But it doesn't work.

root@Pulpstone:~# php-cgi 
Error relocating /usr/bin/php-cgi: fopencookie: symbol not found

When i tried to build meyergru's fork i saw something like:

./scripts/feeds update -a
Updating feed 'packages' from '' ...
Cloning into './feeds/packages'...
fatal: unable to access '': LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to 

Need help with mr3020
P.S.: Sorry for my english)

Is there anything in the works for v3.20, too? If it's true that this version won't run on those?

Could you please help me?
I cloned your git with command:

git clone --branch TL-MR3020-V3...
There was no errors.
But when i started
./scripts/feeds update -a
i had errors:
./scripts/feeds update -a
Updating feed 'packages' from '' ...
Cloning into './feeds/packages'...
fatal: unable to access '': Couldn't connect to server

And other requests with same error.

I think that the URL has change in the meantime, but when I tried, I was redirected to the new URL. Seems like you have connectivity problems - I cannot help there.

P.S.: Looking at your previous post, I suspect that your development system is either too old or too limited - your git client could not even connect to a SSL URL.

May i just change links in default.feed.conf file?
If i use link to lede.git from browser i really was redirected, but when i tried curl from command line i had an error.
My git is updated and no problem with SSL connection.

You can try to use the other links, I guess...

use proxy for downloading (if you in Russia)
Роскомнадзор блочит
proxy = socks5:// # Tor-прокси или свой пропиши

I already built it.
But there is kernel 4.9, and all about PHP from repository require kernel 4.14.
How to build image with last kernel?
Собралось, только почему-то со старым ядром.
Все, что касается PHP из репозитория требует 4.14, а там 4.9.
Не знаешь, как собрать с последним ядром?

4.9 нужно? надо собирать из транка Openwrt, но там не добавили поддержку 3020v3. вроде бы, не проверял.