TP-Link MR3020 v3 build problems


#42

No, the cloning of the branch should be sufficient.


#43

After I change my PC ip address to 192.168.1.3 I'm still not having response from the router. Pinging 192.168.1.3 got Destination host unreacheable.


#44

hello, thank you for your advise.
The following steps are how I build LEDE image from git.
1.$git clone --branch TL-MR3020-V3 https://github.com/meyergru/lede-source.git
2.$cd lede-source/
3.$./scripts/feeds update
4.$./scripts/feeds install -a
5.$make menuconfig
6.$make
I have created LEDE image from both Debian 8 and Ubuntu 16.04.
After flash via tftp, I captured activity on LAN and found that mr3020 is still in recovery mode.


#45

Did you get it working? If it this, can you upload the firmware?

Thanks


#46

Not yet, I don't have working image. @meyergru can you please share LEDE working image with us?


#47

I can confirm @meyergru 's fork is working with my MR3020 v3. I've just built the image including some config file.

@doxigin sornchai
You can generate your very own config files by hand or by getting them from a running openwrt distro on similar hardware (ex: MR3020 v1)
Then you can embed them in a custom-image using the image builder you can generate from @meyergru 's sources. More infos here: https://wiki.openwrt.org/doc/howto/obtain.firmware.generate#files_variable
If you are still in trouble I can try to get and upload my configurations.


#48

Thank you very much @Guglio for the confirmation. I'll using image builder. And if i stumble along the way i'll post here for help.

Much appriciate.


#49

Thank you @Guglio for the hint. I manage to get it working. Thank you very much.


#50

Hello,
I don't know why my build image is not running. I tried also using image builder but no success.
The Internet and WPS/reset LEDs always blinking. please advise me. Thank you.


#51

As stated in the link by @Guglio basically you got to have a network configuration of a working mr3020 any version. Just Google for example. That's what I did. And then you follow the steps in the link. Hope it's help.

PS:
I only use repos from @meyergru and then I created folder named files/etc/config. Put the network configuration file and build


#52

Hello all,
Thank you for your help. I have done setting network configuration and my router is working well.


#53

Dear colleagues,
can someone share his built image with a network configuration? This will save many time.
Thanks!


#54

I'm having trouble in the make (6 part) part. Can someone share with us a compiled version?


#56

I've encountered the same problem. When I try the command "make", the three Warnings appear. I'm using Linux Mint as distro.


#59

I guess that kind of warning does not matter when you build it


#62

42

Link firmware : http://pulpstone.pw/beta-tester/ramips-mt76x8/

Added:
All Modem Packages
Support 3G/4G Modem
Support Protocol HiLink/NCM/RNDIS/QMI
Support USB Tethering Android
Support Exroot
Support SCP and SFTP Protocol
LuCI Theme Darkmatter
3G/4G Info by eko.one.pl

Basic Information:
Default IP Address: 192.168.1.1
Username: root
Password: root
SSID Wifi: PULPSTONE
SSID Password: internet

Big Thanks to meyergru


#63

@pilpstone
Can u please share the compile process for the image
Actually i want to create a custom image with some specifications like wifi settings and all.
since the old process was to create and a directory and put all config file in it, but in this lede build process i am unable to find how to do custom settings for my config files.
its been helpful for me if you share the build process.


#64

FYI: I created https://openwrt.org/toh/tp-link/tl-mr3020_v3 for documentation of this device.
It would be great if someone could fill in the basic hardware information and a short description of the installation process.


#65

Hi all,

I can confirm that pulpstone's build works like a charm. Also tested with 3G USB modem, ETH with DHCP or fixed IP, package installation.

Couldn't this build used as an official image, thus allowing immediate support for MR3020 v3?

I'm sure there's a lot of people in need of a openwrt version for this hw revision, and the official openwrt only mentions a link to this forum.

Can I help somehow ? Maybe in filling the install instructions of this build into the openwrt official page? What is necessary for it to show as a "supported device"?


#66

An official OpenWrt image downloadable from downloads.openwrt.org.