TP-Link MR3020 v3 build problems


#67

Hello,
Do I understand this correctly, there is an official version for the TP-Link MR3020 v3?
I can't find the firmware at downloads.openwrt.org


#68

Hello, I just bought the TL-MR3020 V3 Today and sadly I had this problem as well
But I felt so good that there is other people having this problem as well
Hope we can have the firmware soon, I'm bookmarking this post :)))


#69

I'm reading through this post and have no idea at all how to do it :frowning:


#70

#71

Hello, Thankyou for reply,
.
.
I will try to explain as detail as I can how I got stucked
.
.
1. Set the Ethernet that the pc is connect to the MR3020 v3 by LAN cable
-Control panel > Network and Sharing Center > Right click on the connection > Properties
-Double click Internet Protocol Version 4, new windows open
-Check "Use the following IP Address"
-IP address = 192.168.0.255
-Subnet mask = 255.255.255.0
-Other leave blank
I got an error says that
The combination of IP address and subnet mask is invalid. All of the bits in the host address portion of the IP Address are set to 1. Please enter a valid combination of IP address and subnet mask.
I looked in this page
http://pulpstone.pw/beta-tester/ramips-mt76x8/READ_ME.txt
on the 11th line it says
"1. Configure PC with static IP 192.168.0.225/24 and tftp server."
so I try to setup IP as 192.168.0.254, not sure If I 255/24 you mean I can set to 254 as well, but it works
the new setting is
-IP address = 192.168.0.254
-Subnet mask = 255.255.255.0
-Other leave blank
.
.
2.tftpd32 download and setup .bin file
-I downloaded from this link "http://tftpd32.jounin.net/tftpd32_download.html"
-Version 4.52 "tftpd32 standard edition (installer)"
-It is installed at C:\Program Files (x86)\Tftpd32 (default)
-I use the file from http://pulpstone.pw/beta-tester/ramips-mt76x8/
-file name pulpstone-tplink_tl-mr3020-v3-squashfs-tftp-recovery-rev2.bin
-after download change name to tp_recovery.bin
-move tp_recovery,bin to C:\Program Files (x86)\Tftpd32 (default)
.
.
3.tftp upload
-Power off MR3020 v3 router, leave the lan cable connected
-Get the tftpd32.exe ready in another window
-Hold down reset button on the router
-Still holding reset/ Plug in power to the router
-Still holding reset/ as fast as I can > open tftpd32.exe in the PC
-I waited about 10 secs,the file should start upload but I got nothing
-Holding reset the router keep rebooting without upload from tftpd32.exe
-I tried other IP
-IP address = 192.168.0.255
-Subnet mask = 255.255.255.255
-Also not working
.
I didn't setup the tftpd32, don't know how to set it, and when I tried set it and reboot the tftpd32
the setting didn't keep, it revert to default setting

.
Please help~


#72

Look the video on 1.30! The correct ip-adress is: 192.168.0.225 and not 192.168.0.255 how you write...


#73

Omg I got it! Thanks!


#74

hey can anyone know the GPIO configuration for this v3 router


#75

Hello lede, could you please provide instructions to connect to board via UART


#76

Hi,

Do we know how much Flash and Ram are provisioned on the MR3020 V3?

Thanks


#77

to make this as simple as i can for anyone with a little knowledge

go here - http://pulpstone.pw/beta-tester/ramips-mt76x8/
and download pulpstone-tplink_tl-mr3020-v3-squashfs-tftp-recovery-rev2.bin
Rename it to tp_recovery.bin

go here - http://tftpd32.jounin.net/tftpd32_download.html
i downloaded the latest portable version (so i didnt have to install it) v4.62 tftpd64 portable edition

create a folder C:/MR3020
extract tftpd64.zip to it
copy tp_recovery.bin to it

change the network adapter of the pc to 192.168.0.225 press enter so subnet mask auto fills then apply
run tftpd64.exe from C:/MR3020

plug MR3020 lan cable into pc - dont power it on
hold the reset button and plug the power cable in. keep holding the reset button until tp_recovery has been copied across.
once the copy window has disappeared release the reset button and change your network adapter back to obtain automatically.
close the programs
open 192.168.1.1
user/pass root:root

job done

3g usb stick just works automatically, S7 works when connected as usb tether (just make sure wifi is off it your connected to wifi)


#78

Does anyone know how to use the MR3020 as a "modem" for my main router? ie set it as bridge mode
so the mr3020 connects to the phone/usb stick gets the internet connection but my main router connects to the mr3020 like the NBN NTD and handles all the dhcp etc?

im guessing its double NAT atm and everything is running slow

can i put the lan port into dmz to the router wan or bridge something or what can i do to get rid of this double nat while letting my main router handle everything.


#79

Seems the answer the how much Flash and how much RAM ... is here. https://forums.whirlpool.net.au/forum-replies.cfm?t=2689577&p=163#r3260

https://pastebin.com/FitcPEZL

memory: 04000000 @ 00000000 (usable), that is 64MB RAM

m25p80 spi32766.0: gd25q64 (8192 Kbytes), that is 8MB Flash

A big improvement! :slight_smile:


#80

I wanted WDS client functionality, working nicely here so far. I have yet to test 3G/4G dongles but they're detected fine. Upgrading packages via opk fails with "I wanted WDS client functionality", is this device so low on space that only full firmware upgrades will work?


#81

A post was merged into an existing topic: TP-LINK TL-MR3020 + E3372 dongle


#82

Hello. Anybody using this device - can you confirm how WiFi working on it? Any problems with weak signal, etc?
Thank You.


#83

someone will tell why in firmware /cgi-bin / pingloop? Because of this, the system-Startup in luci menu does not work. only when this pingloop is disabled, the startup menu is displayed in the web


#84

After building the image, router works. But lan port is not responding on 192.168.1.1! (pulpstone image works fine)
Need help.


#85

ifup ifdown commands not work (


#86

all works! thanks You! )

anyone have information about gpios for USB power switching (as gpio8 in v1) ?

thanks!