TP-Link MR3020 v3 build problems


#87

I installed pulpstone on mr3020 v3 with no problems. But then i tried to install php(
There is only php7 in repository, and it installs fine. But it doesn't work.

root@Pulpstone:~# php-cgi 
Error relocating /usr/bin/php-cgi: fopencookie: symbol not found

When i tried to build meyergru's fork i saw something like:

./scripts/feeds update -a
Updating feed 'packages' from 'https://git.lede-project.org/feed/packages.git' ...
Cloning into './feeds/packages'...
fatal: unable to access 'https://git.lede-project.org/feed/packages.git/': LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to git.lede-project.org:443 
failed.

Need help with mr3020
P.S.: Sorry for my english)


#89

Is there anything in the works for v3.20, too? If it's true that this version won't run on those?


#90

Could you please help me?
I cloned your git with command:

git clone --branch TL-MR3020-V3...
There was no errors.
But when i started
./scripts/feeds update -a
i had errors:
./scripts/feeds update -a
Updating feed 'packages' from 'https://git.lede-project.org/feed/packages.git' ...
Cloning into './feeds/packages'...
fatal: unable to access 'https://git.lede-project.org/feed/packages.git/': Couldn't connect to server
failed.

And other requests with same error.


#91

I think that the URL has change in the meantime, but when I tried, I was redirected to the new URL. Seems like you have connectivity problems - I cannot help there.

P.S.: Looking at your previous post, I suspect that your development system is either too old or too limited - your git client could not even connect to a SSL URL.


#92

May i just change links in default.feed.conf file?
If i use link to lede.git from browser i really was redirected, but when i tried curl from command line i had an error.
My git is updated and no problem with SSL connection.


#93

You can try to use the other links, I guess...


#94

use proxy for downloading (if you in Russia)
Роскомнадзор блочит
gitconfig
[http]
proxy = socks5://127.0.0.1:9050 # Tor-прокси или свой пропиши


#95

Thanks)
I already built it.
But there is kernel 4.9, and all about PHP from repository require kernel 4.14.
How to build image with last kernel?
Спасибо)
Собралось, только почему-то со старым ядром.
Все, что касается PHP из репозитория требует 4.14, а там 4.9.
Не знаешь, как собрать с последним ядром?


#96

4.9 нужно? надо собирать из транка Openwrt, но там не добавили поддержку 3020v3. вроде бы, не проверял.


#97

нужно 4.14, а из форка meyergru собирается на 4.9
не нашел, где можно указать версию ядра


#98

надо тогда искать в старых версиях
например
git clone https://github.com/lede-project/source.git -b v17.01.2
собирается на ядре 4.4.61
тебе наверно надо искать собирать на 15.05 Chaos Calmer
только наверно на старых ядрах еще нет поддержки чипсетов MT7628


#99

так ядро вроде не старое
4.14 позже, чем 4.9
А у тебя собралась нормально прошивка?
php-cgi работает?


#100

сорри перепутал. действительно новее. насчет php-cgi не скажу, не использую. то, что мне нужно работает и на старом ядре.


#101

You started good with providing the english translation besides the russian.
Please continue to do so.


#102

Sorry for disturbing you, but could you please help me again?
I built an image from your fork without any changes, just with FILES=files/ with network configs.
But when i'm trying to install some packages from repository (mod-usb-storage, or php) it says that packages in repository are for kernel 4.14 and kernel version in your fork is 4.9
How do you build firmware with new kernel?
Or maybe i need to change repository on router after flashing on repository of release?
When you made your fork on which release is it based on?
After flashing firmware all repositories are target to snapshot brunch. Is it correct?


#103

why install packages from the repository if you can compile the firmware with the necessary packages?


#104

Because it is not so much memory on the router for all packages i need.
And because i don't want to rebuild firmware every time i need to add some packages.


#105

opkg install --force-depends .......
but it's a little wrong


#106

Maybe you can help me?
I flashed pulpstone, but there was an error with php-cgi. It use fopencoockie, but there is no fopencoockie in your system. So php-cgi doesn't work(


#107

It doesn't work.