TP-Link MR200 firmware update


#1

I recently got a "customized" (i.e. provider specific firmware) MR200 delivered with my 4G internet service. I've been able to flash OpenWRT on it following the instructions from the archived forum post here (https://forum.openwrt.org/viewtopic.php?pid=342280#p342280)

I see that TP-link has released firmware 20180502; has anybody reverted back to stock, using the file from the forum, then updated to the generic TP link latest firmware, and then gone back to latest OpenWRT (2 steps, obviously).

Basically, I'm wondering if by flashing the mr200_back_to_stock.bin file, I get "generic" TPLink firmware which will allow me to update to the latest from TP-Link (which hopefully contains the latest Modem firmware), and then reflash OpenWRT. I would think so, but wanted to see if anyone has actually done this successfully.....

TIA


#2

Which tp-link 20180502 firmware are you talking about? Can you give the firmware link?
Btw you can revert back to stock rom and flash the newer stock tp-link rom from the router webpage.


#3

A quick google search reveals this:
https://static.tp-link.com/2018/201807/20180720/Archer%20MR200(EU)_V1_180502.zip


#4

Hi @gurangax, do you get success with that firmware?

I have got also a MR200 V1 with a custom firmware that avoid me to update the MR200 to the last official firmware in the webgui. (error 4053)

I want to try the steps that I have read in https://forum.archive.openwrt.org/viewtopic.php?id=64293

But I want to ensure all the steps not to brick me device.

Are these ok ?:

1.- Flash openWrt "pre-modified" firmware http://www.mediafire.com/file/1e0ygxswmx5a73n/ArcherC2V1_tp_recovery.bin/file using TFTP recovery.

2- Using webgui of OpenWrt, flash "back_to_stock firmware" found also in the post in forum.archive.openwrt post by Heinz: This is the link to the google drive: I can't put it as I am a new user so I can't put more than 2 link. The post from Heinz i is #41.

3- At this point, I will have a official TP LINK router, so I can update it through webgui to the last version 20180502 (I can't put more than 2 links as I am a new user, but it is the link of the previous post)

4- After updating this, I will have a router and a modem update up to final version from tplink

  1. After that, if I want, I could use again "ArcherC2V1_tp_recovery.bin" and after update via webgui to the last version of OpenWRT.

But I have several questions after reading old post and all the post that I have found here.

a. the file ArcherC2V1_tp_recovery.bin that I have found in mediafire is from 09/26/2018 and it has different size from what I have downloaded from a google drive link. How to know what is the correct one?

b. That google drive link has also the file "back to stock", so I don't know what of these options is the correct one:

  1. both ArcherC2V1_tp_recovery.bin are ok, so "back to stock" file from google drive will be ok.
  2. ArcherC2V1_tp_recovery.bin from mediafire is not the good one. So take both from google drive link
  3. ArcherC2V1_tp_recovery.bin from mediafire is ok, and the one from google drive NOT, but you can use the "back to stock" from google drive

c. Is it better to prepara a file with the last firmware version from TPLINK ? I don't know how.

d. are the steps correct ?

e. I have also read about people that after flash "back to stock" can't update with the official EU firmware from TPLink, what do you know about this?

Thanks a lot for your help.


#5

Hi, anyone could help me ? Thanks


#6

I didn't test the new firmware, but i suspect the user interface will be different to match tp-link new interface. My original modem inside the router is broken, and I have replaced it with another modem brand. So using the new firmware is not worth for me. But Maybe I will try it when I have the time to do so.

ArcherC2V1_tp_recovery.bin is used to flash with tftp. this file must start with the bootloader else your router will be soft bricked. It will be harder to recover once it is soft bricked as it involves using external rom programmer. Just keep this in mind. The mediafire file which you mentioned is already the right file if you wish to flash using tftp. It contains the bootloader with openwrt 18.06.1. The file size is correct, size difference is due to firmware version and packages included. You can straight away use tftp to get openwrt in your router.

Updating to the latest tp-link firmware should be done if you feel that you want to update the modem firmware inside the router. It will update both the router and modem. You can not update the modem firmware from openwrt currently, but it is possible if someone works on it.

If you wish to revert back to the original tp-link version you can use back_to_stock firmware with the webgui. If you can't update with official tp-link firmware after back_to_stock then something is wrong with the firmware but it can still be corrected. I can prepare the correct file if you need it.


#7

Hi, I have just tried. With the file from mediafire and with the "back to stock" from google drive.
I am now in TPLINK 0.9.1 0.0 v004a.0 Build 160118 Rel.50197n
So this is great, everythink ok .... ... but....

  1. I have not option to connect to my router via LAN --> really a big problem as NOW i can't upload again with TFTP method. Also with openWRT I can't connect it with LAN, so I have flash "back to stock" with WIFI. (I have already check cable, and reboot my computer). If I connect other router that I have, my laptop¡s LAN works perfect. May be something related to firewall? Does my router lan break?
  2. I have try to upload the tplink oficial fimware: Archer MR200v1_0.9.1_0.0_update_1041_1021_2009 (Archer_MR200(EU)_V1_160412)

And.....

Error code:4503
The uploaded file was not accepted.

I have also tried: Archer MR200v1_0.9.1_1.1_up_boot_v004a.0 Build 160905 Rel.60037n
and: Archer MR200v1_0.9.1_1.2_up_boot_v004a.0 Build 180502 Rel.53881n
and: Archer MR200_V1_160118

What could I try now ?

Regards,


#8

Try again with tftp via LAN, Wifi can sometimes send corrupt data not the best option. make sure you follow directions found here https://oldwiki.archive.openwrt.org/toh/tp-link/archer-mr200
I think it is just IP configuration problem


#9

Hi, thanks again.

I tried it, but I have just tried again. It is impossible. TFTP32 logs shows nothing. Router lights the update led, but doesn't blink, my laptop doesnt show anythin related with ethernet.
It is like lan ports are not working.
Lan led on router doesnt show also
I have checked with all 4 ports. And I have done the same step as yesterday, when I flashed the mediafire file with any problem.
I remember that with openwrt also lan ports didn't work. How could it be? Just only after flashing openwrt (mediafire file) I broke my ports?

May be the mediafire bootloader doesn't start lan ports? so now it is impossible for me to update anything?

Is there any file to flash from tplink gui to update to the las version of tplink firmware (may be the last option).

Please help me. (i have arduino's could I do anything with it?


#10

Can you read the router terminal output by Serial port connection? Try flash with openwrt webgui the back to stock rom and confirm if the lan works or not after. If not, I can only imagine a different hardware/version of your router. The bootloader only loads the initial drivers, openwrt has its own LAN drivers and if its not working under openwrt then something is wrong. You can post the system/kernel log from LEDE interface. You can update with wifi connection since you cant connect with LAN. Make sure the connection is not interrupted during firmware uploading.


#11

I will try this week.

I think i wrote it, I have already flashed from openwrt webgui with WIFI the "back to stock" file, I flashed it just after flashing openwrt with TFTP. First TFTP and after with openwrt webgui.

I am now in tp-link firmware (back to stock) but I can update with any of tplink official firmwares and also LAN is not working.

Today I have tried another computer, but same problem, NO lan, even no lights in the port lan of the new computer.

May be the "initial drivers" of the bootloaders aren't the correct one?

I will try reading serial port of the router and I will paste here the log. Any other thing to try ? I could only flash thrught tplink webgui :sleepy:

Thanks a lot for your help. Now, I have a tplink firmware (old one) that works with wifi, but no with LAN (checked in two computers).


#12

Sounds more like hardware/version problem to me. Are you sure you have v1 and not v2 of MR200. It's very unlikely to damage the LAN ports from rom update and I have personally tried the file without problems on my router. You can also take some pictures inside the router to confirm the version.


#13

Hi, yes, it is V1 (sticker in the back). When I open it to take serial output, I will take some potos also. Probably it has not a solution now, has it ?


#14

Try with a different cable and use only LAN 4/WAN port


#15

Thanks,no luck. New cable and LAN/WAN port. Nothing in TFTP server. After 10 seconds router lights on update light, but nothing happens

I will try to open it this week and attach a serial adapter.

Thanks, let's we see if we could find a solution.


#16

Could it be a net/subnet problem?

I extract this answer from old forum thread:

"Post #115 Heinz 6 Apr 2017, 00:42

Here is Your problem:

Listening On: 192.168.0.66:69
Client 192.168.1.1:1040

Change Netmask to 255.255.254.0 because router have IP ( 192.168.1.1) from another subnet than TFTP server (192.168.0.1)."

https://forum.archive.openwrt.org/viewtopic.php?id=64293&p=5

Good luck.


#17

Hi, I have also tried what you say. No luck.The problem is that since falshin openwrt lan ports doesnt work, any of them.

I did with 192.168.0.66 and 255.255.0.0. Today I have also tried 192.168.0.66 and 255.255.254.0 but doesnt work ( I have tried with each lan ports, 4 times)

This is what I did:
03

Also with the tplink firmware (back to stock), I CAN'T connecto to my router with lan ports (I tried also new cables and another computer). Wifi is working, but lan ports don't.

@gurangax I have to remove the back sticker to access inside. Is there any posibility of recover it with serial commands? I dont want to remove sticker if I can't do anything without lan ports. What do you think ?

Thanks a lot, guys.


#18

We can check if the LAN drivers are being loaded at all from the serial log. I have read of some people who has the same problem as you. It could be a slight hardware variation i'm not sure if US or EU or etc version has the same hardware. You need to take pictures on the inside to make sure. Can you update to other tplink firmware? try newer firmware.


#19

Thanks, several post ago, I put three official firmwares that I checked. All of them with 4053 error or error 500 unknown.

About serial port. Imagine that the pan's driver is not loaded. Could we find any solution to that ? (I don't have skill to desolder and solder IC's so easy)


#20

4053 error is related to a region difference or try to upgrade with an earlier version.
Perhaps it is because it is a branded device.

I think back_to_stock.bin made by Heinz has some region difference with tplink fw that you are trying to load.
I think it's best to begin update process with all official versions from first to last, to be sure they are compatible.
I found in MR200 openwrt page, this method to revert to a stock fw:
"

Reverting back to the stock firmware

Always revert back to the same version in which you switched from.

Steps:

  1. cut out the first 0x20200 bytes. (tp-link header+bootloader)

  2. cut out the rest of the firmware after 0x7B0000 bytes (LTE modem firmware starts there)

  3. upload the file to the /tmp folder

  4. assuming the file name is stock.bin, issue mtd -r write stock.bin firmware command and wait for reboot.
    "
    https://openwrt.org/toh/tp-link/archer-mr200

But, you must to build the first .bin, hex editor cutting and pasting like is explained before. If it is succesfull try to load via webgui the following official fw's.

I'm not sure if this method is valid or not, maybe @Gurangax can tell us.

Good luck.