Tp-link mr-3020 bricked

Hello, I am Raimund from Germany.

I bought a mr-3020 but this was not working. I was able to get connection via serial port, an have a look with "screen" on the router. When i press "f" and enter at the right moment, I get into the failsafe mode, but I can't get connection via LAN. I can ping it on but get no conection via telnet or ssh. How can I get a SW on it to flash it new?

Try type firstboot and confirm with Y it will reset factory setting and see.

I tried, but after reboot nothing changed. That's kurios.

you should be able to recover sing TFTP

what version of the 3020 is it, anyway ?

I think it is version 1.9

Use TFTP recovery, and since you already have the serial console up and running,
it shouldn't be a big issue.

But the connection with TFTP should work over LAN or? I Think I don't get connection over LAN.
And who to start this TFTP. In the instruction says "type in tpl, when Autobooting in 1 seconds" is to see.
But I don't see this, because, there ist not the OEM SW on it.

The output for TFTP instruction in the Wiki comes from the serial console.

Assuming you serial cable works intended, you should be able to interrupt the
boot loader, and reflash the unit using TFTP.
The loader kicks in before the OS, in our case OpenWRT.

You need a physical network connection to transfer the image, but there's no
relation to the unit being unreachable once OpenWRT's booted.

How can I interrupt the bootloader?
Is it before or after the "f" for failsafe mode?

It's all in the wiki ....

Before. it should pretty much be the 1st thing you see once the output starts on the console.

You'll need a TFP server on your computer though. is excellent for Win.
Don't forget to temp disable your FW.

Okay, I will try.
The first thing I see is this:


that probably means the baud rate changes between boot loader, and openwrt.

You need to make it readable where the garbage is, that's the part of the boot sequence you
want to interrupt.

Play around with different baud rates, trial and error, unfortunately.

1 Like

The problem was not the baud rate. I testet this settings: „screen /dev/ttyS0 115200,cs7“ and now it works.

But it was not possible to type in tpl. So I testet something different. I bootet again, with´the WPS-Button pushed, and then it should be possible to get a file via ftfp

haven't tried screen in that way before, always use minicom or putty, if in Win :wink:

Yes, the TFTP looks like it'll work, and you have all the info you need right there,
IPs and expected file name.

let us know if TFTP works, then the wiki might need an update.

I had success. When You know how it works, it is quite easy.

What I did:
-connect the Router via a switch with a Windows Computer
-installed tftpd64 as portable version
-set computer IP at (sub
-rename the SW (openwrt 17.01) to „mr3020v1_tp_recovery.bin“ and put in the same folder like tftpd64.exe
-open tftpd64, check the path, set the correct ip
-push/hold the WPS button on the router and plug it in
-lay back and look on screen how it works, it reebots itself and then the router accessible on the ip

The serial connection is not necessary for this, but interessting to look at.

It looks like the guide decribed on openwrt wiki called Bootloader Recovery. But I have a V1, and the IP is different.

Thanks for the help.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.