TP-Link EAP245 V3 bad file even after cliclientd stopcs

Hey Folks!
I tried to flash my EAP 245 V3...
after I logged into SSH and done cliclientd stopcs and even got success after reply my software version is 2.7.0 i got the error please check firmware file.
I used the file.

please help

Just a quick check before I dive deeper into this, did you try renaming the firmware file to something short like openwrt.bin? The long filename may be an issue for the TP-Link firmware.

Yes of course I named it firmware.bin I also reset the device completely and tried it again same error occurs

This is what I done.
SSH into tplink send the command cliclientd getting success as return try to upload the firmware with the name firmware.bin and getting check firmware file

By the way is there any chance to get root access via SSH? I only need to edit the iptables then I don't need openwrt when it's not working.

I figure I'd ask since you didn't mention it in your opening post.

There is another topic from someone running 2.20.0 who has no issues installing the firmware. So since 2.3.0 to 2.20.0 work, I would think 2.7 should also work.

Could you specify which regional version of the access point/firmware you have? I know there are issues with flashing the firmware on Canadian models, so perhaps yours also has additional checks that aren't in the "universal" firmware.

To my knowledge, nobody's been able to figure out the root password, or another way to obtain a root shell on these devices.

1 Like

Continuing the discussion from TP-Link EAP245 V3 bad file even after cliclientd stopcs:

I'm from Germany

Oh my bad I have 225 v3 not 245 I will try it later again must done some work now

So I now flashed the EAP225 v3 snapshot done everything like the instructions. After updating the tplink was not reachable on the old ip Adress or

Now I restarted my router and the tplink and I don't have a connection via lan on my PC the network named now network 2 so I have no ethernet connection and the TP link is not reachable I cannot even access my router page (Vodafone station a German ISP)

If your default network is, you router won't know where to send packets meant for (the OpenWrt device).
The OpenWrt device should be at on a newly flashed device, but it will also run a DHCP server. So if your pc requests a new address as you reboot your ISP's modem, you might end up with an address in the subnet.

The safest way to set up a new OpenWrt device, is to give your PC a fixed address in the subnet, and make sure your PC and the OpenWrt device are isolated from the rest of your network.

1 Like

Alright I got it now I can access the openwrt device via SSH. But I don't have any web panel so far. I cannot turn off the dhcp from my isp router

Also the openwrt device doesn't have a internet connection yet


snapshots do not contain LuCI GUI by default. It needs to be installed by the user.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.