Stock firmware complains with "bad file" when installing on TP-Link EAP245 V3

Hi all,

I am an happy OpenWRT user since years, on several devices. As I needed an access point, I selected a TP-Link EAP245 V3 just because it was supported by OpenWRT since a few months.

The device arrived today and I tried to install the latest squashfs-factory.bin file I found for my device, using the upgrade firmware option from the web interface of the stock firmware.

It failed with a "bad file" error. I checked the downloaded file was correct using the sha256sum, it is OK.

I tried to redo the process from various versions of the stock firmware, and always got the same error. The device was pre-installed with a version 2.21, I tried to put first the latest version from TP-Link (5.0) and then downgrading to an aloder version (2.20). Flashing the official TP-Link firmware always worked, but flashing OpenWRT always failed.

I guess this may have something to do with signature checks, but am not sure and don't know how to work around this check.

You can probably use TFTP, even though its undocumented in

also read Adding OpenWrt support for TP-Link EAP245

Thanks for the advice. Unfortunately, the thread seems to say that tftp was not possible and that signatures are also checked.

I tried to run wireshark during the device boot process, but found nothing. The first packets from the device are sent quite late and are UDP packets with json-like data describing the device (version, MAC, type, device info, firmware version...). I guess this is for the Omada controllers. The keep being sent minutes after the boot, so probably not related to tftp at all.

And I assume you did

To install OpenWrt, you should have a TP-Link firmware installed with version 2.3.0 
or higher. If this is not the case, you will need to upgrade first. All recent firmware 
versions (up to at least 2.20.0) can disable firmware signature verification to flash 
OpenWrt. Installating OpenWrt is then done as follows:

* ssh into target device and run `cliclientd stopcs`

* upload OpenWrt factory.bin image via web interface. If the filename is too long, you can rename this file to anything shorter, e.g. “openwrt.bin”.

Stupid me!

I read "when done" instead of "then done", so somehow assumed the command was to be
passed on openwrt after installation. I should have read more carefully.

This worked.
Thanks a lot for your help and sorry for bothering you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.